通达信秒杀一切妖股指标公式源码,一线定乾坤指标公式

通达信秒杀一切妖股指标公式源码,一线定乾坤指标公式

通达信秒杀一切妖股指标公式源码,一线定乾坤指标公式

{百底公式1}
{AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);
BA:=EMA(AB,5);
顶1:=REFDATE(REF(HHV(H,100),5),DATE);
底1:=REFDATE(REF(LLV(L,100),5),DATE);
中1:=((顶1)+(底1))/2;
顶:IF(AB>0 AND AB-BA<=0,顶1,顶1),COLOR00FF00;
中:IF(AB>0 AND AB-BA<=0,中1,中1),COLORWHITE;
底:IF(AB>0 AND AB-BA<=0,底1,底1),COLORYELLOW;
DRAWTEXT(ISLASTBAR,(顶),STRCAT('',CON2STR(顶,2))),COLORWHITE;
DRAWTEXT(ISLASTBAR,(中),STRCAT('',CON2STR(中,2))),COLORWHITE;
DRAWTEXT(ISLASTBAR,(底),STRCAT('',CON2STR(底,2))),COLORWHITE;}
{百底公式2}
N:100 NODRAW ;
高:IF(CURRBARSCOUNT<=N,CONST(HHV(H,N)),DRAWNULL),COLORGREEN ;
低:IF(CURRBARSCOUNT<=N,CONST(LLV(L,N)),DRAWNULL),COLORYELLOW;
NOTEXT中:低+(高-低)/2 COLORWHITE;
{涨幅:(C-低)/低*100 NODRAW COLORFF00FF;}
涨幅:((C-低)/(高-低))*100 NODRAW COLORFF00FF;
涨天数:LLVBARS(L,100)COLORWHITE NODRAW;
{跌幅:((C-高)/高)*100 NODRAW COLORD9D919;};
跌幅:((C-高)/(高-低))*100 NODRAW COLORD9D919;
跌天数:HHVBARS(H,100)COLORWHITE NODRAW;
DRAWTEXT(ISLASTBAR,(高-(高-低)/50),STRCAT('',CON2STR(高-(高-低)/50,2))),COLORWHITE;
DRAWTEXT(ISLASTBAR,(NOTEXT中),STRCAT('',CON2STR(NOTEXT中,2))),COLORWHITE;
DRAWTEXT(ISLASTBAR,(低),STRCAT('',CON2STR(低,2))),COLORWHITE;
MA5:MA(C,5),COLORYELLOW;
NOTEXT5:IF((C<=MA5 OR MA5<=REF(MA5,1)),MA5,DRAWNULL),COLORFFFF00;
振幅:((高-低)/低)*100 NODRAW COLORGREEN;
均周月:INBLOCK('均周')AND INBLOCK('均月') COLORWHITE NODRAW;
逃周月:INBLOCK('逃周')AND INBLOCK('逃月')NODRAW COLORYELLOW;
{VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,'高抛'),COLORFFFFFF;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),'低吸'),COLORYELLOW;};
{百底距:=((C-低)/低)*100;
XG1:=BETWEEN(C,低,低*(1+0.03));
盘整天:BARSLASTCOUNT(XG1)NODRAW COLORYELLOW;}
{上涨值:=MA((H+REF(L,1))/2,3);
买进高点:=MA((H+REF(H,1))/2,3);
VAR1:=((O+H+L+2*C)/5)*2-L;
突破买入值:=MA(VAR1,3);{LSS轴点突破买入值}
{下跌值:=MA((REF(H,1)+L)/2,3);
卖出低点:=MA((REF(L,1)+L)/2,3);
VAR2:=((O+H+L+2*C)/5)*2-H;
突破卖出值:=MA(VAR2,3);
次日卖出点:=(上涨值+买进高点+突破买入值+H)/4;
次日买入点:=(下跌值+卖出低点+突破卖出值+L)/4;
均价:=(2*C+L+H/4);
买入价:IF(均价/REF(均价,1)>1,次日买入点*1.01,次日买入点)COLORWHITE NODRAW;
次低价:IF(均价/REF(均价,1)>1,次日买入点/1.0382,次日买入点)NODRAW COLORYELLOW;
卖出价:IF(均价/REF(均价,1)>1,次日卖出点*1.0191,次日卖出点)NODRAW;
必卖价:IF(均价/REF(均价,1)>1,次日卖出点*1.05,次日卖出点)COLORD9D919 NODRAW;}
{AC:=REF(C,1);
涨停K线:=IF((C-AC)*100/AC>=(10-0.01*100/AC),1,0);
跌停K线:=IF((AC-C)*100/AC>=(10-0.01*100/AC),1,0);
STICKLINE(涨停K线,OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(跌停K线,OPEN,CLOSE,2.5,0),COLORED9564;}
{涨停颜色粉色,完美区分20%10%5%,创业板20200823前10%照样变色}
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
XA_1:=IF(DATE<=1200823,1,0);
STICKLINE((C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,3,0),COLORYELLOW;
STICKLINE((C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,3,0),COLORED9564;
STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,3,0),COLORYELLOW;
STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,3,0),COLORED9564;
{STICKLINE((H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1),H,MAX(C,O),0.1,0),COLORYELLOW;{涨停后回落}
{STICKLINE((L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1),L,MIN(C,O),0.1,0),COLORED9564;{跌停后回升}
{Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,10,0,STRCAT(Z3,GNBLOCK)),COLORWHITE;}
{DRAWTEXT_FIX(1,0.00,0.00,0,'主题投资:')COLORYELLOW;
DRAWTEXT_FIX(1,0.06,0.00,0,EXTERNSTR(0,1))COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.06,0,'主营业务:')COLORWHITE;
DRAWTEXT_FIX(1,0.06,0.06,0,EXTERNSTR(0,2))COLORWHITE;
DRAWTEXT_FIX(1,0.00,0.12,0,'公司亮点:')COLORYELLOW;
DRAWTEXT_FIX(1,0.06,0.12,0,EXTERNSTR(0,3))COLORYELLOW; }
{流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;}
{涨停统计}
{涨停:=CLOSE/REF(CLOSE,1)>=1.095;
ZTCS:=COUNT(涨停,BARSSINCE(涨停)+1);}
{DRAWNUMBER(涨停,HIGH*1.04,ZTCS),COLORYELLOW;}
{GZT1:=STRCAT(' 共涨停: ',CON2STR(ZTCS,0));
GZT2:=STRCAT(GZT1,'次');
SSTS1:=STRCAT(' 上市: ',CON2STR(FINANCE(42),0));
SSTS2:=STRCAT(SSTS1,'天');
NTZZT1:=STRCAT(' 距今:',CON2STR(CONST(BARSLAST(涨停)),0));
NTZZT2:=STRCAT(NTZZT1,'天有涨停');
ZTTJ1:=STRCAT(SSTS2,GZT2);
ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);
ZTTJ:=STRCAT('涨停统计:',ZTTJ2);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.18,0,ZTTJ),COLORWHITE;};
{精彩内容尽在中金指南,欢迎及时关注中金指南通达信指标公式大全 www.zjznw.com}

相关文章