通达信macd+kdj+rsi三合一顶底背离指标公式 抄底逃顶指标

来源:中金指南

macd+kdj+rsi三合一顶底背离指标公式怎么看

通达信macd+kdj+rsi三合一顶底背离指标公式 抄底逃顶指标

macd+kdj+rsi三合一顶底背离指标公式,如上图位水平0轴下方为弱势,由下向上发出红柱此时代表牛股开始向上攻击,同时下方MACD线形成金叉开始出现红色彩带,这是积极的买进信号。上涨途中出现死叉短线宜卖出为佳。

macd+kdj+rsi三合一顶底背离指标公式源码

DIFF1:EMA(CLOSE,12) - EMA(CLOSE,26);

DEA1 :EMA(DIFF1,9);

DIFF77:= EMA(CLOSE,12) - EMA(CLOSE,26);

DEA77:= EMA(DIFF77,9);

牛股攻击 : 2*(DIFF77-DEA77), COLORSTICK;

STICKLINE(牛股攻击>REF(牛股攻击,1) AND DIFF77>DEA77,牛股攻击,0,3,0),COLORRED;

STICKLINE(牛股攻击>REF(牛股攻击,1) AND DIFF77>DEA77,牛股攻击,0,1,0),COLORYELLOW;

DRAWBAND(DEA1,DRAWNULL,DIFF1,RGB(250,0,0));

DIFF:DIFF1,COLORWHITE;

DEA:DEA1,COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);

A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);

C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));

D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));

C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));

D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));

MACD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;

KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;

RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;

MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;

KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;

RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;

STICKLINE(B1>0,-0.04,0,3,0),COLORRED,LINETHICK3;

STICKLINE(B2>0,-0.04,0,3,0),COLORFF00FF,LINETHICK5;

STICKLINE(B3>0,-0.04,0,3,0),COLORYELLOW,LINETHICK5;

STICKLINE(D1>0,0.04,0,3,0),COLOR00FF00,LINETHICK5;

STICKLINE(D2>0,0.04,0,3,0),COLORFFCC66,LINETHICK5;

STICKLINE(D3>0,0.04,0,3,0),COLORWHITE,LINETHICK5;

{精彩内容尽在中金指南,欢迎及时关注中金指南通达信公式大全 www.zjznw.com}

相关文章