通达信红绿macd顶底背离指标公式 神马macd二次金叉指标公式

来源:中金指南

红绿macd顶底背离指标公式怎么看

通达信红绿macd顶底背离指标公式 神马macd二次金叉指标公式

红绿macd顶底背离指标,如上图,金叉红色+大红柱低位出现是发出的积极买入信号,高位绿色箭头是卖出信号,低位金叉和二次金叉同属买入信号。

红绿macd顶底背离指标公式源码

MACD1:=12;

MACD2:=26;

MACD3:=9;

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA),COLORSTICK;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

一金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=1,21)=1;

STICKLINE(一金叉,0,0.1,3,0),COLOR0000FF;

DRAWTEXT(一金叉,-0.095,'一金叉红色'),COLOR0000FF;

二金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二金叉,0,0.10,3,0),COLORLIRED;

DRAWTEXT(二金叉,0.23,'二次金叉淡红色'),COLORLIRED;

三金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,28)=1;

STICKLINE(三金叉,0,0.1,3,0),COLORLIMAGENTA;

DRAWTEXT(三金叉,0.28,'三次金叉洋红色'),COLORLIMAGENTA;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=(REF(L,A1+1)>L OR REF(C,A1+1)>C) AND (L,DIFF)>REF((L,DIFF),A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,-0.1,5,0),COLORYELLOW;

DRAWTEXT(底背离,DEA,'底背离')COLORYELLOW;

DRAWLINE(A1=0,DEA,底背离,DEA,0),COLOR0000FF,LINETHICK3;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=(REF(C,A2+1)<C OR REF(H,A2+1)<H) AND REF((H,DIFF),A2+1)>(H,DIFF) AND CROSS(DEA,DIFF);

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK3;

STICKLINE(顶背离,0,0.1,6,0),COLORCYAN;

DRAWTEXT(顶背离,DEA,'顶背离')COLORCYAN;

IF(DIFF>DEA,DIFF,DRAWNULL),LINETHICK2;

IF(DEA>REF(DEA,1) AND DIFF>DEA,DEA,DRAWNULL),COLORYELLOW,LINETHICK2;

DIF:EMA(CLOSE,MACD1)-EMA(CLOSE,MACD2);

DRAWICON(CROSS(DIF,DEA),DIF,1);

DRAWICON(CROSS(DEA,DIF),DEA,2);

{以上通达信公式你们学会怎么用了吗,如果你还想了解更多更多通达信公式指标,欢迎及时关注中金指南网}

相关文章