通达信kdj指标超买超卖区共振指标公式 超买指标源码

来源:中金指南

kdj指标超买超卖区共振指标公式

通达信kdj指标超买超卖区共振指标公式 超买指标源码

超买超卖区共振指标,如上图,该指标分为超买超卖、严重超买超卖,高位属于超买区即逢高卖出,低位属于超卖区逢低可择机建仓。

kdj指标超买超卖区共振指标公式源码

SJ:=1;

N:=15;

M1:=5;

M2:=3;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K9:=SMA(RSV,M1,1);

D9:=SMA(K9,M2,1);

J:=3*K9-2*D9;

RK:=MA(K9,15),LINETHICK1;

RD:=MA(D9,15),LINETHICK1;

RJ:=MA(J,15),LINETHICK1;

{DRAWTEXT(CROSS(RK,RD)&&RD<20*SJ,RK*0.80,'多'),COLORRED;

DRAWTEXT(CROSS(RD,RK)&&RD*SJ>80,78,'空'),COLORGREEN,DRAWABOVE;}

N8:=80;

M18:=3;

M28:=3;

RSV8:=(CLOSE-LLV(LOW,N8))/(HHV(HIGH,N8)-LLV(LOW,N8))*100;

K98:=SMA(RSV8,M18,1);

D98:=SMA(K98,M28,1);

J8:=3*K98-2*D98;

RK8:=MA(K98,80),LINETHICK1;

RD8:=MA(D98,80),LINETHICK1;

RJ8:=MA(J8,80),LINETHICK1;

{DRAWTEXT(CROSS(RK8,RD8)&&RD8<20*SJ,RK8*0.80,'准多'),COLORFF00FF;

DRAWTEXT(CROSS(RD8,RK8)&&RD8*SJ>80,78,'准空'),COLORFFFF00,DRAWABOVE;}

VAR1:=((CLOSE - LLV(LOW,15))/(HHV(HIGH,15) - LLV(LOW,15)))*(100);

VAR2:=REVERSE(VAR1);

VAR3:=SMA(VAR1,5,1);

K:=SMA(VAR3,3,1);

D:=SMA(K,3,1);

STICKLINE((K*SJ >= D),K,D,2,0),COLORRED;

STICKLINE((K <= D*SJ),K,D,2,0),COLOR008800;

{中轴线:50,COLORWHITE,NODRAW;}

严重超买:100*SJ,COLORRED,DOTLINE;

超买:80,COLORRED,DOTLINE;

超卖:20,COLOR00FF00,DOTLINE;

严重超卖:0*SJ,COLOR00FF00,DOTLINE;

{KF:=(EMA(CLOSE,21)-EMA(CLOSE,3))/2*0.95;

DF:=(EMA(CLOSE,3)-EMA(CLOSE,21))/2*0.95;

DRAWTEXT(DF*SJ>=KF,9*SJ,'大'),COLORRED;

DRAWTEXT(KF*SJ>DF*SJ,91,'大'),COLORCYAN;

MA888:=EMA(C,2);

战士看多空线:=(MA(CLOSE,27)+MA(CLOSE,34)+MA(CLOSE,41)+MA(CLOSE,50))/4,COLOR00FFFF,LINETHICK3;

DRAWTEXT(MA888*SJ>=战士看多空线,15,'中'),COLORRED;

DRAWTEXT(MA888<战士看多空线*SJ,85,'中'),COLORCYAN;}

VAR18:=((CLOSE - LLV(LOW,80))/(HHV(HIGH,80) - LLV(LOW,80)))*(100);

VAR28:=REVERSE(VAR18);

VAR38:=SMA(VAR18,3,1);

K8:=SMA(VAR38,3,1);

D8:=SMA(K8,3,1);

STICKLINE((K8*SJ >= D8),K8,D8,2,0),COLORFF00FF;

STICKLINE((K8 <= D8*SJ),K8,D8,2,0),COLORFFFF00;

{DRAWTEXT(CROSS(D,D8)&&D<20,D*0.80,'稳多'),COLORRED;

XA1:=D8<D AND D>20 AND D8>20;

XA2:=BARSLAST(CROSS(D,D8)&&D<20);

XA3:=COUNT(XA1,XA2);

DRAWTEXT(XA3 AND REF(XA3,1)<1,D8*0.80,'稳健多'),COLORRED;

DRAWTEXT(CROSS(D8,D)&&D>80,D*1.05,'稳空'),COLORGREEN;

X1:=D8>D AND D<80 AND D8<80;

X2:=BARSLAST(CROSS(D8,D)&&D>80);

X3:=COUNT(X1,X2);

DRAWTEXT(X3 AND REF(X3,1)<1,D8*1.05,'稳健空'),COLORGREEN;}

以上关于kdj指标超买超卖区共振指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南网

相关文章