通达信kdj指标买入点公式_优化kdj买卖指标公式

来源:中金指南网

指标公式用法

kdj准备抄底建仓指标公式,白柱或者白柱+蓝柱高位卖出,红柱+准备开始建仓。kdj金叉做多,死叉卖出。

指标公式案例

通达信kdj指标买入点公式_优化kdj买卖指标公式

指标公式源码

N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
N1:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:8,COLORGREEN,LINETHICK0;
上升: IF(CROSS(VAR1,VAR2),80,0),STICK,COLOR0000CC;
专吸: IF(VAR1<=8,25,0),STICK,COLORWHITE;
DRAWTEXT(CROSS(VAR1,VAR2),80,'准备'),COLOR00FFFF;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓: IF((VARO7<10),-30,-10) ,COLOR00CCFF,LINETHICK1;
0,LINETHICK2 ,COLORFFCC00;
底线:10,COLOR9F9F5F;
顶线:92,COLOR9F9F5F;
BB:=IF(BARSLAST(CROSS(K,RSV))>=3 AND CROSS(RSV,K) AND K<30,20,0);
STICKLINE(BB,0,20,2.8,0),COLOR0000BB;
AA:=IF(BARSLAST(CROSS(RSV,K))>=4 AND CROSS(K,RSV) AND RSV>50,20,0);
STICKLINE(AA,80,100,2.8,0),COLORD8D8D8;
下线:30,COLOR9F9F5F,DOTLINE;
上线:70,COLOR9F9F5F,DOTLINE;
CC:=IF(BARSLAST(CROSS(K,RSV))>=1 AND CROSS(RSV,K) AND K<40,20,0);
STICKLINE(CC,10,30,2.8,0),COLORFF1CAE;
QQ:=IF(BARSLAST(CROSS(RSV,K))>=2 AND CROSS(K,RSV) AND RSV>70,20,0);
STICKLINE(QQ,70,90,2.8,0),COLORFF2400;
K1:SMA(RSV,3,1),COLORF580F5,LINETHICK1;
D1:SMA(K,3,1),COLORCCDD33,LINETHICK1;

指标公式动态翻译

N赋值:9
M1赋值:3
M2赋值:3
RSV赋值:(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
输出K:RSV的M1日[1日权重]移动平均
输出D:K的M2日[1日权重]移动平均
输出J:3*K-2*D
N1赋值:5
输出VAR1:4*(收盘价-N1日内最低价的最低值)/(N1日内最高价的最高值-N1日内最低价的最低值)*100的5日[1日权重]移动平均-3*(收盘价-N1日内最低价的最低值)/(N1日内最高价的最高值-N1日内最低价的最低值)*100的5日[1日权重]移动平均的3.2日[1日权重]移动平均,画黄色,线宽为0
输出VAR2:8,画绿色,线宽为0
输出上升: 如果VAR1上穿VAR2,返回80,否则返回0,STICK,COLOR0000CC
输出专吸: 如果VAR1<=8,返回25,否则返回0,STICK,画白色
当满足条件VAR1上穿VAR2时,在80位置书写文字,COLOR00FFFF
VARO5赋值:27日内最低价的最低值
VARO6赋值:34日内最高价的最高值
VARO7赋值:(收盘价-VARO5)/(VARO6-VARO5)*4的4日指数移动平均*25
输出建仓: 如果(VARO7<10),返回-30,否则返回-10 ,COLOR00CCFF,线宽为1
0,线宽为2 ,COLORFFCC00
输出底线:10,COLOR9F9F5F
输出顶线:92,COLOR9F9F5F
BB赋值:如果上次K上穿RSV距今天数>=3ANDCROSS(RSV,K)ANDK<30,返回20,否则返回0
当满足条件BB时,在0和20位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR0000BB
AA赋值:如果上次RSV上穿K距今天数>=4ANDCROSS(K,RSV)ANDRSV>50,返回20,否则返回0
当满足条件AA时,在80和100位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLORD8D8D8
输出下线:30,COLOR9F9F5F,DOTLINE
输出上线:70,COLOR9F9F5F,DOTLINE
CC赋值:如果上次K上穿RSV距今天数>=1ANDCROSS(RSV,K)ANDK<40,返回20,否则返回0
当满足条件CC时,在10和30位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLORFF1CAE
QQ赋值:如果上次RSV上穿K距今天数>=2ANDCROSS(K,RSV)ANDRSV>70,返回20,否则返回0
当满足条件QQ时,在70和90位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLORFF2400
输出K1:RSV的3日[1日权重]移动平均,COLORF580F5,线宽为1
输出D1:K的3日[1日权重]移动平均,COLORCCDD33,线宽为1
 

以上关于kdj指标买入点公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章