通达信主力资金博弈指标公式_神奇止损线指标

来源:中金指南网

指标公式用法

水平面博弈指标,黄线表示水平面线、绿线表示停损线。股价上穿水平面线积极建仓做多,股价跌破水平面线要注意减仓或出局观望。跌破停损线必须全部清仓,严格执行。

指标公式案例

通达信主力资金博弈指标公式_神奇止损线指标

指标公式源码

B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损下限:=IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2),COLORWHITE,LINETHICK1,POINTDOT;
SNAKEA1:=HHV(MA(B2,1),13),COLORYELLOW;
X1:=SNAKEA1;
X2:=IF(SNAKEA1<=B2,SNAKEA1,IF(B2>SMA2,B2,B2));{最后一个B2用SMA2}
{DRAWBAND(X1,RGB(64,64,196),X2,RGB(64,64,64));}
DRAWBAND(SNAKEA1,RGB(64,64,196),MIN(停损下限,L),RGB(64,64,64));
MIN(停损下限,L),COLORWHITE,LINETHICK1;
停损:停损下限,COLORGREEN,LINETHICK1;

{IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK4;}
SNAKEA:=SNAKEA1;
水平面:SNAKEA,COLORYELLOW,LINETHICK1;
IF (SNAKEA1<=B2,B2,DRAWNULL),COLORYELLOW,LINETHICK2;
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
{STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;
STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA,SMA2,0,0),COLORBLUE;}
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);
{STICKLINE((C>=O),OPEN,LOW,0,0),COLOR0726CA;
STICKLINE((C>=O),CLOSE,HIGH,0,0),COLOR0726CA;
STICKLINE((C<O),CLOSE,LOW,0,0),COLORDE9100;
STICKLINE((C<O),OPEN,HIGH,0,0),COLORDE9100;
STICKLINE((C<O),CLOSE,OPEN,2.5,0),COLORFFCC00;
STICKLINE((C<O),CLOSE,OPEN,1.5,0),COLORFFFF00;
STICKLINE((C>O),CLOSE,OPEN,2,0),COLOR0754E9;
STICKLINE((C>O),CLOSE,OPEN,1.5,0),COLOR076EF3;
STICKLINE((C>O),CLOSE,OPEN,1,0),COLOR077BF3;}
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
{STICKLINE(VAR1B,O,O+(C-O)/3,3,0),COLOR10D0FF;}
STICKLINE(VAR1B,O,O+(C-O)/3,3,0),COLOR005555;
STICKLINE(VAR1B,O,O+(C-O)/3,2.5,0),COLOR006565;
STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR007575;
STICKLINE(VAR1B,O,O+(C-O)/3,1.5,0),COLOR008585;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR009595;
STICKLINE(VAR1B,O,O+(C-O)/3,0.5,0),COLOR00A5A5;
STICKLINE(VAR1B,O,O+(C-O)/3,0,0),COLOR00B5B5;
{STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;}
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,O,O+(C-O)/3,3,0),COLOR005500;
STICKLINE(AA,O,O+(C-O)/3,2.5,0),COLOR006500;
STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR007500;
STICKLINE(AA,O,O+(C-O)/3,1.5,0),COLOR008500;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR009500;
STICKLINE(AA,O,O+(C-O)/3,0.5,0),COLOR00A500;
STICKLINE(AA,O,O+(C-O)/3,0,0),COLOR00B500;
{STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;}
A13:=EMA(CLOSE,55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,3);
A16:=EMA(A15,3);
A17:=(HIGH + LOW) / 5;
A18:=(MA(A17,4)) - (MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0,A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,1);
A24:=REF(A20,1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);
A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);
A30:=A28 AND ((COUNT(A28,A21)) = 1);
A31:=A29 AND ((COUNT(A29,A22)) = 1);
A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));
DRAWTEXT(A32,SMA2*0.99,'←═≒∝'),COLORYELLOW;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
BBC:=FORCAST(BBA,3);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
IF (LIFENGCYC,L*0.95,DRAWNULL),POINTDOT,LINETHICK4,COLORWHITE;
{STICKLINE(LIFENGCYC,BBC,0.5,6,0);}
{BBD:(UPPER+LOWER)/2*(C-UPPER);};

指标公式动态翻译

B1赋值:收盘价的1日简单移动平均
B2赋值:B1的2日[1日权重]移动平均的2日[1日权重]移动平均的2日[1日权重]移动平均
SMA2赋值:B2的3日简单移动平均
停损下限赋值:如果3日内B2的8日简单移动平均的最低值<B2,返回3日内B2的8日简单移动平均的最低值,否则返回B2,画白色,线宽为1,POINTDOT
SNAKEA1赋值:13日内B2的1日简单移动平均的最高值,画黄色
X1赋值:SNAKEA1
X2赋值:如果SNAKEA1<=B2,返回SNAKEA1,否则返回如果B2>SMA2,返回B2,否则返回B2
画带状线
停损下限和最低价的较小值,画白色,线宽为1
输出停损:停损下限,画绿色,线宽为1
SNAKEA赋值:SNAKEA1
输出水平面:SNAKEA,画黄色,线宽为1
如果SNAKEA1<=B2,返回B2,否则返回无效数,画黄色,线宽为2
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000045
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR000065
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000085
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000A5
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000C5
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000E5
当满足条件收盘价>=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000F5
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR353500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR454500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR555500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR656500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR757500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR858500
当满足条件收阴线时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR959500
VAR1A赋值:(2*收盘价+最高价+最低价)/4
VAR2A赋值:VAR1A的7日简单移动平均
VAR3A赋值:VAR2A-VAR1A的7/2日简单移动平均<0
VAR4A赋值:VAR2A-VAR1A的7/2日简单移动平均>0
VAR5A赋值:上次VAR3A距今天数
VAR6A赋值:0-上次VAR4A距今天数
VAR7A赋值:如果VAR3A<=0,返回VAR5A,否则返回VAR6A
VAR11A赋值:(收盘价*2+最高价+最低价)/4
VAR21A赋值:VAR11A的13日指数移动平均-VAR11A的34日指数移动平均
VAR31A赋值:VAR21A的5日指数移动平均
VAR2赋值:((收盘价 > 1日前的收盘价) AND (收盘价 > 2日前的收盘价))
VAR3赋值:((1日前的VAR2 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR4赋值:((1日前的VAR3 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR5赋值:((1日前的VAR4 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR6赋值:((1日前的VAR5 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR7赋值:((1日前的VAR6 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR8赋值:((1日前的VAR7 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR9赋值:((1日前的VAR8 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARA赋值:((1日前的VAR9 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VARB赋值:((1日前的VARA AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARC赋值:((1日前的VARB AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VARD赋值:((1日前的VARC AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARE赋值:((收盘价 < 1日前的收盘价) AND (收盘价 < 2日前的收盘价))
VARF赋值:((1日前的VARE AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR10赋值:((1日前的VARF AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR11赋值:((1日前的VAR10 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR12赋值:((1日前的VAR11 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR13赋值:((1日前的VAR12 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR14赋值:((1日前的VAR13 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR15赋值:((1日前的VAR14 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR16赋值:((1日前的VAR15 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR17赋值:((1日前的VAR16 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR18赋值:((1日前的VAR17 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR19赋值:((1日前的VAR18 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR1B赋值:(1日前的(((((((((((VAREORVARF)ORVAR10)ORVAR11)ORVAR12)ORVAR13)ORVAR14)ORVAR15)ORVAR16)ORVAR17)ORVAR18)ORVAR19) AND VAR2)
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR005555
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR006565
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR007575
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR008585
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR009595
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00A5A5
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00B5B5
AA赋值:(1日前的(((((((((((VAR2ORVAR3)ORVAR4)ORVAR5)ORVAR6)ORVAR7)ORVAR8)ORVAR9)ORVARA)ORVARB)ORVARC)ORVARD) AND VARE)
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR005500
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR006500
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR007500
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR008500
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR009500
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00A500
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00B500
A13赋值:收盘价的55日指数移动平均
A14赋值:收盘价的75日简单移动平均
A15赋值:A14的3日指数移动平均
A16赋值:A15的3日指数移动平均
A17赋值:(最高价 + 最低价) / 5
A18赋值:(A17的4日简单移动平均) - (A17的34日简单移动平均)
A19赋值:A18上穿0
A20赋值:0上穿A18
A21赋值:上次A19距今天数
A22赋值:上次A20距今天数
A23赋值:1日前的A19
A24赋值:1日前的A20
A25赋值:上次A23距今天数
A26赋值:上次A24距今天数
A27赋值:如果(A25<A26),返回(A25日前的(2日内最高价的最高值)),否则返回(A26日前的(2日内最低价的最低值))
A28赋值:(((1日前的收盘价) <= (1日前的A27)) AND (收盘价 > A27)) AND (A21 < A22)
A29赋值:(((1日前的收盘价) >= (1日前的A27)) AND (收盘价 < A27)) AND (A22 < A21)
A30赋值:A28 AND ((统计A21日中满足A28的天数) = 1)
A31赋值:A29 AND ((统计A22日中满足A29的天数) = 1)
A32赋值:A30 AND ((1日前的上次A31距今天数) < (1日前的上次A30距今天数))
A33赋值:A31 AND ((1日前的上次A31距今天数) > (1日前的上次A30距今天数))
当满足条件A32时,在SMA2*0.99位置书写文字,画黄色
AC赋值:成交额(元)/(成交量(手))
YY赋值:AC的13日简单移动平均
LLL赋值:(收盘价-YY)/YY*100
赋值: 收盘价的22日简单移动平均
UPPERC赋值: MIDC + 2*收盘价的22日估算标准差
LOWERC赋值: MIDC - 2*收盘价的22日估算标准差
BBA赋值:(收盘价-LOWERC)/(UPPERC-LOWERC)
BBC赋值:BBA的3日线性回归预测值
LIFENGCYC赋值:(1日前的LLL<-15 AND 1日前的BBA<0 AND LLL>1日前的LLL)
如果LIFENGCYC,返回最低价*0.95,否则返回无效数,POINTDOT,线宽为4,画白色
 

以上关于通达信主力资金博弈指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章