通达信k线加彩色柱状线指标公式_多空线指标怎么看

来源:中金指南网

指标公式用法

多空线指标公式,如图,黄金柱买入股票,蓝色柱卖出股票。紫色线代表多空线,股价站稳多空线买,跌破多空线卖出。

指标公式案例

通达信k线加彩色柱状线指标公式_多空线指标怎么看

指标公式源码

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;{红1}
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORFFCC66;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,1),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),5,2),COLOR00FF00{98FD};
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00C8FF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ECFF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10FFFF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORBLUE;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;
PMA:MA(C,5),COLORWHITE,LINETHICK2;
IF(PMA>REF(PMA,1),PMA,DRAWNULL),COLORRED,LINETHICK2;
IF(PMA<REF(PMA,1),PMA,DRAWNULL),COLORGREEN,LINETHICK2;
X:=(3*C+L+O+H)/6;
多空线: (20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK2;
{用法:黄托底买进,蓝压顶卖出。}
DD:=多空线<REF(多空线,1);
IF(DD,多空线,DRAWNULL),COLOR00FFFF,LINETHICK2;
A:=(PMA>多空线);
IF(A,多空线,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;

指标公式动态翻译

VAR1赋值:收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价
VAR2赋值:1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR3赋值:1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR4赋值:1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR5赋值:1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR6赋值:1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR7赋值:1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR8赋值:1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR9赋值:1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARA赋值:1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VARB赋值:1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARC赋值:1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
当满足条件VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC时,在收盘价和1日前的收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
VARD赋值:收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VARE赋值:1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARF赋值:1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR10赋值:1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR11赋值:1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR12赋值:1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR13赋值:1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR14赋值:1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR15赋值:1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR16赋值:1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR17赋值:1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR18赋值:1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
当满足条件VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18时,在收盘价和1日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFCC66
VAR19赋值:1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18 AND VAR1
当满足条件VAR19时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为4,1不为0则画空心柱.,画黄色
VAR1A赋值:1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC AND VARD
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为5,2不为0则画空心柱.,COLOR00FF00
当满足条件VAR19时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00C8FF
当满足条件VAR19时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR10ECFF
当满足条件VAR19时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR10FFFF
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00D900
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画蓝色
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR090FF2
输出PMA:收盘价的5日简单移动平均,画白色,线宽为2
如果PMA>1日前的PMA,返回PMA,否则返回无效数,画红色,线宽为2
如果PMA<1日前的PMA,返回PMA,否则返回无效数,画绿色,线宽为2
X赋值:(3*收盘价+最低价+开盘价+最高价)/6
输出多空线: (20*X+19*1日前的X+18*2日前的X+17*3日前的X+16*4日前的X+15*5日前的X+14*6日前的X+13*7日前的X+12*8日前的X+11*9日前的X+10*10日前的X+9*11日前的X+8*12日前的X+7*13日前的X+6*14日前的X+5*15日前的X+4*16日前的X+3*17日前的X+2*18日前的X+20日前的X)/210,COLORFF00FF,线宽为2
DD赋值:多空线<1日前的多空线
如果DD,返回多空线,否则返回无效数,COLOR00FFFF,线宽为2
A赋值:(PMA>多空线)
如果A,返回多空线,否则返回无效数,COLOR33FF33,POINTDOT,线宽为4
 

以上关于多空线指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章