整合优化macd通达信指标公式_macd顶背离选股公式

来源:中金指南网

指标公式用法

整合优化macd通达信指标公式,如上图,佛手出现即是买点,其他同macd指标用法相同,dif上穿dea绿色带变红色带行情由弱开始走强,积极跟随主力买进吃肉。

指标公式案例

整合优化macd通达信指标公式_macd顶背离选股公式

指标公式源码

DIF:(EMA(CLOSE,12) - EMA(CLOSE,26)),COLORRED,NODRAW;
DEA:EMA(DIF,9),COLOR00FFFF,NODRAW;
MACD:2*(DIF-DEA),NODRAW;
DIFK:=EMA(DIF,3);
DIFD:=EMA(DIFK,3);
DKK:4*DIF-3*DEA,COLORFF00FF,NODRAW;
DDD:EMA(DKK,5),COLOR2588FF,NODRAW;
TRLSX1:= MAX(MAX((HHV(DIF,13)-LLV(DIF,13)),ABS(REF(DIF,1)-HHV(DIF,13))),ABS(REF(DIF,1)-LLV(DIF,13)));
TRLSX2:=EMA(TRLSX1,13);
TRLSX3:=REF(DIF,1)-REF(TRLSX2,1);
支撑:HHV(TRLSX3,13),COLORFFFFFF,NODRAW;
RSV14:=(CLOSE - LLV(LOW,14))/(HHV(HIGH,14) - LLV(LOW,14))-0.5;
K14:=EMA(RSV14,3),COLORFF00FF,NODRAW;
D14:=EMA(K14,3),COLORGREEN,NODRAW;
J14:=3*K14-2*D14;
DRAWBAND(DIF,RGB(200,50,55),DEA,RGB(50,100,10));
MACDXG2:=REF(COUNT(DIF>0 AND MACD<0 AND MACD<REF(MACD,1),4)=4,1) AND MACD>REF(MACD,1);
STICKLINE(MACDXG2,MACD*1.2,0,2.8,0),COLORRED;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR000055;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR000099;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR0000BB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR888888;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLORBBBBBB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLORDDDDDD;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR3377AA;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR3388BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR4499CC;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLORFF3300;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLORFF5500;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLORFF7700;
STICKLINE(J14<-0.5,0,0.15,1.8,0),COLORFF00FF;
支撑,COLORFFFFFF;
IF(C>0,DIF,DRAWNULL),COLORRED,LINETHICK1;
IF(C>0,DEA,DRAWNULL),COLOR00FFFF,LINETHICK1;
IF(DEA<REF(DEA,1),DEA,DRAWNULL),COLORBE7F6F,LINETHICK1;
IF(DIF<=REF(DIF,1),DIF,DRAWNULL),COLORBLUE,LINETHICK1;
IF(C,DKK,DRAWNULL),COLORFF00FF,LINETHICK1;
IF(DKK<=REF(DKK,1),DKK,DRAWNULL),COLORCYAN,LINETHICK1;
IF(C,DDD,DRAWNULL),COLOR2255FF,LINETHICK1;
IF(DDD<=REF(DDD,1),DDD,DRAWNULL),COLOR33FF33,LINETHICK1;
KDJXG:=REF(COUNT(J14<REF(J14,1),5)>=3,1) AND REF(J14,1)<-0.4 AND J14>REF(J14,1);
DRAWICON(FILTER(KDJXG,3),MACD*1.2,11),COLORFF00EE;
准备介入点:=REF(CROSS(0,MACD),3) AND COUNT(DIF>0 AND MACD<REF(MACD,1),4)=4 ;
DRAWICON(准备介入点,0.05,9);

指标公式动态翻译

输出DIF:(收盘价的12日指数移动平均 - 收盘价的26日指数移动平均),画红色,NODRAW
输出DEA:DIF的9日指数移动平均,COLOR00FFFF,NODRAW
输出平滑异同平均:2*(DIF-DEA),NODRAW
DIFK赋值:DIF的3日指数移动平均
DIFD赋值:DIFK的3日指数移动平均
输出DKK:4*DIF-3*DEA,COLORFF00FF,NODRAW
输出DDD:DKK的5日指数移动平均,COLOR2588FF,NODRAW
TRLSX1赋值: (13日内DIF的最高值-13日内DIF的最低值)和1日前的DIF-13日内DIF的最高值的绝对值的较大值和1日前的DIF-13日内DIF的最低值的绝对值的较大值
TRLSX2赋值:TRLSX1的13日指数移动平均
TRLSX3赋值:1日前的DIF-1日前的TRLSX2
输出支撑:13日内TRLSX3的最高值,COLORFFFFFF,NODRAW
RSV14赋值:(收盘价 - 14日内最低价的最低值)/(14日内最高价的最高值 - 14日内最低价的最低值)-0.5
K14赋值:RSV14的3日指数移动平均,COLORFF00FF,NODRAW
D14赋值:K14的3日指数移动平均,画绿色,NODRAW
J14赋值:3*K14-2*D14
画带状线
MACDXG2赋值:1日前的统计4日中满足DIF>0ANDMACD<0ANDMACD<1日前的MACD的天数=4 AND MACD>1日前的MACD
当满足条件MACDXG2时,在MACD*1.2和0位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,画红色
当满足条件MACD>1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR000055
当满足条件MACD>1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为1.1,0不为0则画空心柱.,COLOR000099
当满足条件MACD>1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为0.6,0不为0则画空心柱.,COLOR0000BB
当满足条件MACD<=1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR888888
当满足条件MACD<=1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为1.1,0不为0则画空心柱.,COLORBBBBBB
当满足条件MACD<=1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为0.6,0不为0则画空心柱.,COLORDDDDDD
当满足条件MACD>1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR3377AA
当满足条件MACD>1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为1.1,0不为0则画空心柱.,COLOR3388BB
当满足条件MACD>1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为0.6,0不为0则画空心柱.,COLOR4499CC
当满足条件MACD<=1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLORFF3300
当满足条件MACD<=1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为1.1,0不为0则画空心柱.,COLORFF5500
当满足条件MACD<=1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为0.6,0不为0则画空心柱.,COLORFF7700
当满足条件J14<-0.5时,在0和0.15位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLORFF00FF
支撑,COLORFFFFFF
如果收盘价>0,返回DIF,否则返回无效数,画红色,线宽为1
如果收盘价>0,返回DEA,否则返回无效数,COLOR00FFFF,线宽为1
如果DEA<1日前的DEA,返回DEA,否则返回无效数,COLORBE7F6F,线宽为1
如果DIF<=1日前的DIF,返回DIF,否则返回无效数,画蓝色,线宽为1
如果收盘价,返回DKK,否则返回无效数,COLORFF00FF,线宽为1
如果DKK<=1日前的DKK,返回DKK,否则返回无效数,画青色,线宽为1
如果收盘价,返回DDD,否则返回无效数,COLOR2255FF,线宽为1
如果DDD<=1日前的DDD,返回DDD,否则返回无效数,COLOR33FF33,线宽为1
KDJXG赋值:1日前的统计5日中满足J14<1日前的J14的天数>=3 AND 1日前的J14<-0.4 AND J14>1日前的J14
当满足条件KDJXG的3日过滤时,在MACD*1.2位置画11号图标,COLORFF00EE
准备介入点赋值:3日前的0上穿MACD AND 统计4日中满足DIF>0ANDMACD<1日前的MACD的天数=4 
当满足条件准备介入点时,在0.05位置画9号图标
 

以上关于整合优化macd通达信指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章