通达信量能趋势指标公式_量能检测指标公式

来源:中金指南网

指标公式用法

通达信量能趋势指标公式,通过在副图中判断个股的量能强弱,红柱代表量能较为强势,蓝柱代表量能较弱。

指标公式案例

通达信量能趋势指标公式

指标公式源码

VOL,VOLSTICK;
股价:=VOL;
短3:=XMA(XMA(股价,3),3),LINETHICK0,COLORWHITE;
短5:=XMA(XMA(股价,5),5),LINETHICK0,COLORWHITE;
短6:=XMA(XMA(股价,6),6),LINETHICK0,COLORWHITE;
短7:=XMA(XMA(股价,8),8),LINETHICK0,COLORWHITE;
短8:=XMA(XMA(股价,10),10),LINETHICK0,COLORWHITE;
短9:=XMA(XMA(股价,12),12),LINETHICK0,COLORWHITE;
短中:=(短7+短8+短9+短3+短5+短6)/6,LINETHICK0,COLORWHITE;
短顶:=短中*1.35,LINETHICK0,COLORGREEN;
短底:=短中*0.65,LINETHICK0,COLORGREEN;
中1:=XMA(XMA(股价,16),16),LINETHICK0,COLORWHITE;
中2:=XMA(XMA(股价,19),19),LINETHICK0,COLORWHITE;
中3:=XMA(XMA(股价,22),22),LINETHICK0,COLORWHITE;
中4:=XMA(XMA(股价,25),25),LINETHICK0,COLORWHITE;
中5:=XMA(XMA(股价,28),28),LINETHICK0,COLORWHITE;
中6:=XMA(XMA(股价,31),31),LINETHICK0,COLORWHITE;
中中2:=(中1+中2+中3+中4+中5+中6)/6,LINETHICK0,COLORGREEN;
中顶2:=中中2*1.4,LINETHICK0,COLORGREEN;
中底2:=中中2*0.6,LINETHICK0,COLORGREEN;
中40:=XMA(XMA(股价,40),40),LINETHICK0;
中50:=XMA(XMA(股价,50),50),LINETHICK0;
中60:=XMA(XMA(股价,60),60),LINETHICK0;
中中3:=(中40+中50+中60)/3,LINETHICK0,COLORWHITE;
中顶3:=中中3*1.5,LINETHICK0,COLORRED;
中底3:=中中3*0.5,LINETHICK0,COLORRED;
长90:=XMA(XMA(股价,90),90),LINETHICK0,COLORWHITE;
长120:=XMA(XMA(股价,120),120),LINETHICK0,COLORWHITE;
长150:=XMA(XMA(股价,150),150),LINETHICK0,COLORWHITE;
长中:=(长90+长120+长150)/3,LINETHICK0,COLORYELLOW;
长顶:=长中*1.3,LINETHICK1,COLORWHITE;
长顶顶:=长中*1.8,LINETHICK1,COLORRED;
长底:=长中*0.5,LINETHICK1,COLORYELLOW;
MA短中:=EMA(短中,10),LINETHICK0,COLORWHITE;
MA中中2:=EMA(中中2,10),LINETHICK0,COLORGREEN;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1),NODRAW,COLORRED;
STICKLINE(V2>=1,0,VOL,2,0),COLORYELLOW;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:=VOL,VOLSTICK;
{没问题}

大底VOL:=短底<中底2 AND 中底2<中底3 AND 中底3<长底 AND MA(C,18)>=MA(C,50),LINETHICK5,COLORRED;
中底VOL:=短底<中底2 AND 中底2>中底3 AND 中底2<长底,LINETHICK2,COLORGREEN;
小底VOL:=短底<中底2 AND 中底2<中底3 AND 中底2>长底,LINETHICK1,COLORYELLOW;
STICKLINE(中中2>MA中中2,0,VOL,3,0),COLORFF00FF;{画粉柱}

STICKLINE(短中>MA短中,0,VOL,3,0),COLORRED;
STICKLINE(中中2<MA中中2,0,VOL,3,0),COLORFFFF00;
STICKLINE(V=LLV(V,55) AND 股价<长底,0,VOL,3,0),COLORYELLOW;
NOTEXT攻击量:EMA(V,60),COLORYELLOW;DRAWRECTREL(0,40,90,270,RGB(178,34,34));
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=5 ,0,0.1,0,' 短线量能判定:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=5 ,0,0.2,0,' 强'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=3 AND COUNT(V>EMA(V,60),7)<5,0,0.1,0,' 短线量能判定:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=3 AND COUNT(V>EMA(V,60),7)<5 ,0,0.1,0,' 中'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)<3 ,0,0.1,0,' 短线量能判定:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)<3 ,0,0.2,0,' 弱'),COLORGREEN;

指标公式动态翻译

成交量(手),VOLSTICK
股价赋值:成交量(手)
短3赋值:股价的3日偏移移动平均的3日偏移移动平均,线宽为0,画白色
短5赋值:股价的5日偏移移动平均的5日偏移移动平均,线宽为0,画白色
短6赋值:股价的6日偏移移动平均的6日偏移移动平均,线宽为0,画白色
短7赋值:股价的8日偏移移动平均的8日偏移移动平均,线宽为0,画白色
短8赋值:股价的10日偏移移动平均的10日偏移移动平均,线宽为0,画白色
短9赋值:股价的12日偏移移动平均的12日偏移移动平均,线宽为0,画白色
短中赋值:(短7+短8+短9+短3+短5+短6)/6,线宽为0,画白色
短顶赋值:短中*1.35,线宽为0,画绿色
短底赋值:短中*0.65,线宽为0,画绿色
中1赋值:股价的16日偏移移动平均的16日偏移移动平均,线宽为0,画白色
中2赋值:股价的19日偏移移动平均的19日偏移移动平均,线宽为0,画白色
中3赋值:股价的22日偏移移动平均的22日偏移移动平均,线宽为0,画白色
中4赋值:股价的25日偏移移动平均的25日偏移移动平均,线宽为0,画白色
中5赋值:股价的28日偏移移动平均的28日偏移移动平均,线宽为0,画白色
中6赋值:股价的31日偏移移动平均的31日偏移移动平均,线宽为0,画白色
中中2赋值:(中1+中2+中3+中4+中5+中6)/6,线宽为0,画绿色
中顶2赋值:中中2*1.4,线宽为0,画绿色
中底2赋值:中中2*0.6,线宽为0,画绿色
中40赋值:股价的40日偏移移动平均的40日偏移移动平均,线宽为0
中50赋值:股价的50日偏移移动平均的50日偏移移动平均,线宽为0
中60赋值:股价的60日偏移移动平均的60日偏移移动平均,线宽为0
中中3赋值:(中40+中50+中60)/3,线宽为0,画白色
中顶3赋值:中中3*1.5,线宽为0,画红色
中底3赋值:中中3*0.5,线宽为0,画红色
长90赋值:股价的90日偏移移动平均的90日偏移移动平均,线宽为0,画白色
长120赋值:股价的120日偏移移动平均的120日偏移移动平均,线宽为0,画白色
长150赋值:股价的150日偏移移动平均的150日偏移移动平均,线宽为0,画白色
长中赋值:(长90+长120+长150)/3,线宽为0,画黄色
长顶赋值:长中*1.3,线宽为1,画白色
长顶顶赋值:长中*1.8,线宽为1,画红色
长底赋值:长中*0.5,线宽为1,画黄色
MA短中赋值:短中的10日指数移动平均,线宽为0,画白色
MA中中2赋值:中中2的10日指数移动平均,线宽为0,画绿色
V2赋值:如果到最后交易的周期=1,返回成交量(手)*240/当前离开盘分钟数/1日前的成交量(手)-1,否则返回成交量(手)/1日前的成交量(手)-1,NODRAW,画红色
当满足条件V2>=1时,在0和成交量(手)位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
VVOL赋值:如果到最后交易的周期=1ANDPERIOD=5,返回成交量(手)*240/当前离开盘分钟数,否则返回无效数,NODRAW
当满足条件到最后交易的周期=1ANDPERIOD=5时,在VVOL和0位置之间画柱状线,宽度为-1,-1不为0则画空心柱.,COLOR00C0C0
VOLUME赋值:成交量(手),VOLSTICK
大底VOL赋值:短底<中底2 AND 中底2<中底3 AND 中底3<长底 AND 收盘价的18日简单移动平均>=收盘价的50日简单移动平均,线宽为5,画红色
中底VOL赋值:短底<中底2 AND 中底2>中底3 AND 中底2<长底,线宽为2,画绿色
小底VOL赋值:短底<中底2 AND 中底2<中底3 AND 中底2>长底,线宽为1,画黄色
当满足条件中中2>MA中中2时,在0和成交量(手)位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
当满足条件短中>MA短中时,在0和成交量(手)位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
当满足条件中中2<MA中中2时,在0和成交量(手)位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFFF00
当满足条件成交量(手)=55日内成交量(手)的最低值AND股价<长底时,在0和成交量(手)位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色
输出NOTEXT攻击量:成交量(手)的60日指数移动平均,画黄色
相对位置上画矩形
当满足条件到最后交易的周期=1ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)>=5时,在横轴0纵轴0.1位置书写文字,画黄色
当满足条件到最后交易的周期=1ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)>=5时,在横轴0纵轴0.2位置书写文字,画黄色
当满足条件到最后交易的周期=1ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)>=3ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)<5时,在横轴0纵轴0.1位置书写文字,画黄色
当满足条件到最后交易的周期=1ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)>=3ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)<5时,在横轴0纵轴0.1位置书写文字,画白色
当满足条件到最后交易的周期=1ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)<3时,在横轴0纵轴0.1位置书写文字,画黄色
当满足条件到最后交易的周期=1ANDCOUNT(成交量(手)>成交量(手)的60日指数移动平均,7)<3时,在横轴0纵轴0.2位置书写文字,画绿色
 

以上关于通达信量能趋势指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章