通达信九转序列指标公式_九转序列的使用技巧

来源:中金指南网

指标公式用法

通达信九转序列指标公式是一款由多个指标合体,以MACD为底部结构形成指标公式,包含九转序列、RSI底背离、底部结构形成、柱底背离以及顶背离提示。低位金叉看多,高位死叉看空。可以以九转序列来进入买卖操作,低位由1,2,3,4,...9买入,上涨区间由1,2,3,4,...9卖出。

指标公式案例

通达信九转序列指标公式_九转序列的使用技巧

指标公式源码

DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26)),COLORWHITE,LINETHICK1;
DEA:EMA(DIF,9),COLORYELLOW,LINETHICK1;
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.2,0),COLORRED;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.2,0),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.2,0),COLORBLUE;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0.2,0),COLORGREEN;
FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
FH5:=FH1 AND FH2 AND MACD<0.10;
二次翻红:=(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
低买:=CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;
加油:=CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;
DRAWICON(二次翻红,-0.05,1);
DRAWTEXT(二次翻红,-0.15,'↖翻红'),COLORRED;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;
DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW;
YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
W1:=C>REF(C,4);
NT:=BARSLASTCOUNT(W1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,MACD*1.02,VAR2STR(AY,0)),COLORLIRED;
DRAWTEXT(NT=9,MACD*1.02,'9'),COLORGREEN;
Q1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(Q1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,MACD*0.98,VAR2STR(AY1,0)),COLORGREEN;
DRAWTEXT(NT0=9,MACD*0.98,'9'),COLORRED;
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}

N2:=REF(BARSLAST(死叉),N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉的区间}

N3:=REF(BARSLAST(死叉),N2+N1+2),NODRAW;{倒数第三次死叉与倒数第二次死叉的区间}

CL1:=LLV(C,N1+1),NODRAW;{最近一次死叉后,最低收盘价}

DIFL1:=LLV(DIF,N1+1),NODRAW;
CL2:=REF(CL1,N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}

DIFL2:=REF(DIFL1,N1+1),NODRAW;
CL3:=REF(CL2,N1+1),NODRAW;{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}

DIFL3:=REF(DIFL2,N1+1),NODRAW;
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
底部钝化:=直接底背离 OR 隔峰底背离,NODRAW;
底背离:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),NODRAW;
STICKLINE(底部钝化,DIF,DEA,1,0),COLORRED;
DRAWTEXT(TFILTER(底背离,C<REF(CL1,1),1),DIF*0.98,'底部结构形成'),COLORMAGENTA;
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}

M2:=REF(BARSLAST(金叉),M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉的区间}

M3:=REF(BARSLAST(金叉),M2+M1+2),NODRAW;{倒数第三次金叉与倒数第二次金叉的区间}

CH1:=HHV(C,M1+1),NODRAW;{最近一次金叉后,最高收盘价}

DIFH1:=HHV(DIF,M1+1),NODRAW;
CH2:=REF(CH1,M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉之间的最高收盘价}

DIFH2:=REF(DIFH1,M1+1),NODRAW;
CH3:=REF(CH2,M1+1),NODRAW;{倒数第三次金叉与倒数第二次金叉之间的最高收盘价}

DIFH3:=REF(DIFH2,M1+1),NODRAW;
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
顶部钝化:=直接顶背离 OR 隔峰顶背离,NODRAW;
顶背离:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1)),NODRAW;
STICKLINE(顶部钝化,DIF,DEA,1,0),COLORGREEN;
DRAWTEXT(TFILTER(顶背离,C>REF(CH1,1),1),DIF*1.02,'顶部结构形成'),COLORMAGENTA;
DRAWICON(CROSS(DIF,DEA),DEA,36);
DRAWICON(CROSS(DEA,DIF),DEA,37);
MACDDIF:=IF(ABS(MACD)>ABS(DIF),MACD,DIF);
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,MACDDIF*1.1,39),COLORGREEN;
DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,MACDDIF*1.1,38),COLORRED;
启动点:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)

AND REF(MACD ,2)<REF(MACD ,3)

AND REF(MACD ,3)<REF(MACD ,4);
DRAWTEXT(启动点,MACD-0.1,'↑启动点'),COLORFF33FF;
GC:=IF(DIF>DEA,DIF,DRAWNULL)COLOR0099FF;
A1:=BARSLAST(REF(CROSS('MACD.DIF','MACD.DEA'),1));
B1:=REF(C,A1+1)>C AND REF('MACD.DIF',A1+1)<'MACD.DIF' AND CROSS('MACD.DIF','MACD.DEA');
DRAWICON(B1>0,LLV(DIF,60)*0.84,1);
DRAWTEXT(B1>0,LLV(DIF,60)*0.85,'MACD底背离'),COLOR9900FF;{MACD底背离}

MACD底背离:=B1>0 AND LLV(DIF,60)*0.85;
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWICON(D1>0,HHV(DIF,60)*0.84,2);
DRAWTEXT(D1>0,HHV(DIF,60)*0.85,'M顶背离'),COLOR00FF00;{MACD顶背离}

A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)> C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D") {AND "KDJ.J"<30};
DRAWICON(B2>0,LLV(DIF,60)*0.59,1);
DRAWTEXT(B2>0,LLV(DIF,60)*0.60,'K底背'),COLORFF33FF;{KDJ底背离}

K底背:=B2>0 AND LLV(DIF,60)*0.60;
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)> "KDJ.K" AND CROSS("KDJ.D","KDJ.K") {AND "KDJ.J">70};
DRAWICON(D2>0,HHV(DIF,60)*0.59,2);
DRAWTEXT(D2>0,HHV(DIF,60)*0.60,'K顶背'),COLORFFFF99;{KDJ顶背离}

A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)> C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2") {AND "RSI.RSI1"<40};
DRAWICON(B3>0,LLV(DIF,60)*0.34,1);
DRAWTEXT(B3>0,LLV(DIF,60)*0.35,'RSI底背'),COLOR00FFFF;{RSI底背离}

RSI底背:=B3>0 AND LLV(DIF,60)*0.35;
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)> "RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1") {AND "RSI.RSI1">60};
DRAWICON(D3>0,HHV(DIF,60)*0.34,2);
DRAWTEXT(D3>0,HHV(DIF,60)*0.35,'RSI顶背'),COLORFFCC99;{RSI顶背离}

JC:=DEA-DIF;
绿柱:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
红柱:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);
前次绿柱:=REF(绿柱,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱<0 AND ABS(绿柱)<ABS(前次绿柱)

AND 本次最低价<前次最低价),1,0);
RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价

AND ABS(绿柱)<ABS(前次绿柱) AND ABS(MACD)<ABS(REF(MACD,1));
底背驰:=IF (CROSS(DIF,DEA),REF(Y1,1),0);
DRAWICON(底背驰,LLV(DIF,60)*0.1,1);
DRAWTEXT(底背驰,LLV(DIF,60)*0.1,'↑柱底背离'),COLOR00CCFF;{柱底背离}

X2:=IF(MACD>0,BARSLAST(CROSS(DEA,DIF)),0);
前次红柱:=REF(红柱,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱>0 AND 红柱<前次红柱 AND 本次最高价>前次最高价),1,0);
RS2:=MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱)<ABS(前次红柱) AND ABS(MACD)<ABS(REF(MACD,1));
顶背驰:=IF(CROSS(DEA,DIF),REF(Y2,1),0);
DRAWICON(顶背驰,HHV(DIF,60)*0.1,2);
DRAWTEXT(顶背驰,HHV(DIF,60)*0.1,'↓柱'),COLORFFCCCC;{柱顶背离};

指标公式动态翻译

输出DIF:100*(收盘价的12日指数移动平均-收盘价的26日指数移动平均),画白色,线宽为1
输出DEA:DIF的9日指数移动平均,画黄色,线宽为1
输出平滑异同平均:(DIF-DEA)*2,COLORSTICK
当满足条件MACD>1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,画红色
当满足条件MACD<1日前的MACDANDMACD>0时,在0和MACD位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,画黄色
当满足条件MACD>1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,画蓝色
当满足条件MACD<1日前的MACDANDMACD<0时,在0和MACD位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,画绿色
FH1赋值:1日前的MACD<2日前的MACD AND 2日前的MACD<3日前的MACD AND 3日前的MACD<4日前的MACD
FH2赋值:MACD>=0 AND 统计1日中满足MACD>1日前的MACD的天数=1
FH3赋值:FH1 AND FH2 AND 收盘价的13日指数移动平均>1日前的收盘价的13日指数移动平均
FH4赋值:FH1 AND FH2 AND (DIF-DEA)/收盘价的绝对值<0.018
FH5赋值:FH1 AND FH2 AND MACD<0.10
二次翻红赋值:(FH3 OR FH4 OR FH5),画红色,NODRAW
低买赋值:DIF上穿DEA AND DIF<0,COLORFF00FF,NODRAW
加油赋值:DIF上穿DEA AND DIF>0,画黄色,NODRAW
当满足条件二次翻红时,在-0.05位置画1号图标
当满足条件二次翻红时,在-0.15位置书写文字,画红色
当满足条件DIF上穿DEAANDDIF<0时,在DEA-0.02位置书写文字,COLORFF00FF
当满足条件DIF上穿DEAANDDIF>0时,在DEA-0.05位置书写文字,画黄色
YLZC赋值:如果收盘价=大盘的收盘价,返回(大盘的收盘价+大盘的最高价+大盘的最低价+大盘的开盘价)/4,否则返回成交额(元)/(成交量(手)+0.01)/100
W1赋值:收盘价>4日前的收盘价
NT赋值:条件连续成立次数
TJ11赋值:NT=9
TJ13赋值:是否最后一个周期 AND NT位于5和8之间
AY赋值:(若TJ11>0则将最近9周期置为1 OR 若TJ13>0则将最近NT周期置为1)*NT
当满足条件AY>0时,在MACD*1.02位置书写文字,画淡红色
当满足条件NT=9时,在MACD*1.02位置书写文字,画绿色
Q1赋值:收盘价<4日前的收盘价
NT0赋值:条件连续成立次数
TJ21赋值:NT0=9 
TJ23赋值:是否最后一个周期 AND NT0位于5和8之间
AY1赋值:(若TJ21>0则将最近9周期置为1 OR 若TJ23>0则将最近NT0周期置为1)*NT0
当满足条件AY1>0时,在MACD*0.98位置书写文字,画绿色
当满足条件NT0=9时,在MACD*0.98位置书写文字,画红色
当满足条件DIF上穿DEA时,在DEA位置画1号图标
当满足条件DEA上穿DIF时,在DEA位置画2号图标
死叉赋值:DEA上穿DIF
N1赋值:上次死叉距今天数,NODRAW
N2赋值:N1+1日前的上次死叉距今天数,NODRAW
N3赋值:N2+N1+2日前的上次死叉距今天数,NODRAW
CL1赋值:N1+1日内收盘价的最低值,NODRAW
DIFL1赋值:N1+1日内DIF的最低值,NODRAW
CL2赋值:N1+1日前的CL1,NODRAW
DIFL2赋值:N1+1日前的DIFL1,NODRAW
CL3赋值:N1+1日前的CL2,NODRAW
DIFL3赋值:N1+1日前的DIFL2,NODRAW
PDIFL2赋值:如果DIFL2>0,返回DIFL2的对数的整数部分-1,否则返回-DIFL2的对数的整数部分-1
MDIFL2赋值:DIFL2/10的PDIFL2乘幂的整数部分
PDIFL3赋值:如果DIFL3>0,返回DIFL3的对数的整数部分-1,否则返回-DIFL3的对数的整数部分-1
MDIFL3赋值:DIFL3/10的PDIFL3乘幂的整数部分
MDIFB2赋值:DIF/10的PDIFL2乘幂的整数部分
MDIFB3赋值:DIF/10的PDIFL3乘幂的整数部分
直接底背离赋值:(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND 1日前的MACD<0) AND MDIFB2<=1日前的MDIFB2
隔峰底背离赋值:(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND 1日前的MACD<0) AND MDIFB3<=1日前的MDIFB3
底部钝化赋值:直接底背离 OR 隔峰底背离,NODRAW
底背离赋值:((MDIFB2>1日前的MDIFB2)*1日前的直接底背离) OR ((MDIFB3>1日前的MDIFB3)*1日前的隔峰底背离),NODRAW
当满足条件底部钝化时,在DIF和DEA位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
当满足条件信号过滤(多头)时,在DIF*0.98位置书写文字,画洋红色
金叉赋值:DIF上穿DEA
M1赋值:上次金叉距今天数,NODRAW
M2赋值:M1+1日前的上次金叉距今天数,NODRAW
M3赋值:M2+M1+2日前的上次金叉距今天数,NODRAW
CH1赋值:M1+1日内收盘价的最高值,NODRAW
DIFH1赋值:M1+1日内DIF的最高值,NODRAW
CH2赋值:M1+1日前的CH1,NODRAW
DIFH2赋值:M1+1日前的DIFH1,NODRAW
CH3赋值:M1+1日前的CH2,NODRAW
DIFH3赋值:M1+1日前的DIFH2,NODRAW
PDIFH2赋值:如果DIFH2>0,返回DIFH2的对数的整数部分-1,否则返回-DIFH2的对数的整数部分-1
MDIFH2赋值:DIFH2/10的PDIFH2乘幂的整数部分
PDIFH3赋值:如果DIFH3>0,返回DIFH3的对数的整数部分-1,否则返回-DIFH3的对数的整数部分-1
MDIFH3赋值:DIFH3/10的PDIFH3乘幂的整数部分
MDIFT2赋值:DIF/10的PDIFH2乘幂的整数部分
MDIFT3赋值:DIF/10的PDIFH3乘幂的整数部分
直接顶背离赋值:(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND 1日前的MACD>0) AND MDIFT2>=1日前的MDIFT2
隔峰顶背离赋值:(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND 1日前的MACD>0) AND MDIFT3>=1日前的MDIFT3
顶部钝化赋值:直接顶背离 OR 隔峰顶背离,NODRAW
顶背离赋值:((MDIFT2<1日前的MDIFT2)*1日前的直接顶背离) OR ((MDIFT3<1日前的MDIFT3)*1日前的隔峰顶背离),NODRAW
当满足条件顶部钝化时,在DIF和DEA位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
当满足条件信号过滤(多头)时,在DIF*1.02位置书写文字,画洋红色
当满足条件DIF上穿DEA时,在DEA位置画36号图标
当满足条件DEA上穿DIF时,在DEA位置画37号图标
MACDDIF赋值:如果MACD的绝对值>DIF的绝对值,返回MACD,否则返回DIF
当满足条件1日前的DIF>2日前的DIFANDDIF<1日前的DIFANDDIF>0ANDDIF>DEA时,在MACDDIF*1.1位置画39号图标,画绿色
当满足条件1日前的DIF<2日前的DIFANDDIF>1日前的DIFANDDIF<0ANDDIF<DEA时,在MACDDIF*1.1位置画38号图标,画红色
启动点赋值:MACD<0 AND MACD>1日前的MACD AND 1日前的MACD<2日前的MACDAND 2日前的MACD<3日前的MACDAND 3日前的MACD<4日前的MACD
当满足条件启动点时,在MACD-0.1位置书写文字,COLORFF33FF
GC赋值:如果DIF>DEA,返回DIF,否则返回无效数COLOR0099FF
A1赋值:上次1日前的'MACD.DIF'上穿'MACD.DEA'距今天数
B1赋值:A1+1日前的收盘价>收盘价 AND A1+1日前的'MACD.DIF'<'MACD.DIF' AND 'MACD.DIF'上穿'MACD.DEA'
当满足条件B1>0时,在60日内DIF的最低值*0.84位置画1号图标
当满足条件B1>0时,在60日内DIF的最低值*0.85位置书写文字,COLOR9900FF
MACD底背离赋值:B1>0 AND 60日内DIF的最低值*0.85
C1赋值:上次1日前的"MACD.DEA"上穿"MACD.DIF"距今天数
D1赋值:C1+1日前的收盘价<收盘价 AND C1+1日前的"MACD.DIF">"MACD.DIF" AND "MACD.DEA"上穿"MACD.DIF"
当满足条件D1>0时,在60日内DIF的最高值*0.84位置画2号图标
当满足条件D1>0时,在60日内DIF的最高值*0.85位置书写文字,COLOR00FF00
A2赋值:上次1日前的"KDJ的K"上穿"KDJ的D"距今天数
B2赋值:A2+1日前的收盘价> 收盘价 AND A2+1日前的"KDJ的K"<"KDJ的K" AND "KDJ的K"上穿"KDJ的D" 
当满足条件B2>0时,在60日内DIF的最低值*0.59位置画1号图标
当满足条件B2>0时,在60日内DIF的最低值*0.60位置书写文字,COLORFF33FF
K底背赋值:B2>0 AND 60日内DIF的最低值*0.60
C2赋值:上次1日前的"KDJ的D"上穿"KDJ的K"距今天数
D2赋值:C2+1日前的收盘价<收盘价 AND C2+1日前的"KDJ的K"> "KDJ的K" AND "KDJ的D"上穿"KDJ的K" 
当满足条件D2>0时,在60日内DIF的最高值*0.59位置画2号图标
当满足条件D2>0时,在60日内DIF的最高值*0.60位置书写文字,COLORFFFF99
A3赋值:上次1日前的"RSI的RSI1"上穿"RSI的RSI2"距今天数
B3赋值:A3+1日前的收盘价> 收盘价 AND A3+1日前的"RSI的RSI1"<"RSI的RSI1" AND "RSI的RSI1"上穿"RSI的RSI2" 
当满足条件B3>0时,在60日内DIF的最低值*0.34位置画1号图标
当满足条件B3>0时,在60日内DIF的最低值*0.35位置书写文字,COLOR00FFFF
RSI底背赋值:B3>0 AND 60日内DIF的最低值*0.35
C3赋值:上次1日前的"RSI的RSI2"上穿"RSI的RSI1"距今天数
D3赋值:C3+1日前的收盘价<收盘价 AND C3+1日前的"RSI的RSI1"> "RSI的RSI1" AND "RSI的RSI2"上穿"RSI的RSI1" 
当满足条件D3>0时,在60日内DIF的最高值*0.34位置画2号图标
当满足条件D3>0时,在60日内DIF的最高值*0.35位置书写文字,COLORFFCC99
JC赋值:DEA-DIF
绿柱赋值:如果MACD<0,返回MACD的上次JC<0距今天数日累和,否则返回0
红柱赋值:如果MACD>0,返回MACD的上次JC>0距今天数日累和,否则返回0
本次最低价赋值:上次JC<0距今天数日内最低价的最低值
本次最高价赋值:上次JC>0距今天数日内最高价的最高值
X1赋值:如果MACD<0,返回上次DIF上穿DEA距今天数,否则返回0
前次绿柱赋值:X1+1日前的绿柱
前次最低价赋值:X1+1日前的本次最低价
Y1赋值:如果(绿柱<0ANDABS(绿柱)<前次绿柱的绝对值AND本次最低价<前次最低价),返回1,否则返回0
RS1赋值: MACD<0 AND 1日前的MACD<0 AND 收盘价<前次最低价AND 绿柱的绝对值<前次绿柱的绝对值 AND MACD的绝对值<1日前的MACD的绝对值
底背驰赋值:如果DIF上穿DEA,返回1日前的Y1,否则返回0
当满足条件底背驰时,在60日内DIF的最低值*0.1位置画1号图标
当满足条件底背驰时,在60日内DIF的最低值*0.1位置书写文字,COLOR00CCFF
X2赋值:如果MACD>0,返回上次DEA上穿DIF距今天数,否则返回0
前次红柱赋值:X2+1日前的红柱
前次最高价赋值:X2+1日前的本次最高价
Y2赋值:如果(红柱>0AND红柱<前次红柱AND本次最高价>前次最高价),返回1,否则返回0
RS2赋值:MACD>0 AND 1日前的MACD>0 AND 收盘价>前次最高价 AND 红柱的绝对值<前次红柱的绝对值 AND MACD的绝对值<1日前的MACD的绝对值
顶背驰赋值:如果DEA上穿DIF,返回1日前的Y2,否则返回0
当满足条件顶背驰时,在60日内DIF的最高值*0.1位置画2号图标
当满足条件顶背驰时,在60日内DIF的最高值*0.1位置书写文字,COLORFFCCCC

 

以上关于  使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章