红里透黄指标公式通达信_黄金坑副图指标公式

来源:中金指南网

指标公式用法

红里透黄指标公式通达信,如图绿柱变红柱,提示B字母,也即是买的意思,密集提示是买入强烈的信号。

指标公式案例

红里透黄指标公式通达信

指标公式源码

VAR1:=EMA(CLOSE,12)-EMA(CLOSE,26);
VAR2:=EMA(VAR1,9);
VAR3:=VAR1>VAR2;
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=SMA(VAR4,3,1);
VAR6:=SMA(VAR5,3,1);
VAR7:=VAR5>VAR6;
VAR8:=REF(CLOSE,1);
VAR9:=SMA(MAX(CLOSE-VAR8,0),9,1)/SMA(ABS(CLOSE-VAR8),9,1)*100;
VAR10:=SMA(MAX(CLOSE-VAR8,0),26,1)/SMA(ABS(CLOSE-VAR8),26,1)*100;
VAR11:=VAR9>VAR10;
VAR12:=SMA(VAR4,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR12>VAR13;
VAR15:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
VAR16:=CLOSE>VAR15;
VAR17:=CLOSE-REF(CLOSE,1);
VAR18:=100*EMA(EMA(VAR17,9),9)/EMA(EMA(ABS(VAR17),9),3);
VAR19:=100*EMA(EMA(VAR17,26),12)/EMA(EMA(ABS(VAR17),26),12);
VAR20:=VAR18>VAR19;
VAR21:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
VAR22:=REF(EMA(VAR21,3),1);
VAR23:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
VAR24:=IF(CLOSE>OPEN,VAR23*(HIGH-LOW),IF(CLOSE<OPEN,VAR23*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-VAR23*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-VAR23*(HIGH-LOW),0-VOL/2));
VAR25:=VAR24/20/1.15;
VAR26:=VAR25*0.55+REF(VAR25,1)*0.33+REF(VAR25,2)*0.22;
VAR27:=EMA(VAR26,8);
VAR28:=EMA(VAR26,3);
VAR29:=VAR28;
VAR30:=VOL;
VAR31:=MA(VAR30,5);
VAR32:=MA(VAR30,10);
VAR33:=VAR31>=VAR32;
VAR34:=VAR29>=0;
VAR35:=VAR34 AND VAR33;
DRAWICON(VAR35,1,25);
VAR36:=MA(KDJ.K#WEEK(9,3,3),5);
VAR37:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
VAR38:=EMA(VAR37,9/2);
VAR39:=VAR36>=REF(VAR36,1) AND VAR37>=VAR38;
DRAWICON(VAR39,0.9,7);
VAR40:=VAR39 OR VAR35;
VAR41:=VAR3 AND VAR7 AND VAR11 AND VAR14 AND VAR16 AND VAR20;
VAR42:=COST(50)*COST(50)/COST(80);
VAR43:=COST(40)*COST(40)/COST(60);
VAR44:=VAR43-VAR42;
VAR45:=VAR44>0 AND CLOSE>VAR43;
VAR46:=VAR44<0 AND CLOSE>VAR42;
VAR47:=VAR45 OR VAR46 OR (VAR45 AND VAR46);
VAR48:=VAR47=0 OR (VAR44>0 AND CLOSE>VAR43 AND CLOSE<MA(CLOSE,10)) OR (VAR44<0 AND CLOSE>VAR42 AND CLOSE<MA(CLOSE,5));
VAR49:=VAR47 AND REF(VAR48,1);
VAR50:=VAR48 AND REF(VAR47,1);
STICKLINE(VAR48,0.5,0.8,3,0),COLORGREEN;
STICKLINE(VAR48,0.5,0.8,2.5,0),COLOR006000;
STICKLINE(VAR48,0.5,0.8,2,0),COLOR007500;
STICKLINE(VAR48,0.5,0.8,1.5,0),COLOR009100;
STICKLINE(VAR48,0.5,0.8,1,0),COLOR00A600;
STICKLINE(VAR48,0.5,0.8,0.5,0),COLOR00BB00;
STICKLINE(VAR48,0.5,0.8,0,0),COLOR00CC00;
STICKLINE(VAR47,0.5,0.8,3,0),COLORYELLOW;
STICKLINE(VAR47,0.5,0.8,2.5,0),COLOR0035FF;
STICKLINE(VAR47,0.5,0.8,2,0),COLOR0064FF;
STICKLINE(VAR47,0.5,0.8,1.3,0),COLOR0093FF;
STICKLINE(VAR47,0.5,0.8,0.8,0),COLOR00C2FF;
STICKLINE(VAR47,0.5,0.8,0.3,0),COLOR00FFFF;
STICKLINE(VAR41,0.5,0.8,3,0),COLORRED;
STICKLINE(VAR41,0.5,0.8,2.5,0),COLOR000055;
STICKLINE(VAR41,0.5,0.8,2,0),COLOR000077;
STICKLINE(VAR41,0.5,0.8,1.5,0),COLOR000099;
STICKLINE(VAR41,0.5,0.8,1,0),COLOR0000BB;
STICKLINE(VAR41,0.5,0.8,0.5,0),COLOR0000DD;
STICKLINE(VAR41,0.5,0.8,0,0),COLOR0000FF;
DRAWICON(VAR47 OR VAR41 AND REF(VAR47 OR VAR41,1)=0 AND VAR40,0.5,25);

指标公式动态翻译

VAR1赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
VAR2赋值:VAR1的9日指数移动平均
VAR3赋值:VAR1>VAR2
VAR4赋值:(收盘价-12日内最低价的最低值)/(12日内最高价的最高值-12日内最低价的最低值)*100
VAR5赋值:VAR4的3日[1日权重]移动平均
VAR6赋值:VAR5的3日[1日权重]移动平均
VAR7赋值:VAR5>VAR6
VAR8赋值:1日前的收盘价
VAR9赋值:收盘价-VAR8和0的较大值的9日[1日权重]移动平均/收盘价-VAR8的绝对值的9日[1日权重]移动平均*100
VAR10赋值:收盘价-VAR8和0的较大值的26日[1日权重]移动平均/收盘价-VAR8的绝对值的26日[1日权重]移动平均*100
VAR11赋值:VAR9>VAR10
VAR12赋值:VAR4的3日[1日权重]移动平均
VAR13赋值:VAR12的3日[1日权重]移动平均
VAR14赋值:VAR12>VAR13
VAR15赋值:(收盘价的3日简单移动平均+收盘价的9日简单移动平均+收盘价的12日简单移动平均+收盘价的26日简单移动平均)/4
VAR16赋值:收盘价>VAR15
VAR17赋值:收盘价-1日前的收盘价
VAR18赋值:100*VAR17的9日指数移动平均的9日指数移动平均/VAR17的绝对值的9日指数移动平均的3日指数移动平均
VAR19赋值:100*VAR17的26日指数移动平均的12日指数移动平均/VAR17的绝对值的26日指数移动平均的12日指数移动平均
VAR20赋值:VAR18>VAR19
VAR21赋值:以0.9为权重(最高价+最低价+收盘价*2)/4的动态移动平均
VAR22赋值:1日前的VAR21的3日指数移动平均
VAR23赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
VAR24赋值:如果收阳线,返回VAR23*(最高价-最低价),否则返回如果收阴线,返回VAR23*(最高价-开盘价+收盘价-最低价),否则返回成交量(手)/2+如果收阳线,返回0-VAR23*(最高价-收盘价+开盘价-最低价),否则返回如果收阴线,返回0-VAR23*(最高价-最低价),否则返回0-成交量(手)/2
VAR25赋值:VAR24/20/1.15
VAR26赋值:VAR25*0.55+1日前的VAR25*0.33+2日前的VAR25*0.22
VAR27赋值:VAR26的8日指数移动平均
VAR28赋值:VAR26的3日指数移动平均
VAR29赋值:VAR28
VAR30赋值:成交量(手)
VAR31赋值:VAR30的5日简单移动平均
VAR32赋值:VAR30的10日简单移动平均
VAR33赋值:VAR31>=VAR32
VAR34赋值:VAR29>=0
VAR35赋值:VAR34 AND VAR33
当满足条件VAR35时,在1位置画25号图标
VAR36赋值:KDJ的K[取周线数据](9,3,3)的5日简单移动平均
VAR37赋值:收盘价的12/2日指数移动平均-收盘价的26/2日指数移动平均
VAR38赋值:VAR37的9/2日指数移动平均
VAR39赋值:VAR36>=1日前的VAR36 AND VAR37>=VAR38
当满足条件VAR39时,在0.9位置画7号图标
VAR40赋值:VAR39 OR VAR35
VAR41赋值:VAR3 AND VAR7 AND VAR11 AND VAR14 AND VAR16 AND VAR20
VAR42赋值:获利盘为50%的成本分布*获利盘为50%的成本分布/获利盘为80%的成本分布
VAR43赋值:获利盘为40%的成本分布*获利盘为40%的成本分布/获利盘为60%的成本分布
VAR44赋值:VAR43-VAR42
VAR45赋值:VAR44>0 AND 收盘价>VAR43
VAR46赋值:VAR44<0 AND 收盘价>VAR42
VAR47赋值:VAR45 OR VAR46 OR (VAR45 AND VAR46)
VAR48赋值:VAR47=0 OR (VAR44>0 AND 收盘价>VAR43 AND 收盘价<收盘价的10日简单移动平均) OR (VAR44<0 AND 收盘价>VAR42 AND 收盘价<收盘价的5日简单移动平均)
VAR49赋值:VAR47 AND 1日前的VAR48
VAR50赋值:VAR48 AND 1日前的VAR47
当满足条件VAR48时,在0.5和0.8位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
当满足条件VAR48时,在0.5和0.8位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR006000
当满足条件VAR48时,在0.5和0.8位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR007500
当满足条件VAR48时,在0.5和0.8位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR009100
当满足条件VAR48时,在0.5和0.8位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00A600
当满足条件VAR48时,在0.5和0.8位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00BB00
当满足条件VAR48时,在0.5和0.8位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00CC00
当满足条件VAR47时,在0.5和0.8位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色
当满足条件VAR47时,在0.5和0.8位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR0035FF
当满足条件VAR47时,在0.5和0.8位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0064FF
当满足条件VAR47时,在0.5和0.8位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR0093FF
当满足条件VAR47时,在0.5和0.8位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,COLOR00C2FF
当满足条件VAR47时,在0.5和0.8位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR00FFFF
当满足条件VAR41时,在0.5和0.8位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
当满足条件VAR41时,在0.5和0.8位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR000055
当满足条件VAR41时,在0.5和0.8位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000077
当满足条件VAR41时,在0.5和0.8位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR000099
当满足条件VAR41时,在0.5和0.8位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000BB
当满足条件VAR41时,在0.5和0.8位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000DD
当满足条件VAR41时,在0.5和0.8位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000FF
当满足条件VAR47ORVAR41AND1日前的VAR47ORVAR41=0ANDVAR40时,在0.5位置画25号图标
 

以上关于红里透黄指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章