通达信股票活跃度指标公式源码及用法

来源:中金指南网

指标公式用法

股票活跃度指标公式,该指标可以分析短线个股异动或是否处于强势区间,以及股性的活跃度评判。通常蓝色线不参考操作,只操作红线区域即可,或者说,蓝转红时可参考。

指标公式案例

活跃度指标公式

指标公式源码

REFLINE:2;
CS:=DMA(AMOUNT/(100*VOL),VOL/CAPITAL);
M20:=MA(C,20);
M30:=MA(C,30);
M2:=M20>REF(M20,1);
M3:=M30>REF(M30,1);
MCS:=CS>REF(CS,1);
TRD:=M2+M3+MCS>1;
{趋势}

LBARS:=LLVBARS(L,21);
BARS:=IF(LBARS<13,13,LBARS);
ACT:SMA(MAX(ABS(C-O),ABS(C-REF(C,1)))/REF(C,1)*100,10,1),LINETHICK2;
{活跃度}

YD:=ACT>LLV(ACT,13)*1.2;
{异动}

A1:=ACT<2 AND NOT(YD);
{弱}

A2:=ACT<2 AND YD;
{异动}

A3:=ACT>=2 AND TRD;
{强}

A4:=ACT>=2 AND NOT(TRD);
{跌}

2,COLOR5E5E5E;
IF(A1>0,ACT,DRAWNULL),COLORBLUE,LINETHICK3;
IF(A2>0,ACT,DRAWNULL),COLORLIRED,LINETHICK3;
IF(A3>0,ACT,DRAWNULL),COLORRED,LINETHICK3;
IF(A4>0,ACT,DRAWNULL),COLORGREEN,LINETHICK3;
DRAWTEXT_FIX(1,0.05,0.02,1,'弱势'),COLORBLUE;
DRAWTEXT_FIX(1,0.05,0.17,1,'异动'),COLORLIRED;
DRAWTEXT_FIX(1,0.05,0.32,1,'强势'),COLORRED;
DRAWTEXT_FIX(1,0.05,0.47,1,'跌秃'),COLORGREEN;
DRAWTEXT_FIX(1,0.5,0.42,1,'短线:异动或强势——参与?!股性处于2以上比较活跃'),COLOR5E5E5E;

指标公式动态翻译

输出REFLINE:2
CS赋值:以成交量(手)/当前流通股本(手)为权重成交额(元)/(100*成交量(手))的动态移动平均
M20赋值:收盘价的20日简单移动平均
M30赋值:收盘价的30日简单移动平均
M2赋值:M20>1日前的M20
M3赋值:M30>1日前的M30
MCS赋值:CS>1日前的CS
TRD赋值:M2+M3+MCS>1
LBARS赋值:21日内最低价距今天数
BARS赋值:如果LBARS<13,返回13,否则返回LBARS
输出ACT:收盘价-开盘价的绝对值和收盘价-1日前的收盘价的绝对值的较大值/1日前的收盘价*100的10日[1日权重]移动平均,线宽为2
YD赋值:ACT>13日内ACT的最低值*1.2
A1赋值:ACT<2 AND 取反
A2赋值:ACT<2 AND YD
A3赋值:ACT>=2 AND TRD
A4赋值:ACT>=2 AND 取反
2,COLOR5E5E5E
如果A1>0,返回ACT,否则返回无效数,画蓝色,线宽为3
如果A2>0,返回ACT,否则返回无效数,画淡红色,线宽为3
如果A3>0,返回ACT,否则返回无效数,画红色,线宽为3
如果A4>0,返回ACT,否则返回无效数,画绿色,线宽为3
当满足条件1时,在横轴0.05纵轴0.02位置书写文字,画蓝色
当满足条件1时,在横轴0.05纵轴0.17位置书写文字,画淡红色
当满足条件1时,在横轴0.05纵轴0.32位置书写文字,画红色
当满足条件1时,在横轴0.05纵轴0.47位置书写文字,画绿色
当满足条件1时,在横轴0.5纵轴0.42位置书写文字,COLOR5E5E5E
 

以上关于活跃度指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章