通达信疯狂T+0分时副图指标公式

来源:中金指南网

指标公式用法

分时图t+0多空决策指标公式,如上图,该指标运用于当日分时图,重点以t+0的交易方式来操盘,在原有仓位基础上,当日低吸高抛或者高抛低吸,提示“顶”高位减仓,提示“关注”则机低吸信号。

指标公式案例

T+0分时

指标公式源码

Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);
天:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));
DRAWICON(CROSS((C/天),1.01),25,3);
STICKLINE(CROSS((C/天),1.01),25,0,2,0), ,COLORYELLOW;
VAR1:=REF(CLOSE,3.5);
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
Q2:=(CLOSE-LLV(LOW, 21))/(HHV(HIGH, 21)-LLV(LOW, 21))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
Q8:=HHVBARS(HIGH, 50);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
快线: SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,COLORFFAA66;
慢线:EMA(Q3, 3),COLORRED;
DRAWBAND(快线,RGB(115,95,120),慢线,RGB(95,120,115));
A:=VOL*CLOSE;
B:=SUM(A,3.52)/SUM(VOL,3.82);
B1:=EMA(B,13);
主力线:(B-B1)*191/B+50,COLORMAGENTA;
多头:3*Q3-2*Q4,COLORRED;
VAR12:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
空头: SMA(VAR12,3,1),COLORGREEN;
DRAWTEXT(CROSS(慢线, 多头) AND REF(多头,1)>80, REF(多头,3), '*顶'),COLORRED,LINETHICK5;
●关注: DRAWTEXT(REF(CROSS(空头,慢线),25) AND 空头>1.005*慢线,慢线,'●关注'),COLORBLUE,LINETHICK1;
★关注: DRAWTEXT(REF(CROSS(慢线,多头),82) AND 慢线>1.3*多头,多头,'★关注'),LINETHICK1;
★追涨: DRAWTEXT(REF(CROSS(多头,慢线),1) AND 多头>1.3*慢线,慢线,'★追涨'),COLORRED,LINETHICK1;
★抄底:IF(CROSS(多头,慢线) AND 快线>=REF(快线,1) AND 多头>=REF(多头,1)

AND 慢线<38.2 AND 慢线>=REF(慢线,1) AND COUNT(REF(快线,1)<REF(快线,2) OR REF(慢线,1)<REF(慢线,2) OR REF(多头,1)<REF(多头,2),3)>=2,30,0),COLORMAGENTA;
DRAWTEXT(CROSS(多头, 8) AND Q10<-13,20,'*大底'),COLORYELLOW,LINETHICK5;
★逃亡:IF(快线< REF(快线,1) AND 快线>61.8,70,100),COLORBLUE;
50,POINTDOT,COLORWHITE;
AZ1:=AMOUNT/VOL/100;
AZ2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
AZ3:=SUM(AMOUNT,40)/AZ1/100;
AZ4:=SUM(AMOUNT,80)/AZ1/100;
BZ1:=DMA(AZ2,VOL/AZ3);
BZ2:=DMA(AZ2,VOL/AZ4);
BZ3:=(CLOSE-BZ1)/BZ1*100;
BZ4:=(CLOSE-BZ2)/BZ2*100;
DRAWTEXT(ISLASTBAR AND C,93,' 冷眼分时专用指标'),COLOR00AAFF;
DRAWTEXT(ISLASTBAR AND C,80,' 55上红柱谨慎看多'),COLOR00BBBB;
DRAWTEXT(ISLASTBAR AND C,68,' 50下绿柱保持警惕'),COLOR00BBBB;
DRAWTEXT(ISLASTBAR AND C,56,' 结合多(黄)空(绿)线'),COLOR00BBBB;
DRAWTEXT(ISLASTBAR AND C,44,' 选择正确操作时段'),COLOR00BBBB;
DRAWTEXT(ISLASTBAR AND C,32,' 按照图中提示关注'),COLOR00BBBB;
DRAWTEXT(ISLASTBAR AND C,20,' 严格遵守操作纪律'),COLOR00BBBB;
DRAWTEXT(ISLASTBAR AND C,8,' 心态平衡投资顺利'),COLOR00BBBB;
STICKLINE(FILTER(C,60)>0,100,-0,0,0),COLORRED;
STICKLINE(BZ4>0,50,50+13.82*BZ4,0,0),COLORYELLOW;
STICKLINE(BZ3>0,50,50+13.82*BZ3,0,0),COLORRED;
STICKLINE(BZ3<=0,50,50+13.82*BZ3,0,0),COLORGREEN;

指标公式动态翻译

Q赋值:收盘价/(成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和)位于1.05和0.95之间
天赋值:如果Q=0,返回收盘价的收盘价的有效数据周期数日简单移动平均,否则返回(成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和)
当满足条件(收盘价/天)上穿1.01时,在25位置画3号图标
当满足条件(收盘价/天)上穿1.01时,在25和0位置之间画柱状线,宽度为2,0不为0则画空心柱., ,画黄色
VAR1赋值:3.5日前的收盘价
VAR2赋值:1日前的收盘价
VAR3赋值:收盘价-VAR2和0的较大值的7日[1日权重]移动平均/收盘价-VAR2的绝对值的7日[1日权重]移动平均*100
Q2赋值:(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100
Q3赋值:Q2的9日[1日权重]移动平均
Q4赋值:Q3的3日[1日权重]移动平均
Q8赋值:50日内最高价距今天数
Q10赋值:(收盘价-Q8日前的开盘价)/Q8日前的开盘价*100
输出快线: 收盘价-VAR1和0的较大值的7日[1日权重]移动平均/收盘价-VAR1的绝对值的7日[1日权重]移动平均*100,COLORFFAA66
输出慢线:Q3的3日指数移动平均,画红色
画带状线
A赋值:成交量(手)*收盘价
B赋值:A的3.52日累和/成交量(手)的3.82日累和
B1赋值:B的13日指数移动平均
输出主力线:(B-B1)*191/B+50,画洋红色
输出多头:3*Q3-2*Q4,画红色
VAR12赋值:(36日内最高价的最高值-收盘价)/(36日内最高价的最高值-36日内最低价的最低值)*100
输出空头: VAR12的3日[1日权重]移动平均,画绿色
当满足条件慢线上穿多头ANDREF(多头,1)>80时,在3日前的多头位置书写文字,画红色,线宽为5
输出●关注: 当满足条件25日前的空头上穿慢线AND空头>1.005*慢线时,在慢线位置书写文字,画蓝色,线宽为1
输出★关注: 当满足条件82日前的慢线上穿多头AND慢线>1.3*多头时,在多头位置书写文字,线宽为1
输出★追涨: 当满足条件1日前的多头上穿慢线AND多头>1.3*慢线时,在慢线位置书写文字,画红色,线宽为1
输出★抄底:如果多头上穿慢线AND快线>=1日前的快线AND多头>=1日前的多头AND慢线<38.2AND慢线>=1日前的慢线ANDCOUNT(1日前的快线<2日前的快线ORREF(慢线,1)<2日前的慢线ORREF(多头,1)<,返回EF(多头,2),3)>=2,否则返回30,画洋红色
当满足条件多头上穿8ANDQ10<-13时,在20位置书写文字,画黄色,线宽为5
输出★逃亡:如果快线<1日前的快线AND快线>61.8,返回70,否则返回100,画蓝色
50,POINTDOT,画白色
AZ1赋值:成交额(元)/成交量(手)/100
AZ2赋值:(3*最高价+最低价+开盘价+2*收盘价)/7
AZ3赋值:成交额(元)的40日累和/AZ1/100
AZ4赋值:成交额(元)的80日累和/AZ1/100
BZ1赋值:以成交量(手)/AZ3为权重AZ2的动态移动平均
BZ2赋值:以成交量(手)/AZ4为权重AZ2的动态移动平均
BZ3赋值:(收盘价-BZ1)/BZ1*100
BZ4赋值:(收盘价-BZ2)/BZ2*100
当满足条件ISLASTBARANDC时,在93位置书写文字,COLOR00AAFF
当满足条件ISLASTBARANDC时,在80位置书写文字,COLOR00BBBB
当满足条件ISLASTBARANDC时,在68位置书写文字,COLOR00BBBB
当满足条件ISLASTBARANDC时,在56位置书写文字,COLOR00BBBB
当满足条件ISLASTBARANDC时,在44位置书写文字,COLOR00BBBB
当满足条件ISLASTBARANDC时,在32位置书写文字,COLOR00BBBB
当满足条件ISLASTBARANDC时,在20位置书写文字,COLOR00BBBB
当满足条件ISLASTBARANDC时,在8位置书写文字,COLOR00BBBB
当满足条件收盘价的60日过滤>0时,在100和-0位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件BZ4>0时,在50和50+13.82*BZ4位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色
当满足条件BZ3>0时,在50和50+13.82*BZ3位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件BZ3<=0时,在50和50+13.82*BZ3位置之间画柱状线,宽度为0,0不为0则画空心柱.,画绿色

以上关于T+0分时副图指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章