通达信底部黑马公式指标源码

来源:中金指南网

指标公式用法

底部黑马公式指标,红色黑马线与绿色反切线金叉,后市上涨趋势行情确立。同时要注意关注黑马线的变化情况,每当站稳70值以后,基本可以确定一波大牛行情趋势已经形成。

指标公式案例

底部黑马公式

指标公式源码

A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,2)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,2);
黑马线:EMA(A1,5),LINETHICK2,COLOR6600FF;
反切线:100-EMA(A1,5),LINETHICK2,COLOR00FF00;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线: (EMA(4*SMA(A4,6,1)-3*SMA(SMA(A4,5,1),5,1),2)),LINETHICK1,COLORYELLOW;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A2<0,7),黑马线,'跑'),COLOR00FF00;
DRAWTEXT(CROSS(趋势线,黑马线)AND 黑马线>20 AND 黑马线<A5,黑马线,'黑马');
DRAWTEXT(CROSS(趋势线,0) AND 黑马线<40,5,'大黑马');
底部:(A2<-10 AND A2>REF(A2,1))*25,COLORRED;
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),LINETHICK2,COLORE66878;
大势已去:IF(CROSS(黑马线,A1) AND 黑马线>70 AND 趋势线>80,90,100),LINETHICK2,COLORE66878;
50,LINETHICK3,COLORE66878,POINTDOT;
70,COLORYELLOW,POINTDOT;

指标公式动态翻译

A1赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[2日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[2日权重]移动平均
输出黑马线:A1的5日指数移动平均,线宽为2,COLOR6600FF
输出反切线:100-A1的5日指数移动平均,线宽为2,COLOR00FF00
A2赋值:(黑马线-1日前的黑马线)/1日前的黑马线*100
A3赋值:收盘价的5日指数移动平均
A4赋值:((收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值))*100
输出趋势线: (4*A4的6日[1日权重]移动平均-3*A4的5日[1日权重]移动平均的5日[1日权重]移动平均的2日指数移动平均),线宽为1,画黄色
A5赋值:(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)*100
当满足条件1日前的黑马线>90ANDA2<0的7日过滤时,在黑马线位置书写文字,COLOR00FF00
当满足条件趋势线上穿黑马线AND黑马线>20AND黑马线<A5时,在黑马线位置书写文字
当满足条件趋势线上穿0AND黑马线<40时,在5位置书写文字
输出底部:(A2<-10 AND A2>1日前的A2)*25,画红色
输出机会来临:1日前的如果(收盘价的5日简单移动平均-收盘价)/收盘价>0.04AND(收盘价的10日简单移动平均-收盘价的5日简单移动平均)/收盘价的5日简单移动平均>0.04,返回30,否则返回0,线宽为2,COLORE66878
输出大势已去:如果黑马线上穿A1AND黑马线>70AND趋势线>80,返回90,否则返回100,线宽为2,COLORE66878
50,线宽为3,COLORE66878,POINTDOT
70,画黄色,POINTDOT

以上关于底部黑马公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章