量化指标公式源码及用法

来源:中金指南网

指标公式用法

量化指标公式源,如图黄色趋势线和红色人气线,同时向上发出买点信号,逢低建仓,高位发出卖点信号,逢高出局。

指标公式案例

量化公式

指标公式源码

VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
趋势线: VAR3, , LINETHICK2,COLORRED;
人气线: VAR4, , LINETHICK2,COLORYELLOW;
VAR5:=CROSS(VAR2,VAR3) AND VAR3<25;
STICKLINE(VAR5,0,VAR3+5,1,1), , LINETHICK2,COLORRED;
VAR6:=CROSS(VAR3,VAR4) AND VAR3<25;
VAR7:=VAR6 AND VOL>REF(VOL,1)*2 AND VOL>REF(MA(VOL,5),1)*2;
STICKLINE(VAR6,0,VAR3+5,1,1), , LINETHICK2,COLORWHITE;
DRAWTEXT(VAR6 AND COUNT(VAR6,10)=1,VAR3+15,'买点'), , LINETHICK2,COLORWHITE;
STICKLINE(VAR7,0,VAR3+5,1,1), , LINETHICK2,COLORRED;
DRAWTEXT(VAR7 AND COUNT(VAR7,10)=1,VAR3+5,'机构异动'), , LINETHICK2,COLORRED;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
STICKLINE(VAR8 AND COUNT(VAR8,5)=1,VAR3-5,100,1,1), , LINETHICK2,COLORGREEN;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(VAR9,VAR3-5,100,1,1), , LINETHICK2,COLORYELLOW;
DRAWTEXT(VAR9 AND COUNT(VAR9,10)=1,VAR3-15,'卖点'), , LINETHICK2,COLORYELLOW;

指标公式动态翻译

VAR1赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)*100
VAR2赋值:VAR1的3日[1日权重]移动平均
VAR3赋值:VAR2的3日[1日权重]移动平均
VAR4赋值:VAR3的3日[1日权重]移动平均
输出趋势线: VAR3, , 线宽为2,画红色
输出人气线: VAR4, , 线宽为2,画黄色
VAR5赋值:VAR2上穿VAR3 AND VAR3<25
当满足条件VAR5时,在0和VAR3+5位置之间画柱状线,宽度为1,1不为0则画空心柱., , 线宽为2,画红色
VAR6赋值:VAR3上穿VAR4 AND VAR3<25
VAR7赋值:VAR6 AND 成交量(手)>1日前的成交量(手)*2 AND 成交量(手)>1日前的成交量(手)的5日简单移动平均*2
当满足条件VAR6时,在0和VAR3+5位置之间画柱状线,宽度为1,1不为0则画空心柱., , 线宽为2,画白色
当满足条件VAR6ANDCOUNT(VAR6,10)=1时,在VAR3+15位置书写文字, , 线宽为2,画白色
当满足条件VAR7时,在0和VAR3+5位置之间画柱状线,宽度为1,1不为0则画空心柱., , 线宽为2,画红色
当满足条件VAR7ANDCOUNT(VAR7,10)=1时,在VAR3+5位置书写文字, , 线宽为2,画红色
VAR8赋值:VAR2上穿VAR3 AND VAR3>80 AND VAR3>VAR4
当满足条件VAR8ANDCOUNT(VAR8,5)=1时,在VAR3-5和100位置之间画柱状线,宽度为1,1不为0则画空心柱., , 线宽为2,画绿色
VAR9赋值:VAR4上穿VAR3 AND VAR3>80
当满足条件VAR9时,在VAR3-5和100位置之间画柱状线,宽度为1,1不为0则画空心柱., , 线宽为2,画黄色
当满足条件VAR9ANDCOUNT(VAR9,10)=1时,在VAR3-15位置书写文字, , 线宽为2,画黄色
 

以上关于量化指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章