量王叠现通达信指标公式

来源:中金指南网

指标公式用法

量王叠现通达信指标公式,正如图中所示,蓝色点线为多空分界线,绿色死收点线,K线处于死收上方看多、下方则要看空。

指标公式案例

量王叠现

指标公式源码

SHORT:=12;
LONG:=26;
M:=9;
最大亏损:=5000;
DIF:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA:=EMA(DIF,M);
MACD:=2*(DIF-DEA),STICK;
多空分界:MA(C,50),LINETHICK1,COLORCYAN,POINTDOT;
{IF(多空分界>REF(多空分界,1),多空分界,DRAWNULL), COLORRED,LINETHICK1;}
TOZ:=MA(C,50),COLORYELLOW,DOTLINE;
TMACD:=MA(C,50)+(MACD.MACD)*3;
HD0:=CROSS(DIF,DEA);
金收:=REF(L,BARSLAST(HD0)),COLORYELLOW,DOTLINE;
DRAWNUMBER(ISLASTBAR,金收,金收),COLORCYAN;
LD0:=CROSS(DEA,DIF);
死收:REF(H,BARSLAST(LD0)),COLOR00FF00,DOTLINE;
JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}
DD:=(MACD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}
DIF拐头价:(DIF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)))COLORYELLOW,LINETHICK1;
柱变向价:=(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),COLORWHITE,LINETHICK1;
DRAWBAND(DIF拐头价,RGB(250,250,0),DIF拐头价,RGB(0,0,0));
DRAWBAND(IF(柱变向价>DIF拐头价,柱变向价,DRAWNULL),RGB(250,0,0),柱变向价,RGB(0,0,0));
黄铢消失见顶:=IF(柱变向价>=DIF拐头价,DIF拐头价,DRAWNULL),COLORYELLOW,CIRCLEDOT,LINETHICK1;
金叉:=IF(柱变向价>=DIF拐头价,多空分界,DRAWNULL),COLORYELLOW,CIRCLEDOT,LINETHICK1;
金死叉价:(JCSC*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)))COLORCYAN,NODRAW;
MACD走平时股价:=(((M+1)*(2*REF(DEA,1)*(M-1)+REF(MACD,1)*(M+1)))/(2*(M+1)*(M-1))+(REF(EMA(C,26),1)*(26-1)/(26+1))-(REF(EMA(C,12),1)*(12-1)/(12+1)))*(12+1)*(26+1)/(2*(26-12));
{DRAWNUMBER(DIF>DEA,TOZ,BARSLAST(CROSS(DIF,DEA))+1),COLORRED;
DRAWNUMBER(DIF<DEA,TOZ,BARSLAST(CROSS(DEA,DIF))+1),COLORGREEN;}
ES:=REF(EMA(C,26),1);
EP:=REF(EMA(C,12),1);
DI:=REF(DIF,1);
DIF穿零价:((12+1)*(26-1)*ES-(26+1)*(12-1)*EP)/(2*(26+1)-2*(12+1)),NODRAW,COLORWHITE;
{DRAWTEXT_FIX(1,0.6,0.94,0,STRCAT('DIF拐头价: ',CON2STR(DIF拐头价,2))),COLORYELLOW;
DRAWTEXT_FIX(1,0.7,0.94,0,STRCAT('柱变向价: ',CON2STR(柱变向价,2))),COLORRED;
DRAWTEXT_FIX(1,0.5,0.94,0,STRCAT('DIF穿零价: ',CON2STR(DIF穿零价,2))),COLORRED;}
DRAWTEXT_FIX(1,0.7,0.01,0,STRCAT('金死叉价: ',CON2STR(金死叉价,2))),COLORCYAN;
ZJ:=DIF>DEA;
HY:=DIF<DEA;
XG1:=ZJ AND C>死收 AND C>多空分界;
STICKLINE(XG1,L,H,0,0),COLOR0000AA;
STICKLINE(XG1,CLOSE,OPEN,3,0),COLOR000055;
STICKLINE(XG1,CLOSE,OPEN,2.8,0),COLOR000066;
STICKLINE(XG1,CLOSE,OPEN,2.5,0),COLOR000077;
STICKLINE(XG1,CLOSE,OPEN,2.2,0),COLOR000088;
STICKLINE(XG1,CLOSE,OPEN,1.7,0),COLOR000099;
STICKLINE(XG1,CLOSE,OPEN,1.2,0),COLOR0000AA;
STICKLINE(XG1,CLOSE,OPEN,0.7,0),COLOR0000CC;
STICKLINE(XG1,CLOSE,OPEN,0.2,0),COLOR0000FF;
W1:= C<死收 AND ZJ;
STICKLINE(W1,H,L,0,1),COLORFF55FF;
STICKLINE(W1,C,O,3.2,0),COLOR880088;
STICKLINE(W1,C,O,2.6,0),COLORAA00AA;
STICKLINE(W1,C,O,1.9,0),COLORCC00CC;
STICKLINE(W1,C,O,1.1,0),COLOREE00EE;
STICKLINE(W1,C,O,0.3,0),COLORFF44FF;
W2:= C<多空分界 AND ZJ;
STICKLINE(W2,H,L,0,1),COLORFF55FF;
STICKLINE(W2,C,O,3.2,0),COLOR880088;
STICKLINE(W2,C,O,2.6,0),COLORAA00AA;
STICKLINE(W2,C,O,1.9,0),COLORCC00CC;
STICKLINE(W2,C,O,1.1,0),COLOREE00EE;
STICKLINE(W2,C,O,0.3,0),COLORFF44FF;
XG2:=C<DIF拐头价 AND HY;
STICKLINE(XG2,H,L,0,0),COLOR00FF00;
STICKLINE(XG2,C,O,3,0),COLOR009900;
STICKLINE(XG2,C,O,2,0),COLOR00BB00;
STICKLINE(XG2,C,O,1,0),COLOR00DD00;
STICKLINE(XG2,C,O,0.3,0),COLOR00FF00;
XG3:=C>DIF拐头价 AND HY;
STICKLINE(XG3,H,L,0,0),COLOR00FF00;
STICKLINE(XG3,C,O,3,0),COLOR009900;
STICKLINE(XG3,C,O,2,0),COLOR00BB00;
STICKLINE(XG3,C,O,1,0),COLOR00DD00;
STICKLINE(XG3,C,O,0.3,0),COLOR00FF00;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE,LINETHICK1,NODRAW;
D:SMA(K,3,1),COLORYELLOW,LINETHICK1,NODRAW;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
IF(COUNT(RSI1>80,3)=3,H,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK8;
IF(COUNT(RSI1<20,3)=3,L,DRAWNULL),POINTDOT,COLORYELLOW,LINETHICK8;
IF(COUNT(K>80,3)=3,H,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK5;
IF(COUNT(K<20,3)=3,L,DRAWNULL),POINTDOT,COLORFF33FF,LINETHICK5;
今日空间:=C-REF(金死叉价,1)COLORGREEN,NODRAW;
尾盘空间:C-金死叉价,NODRAW;
{DRAWTEXT_FIX(1,0.4,0.09,0,STRCAT('今日浮动空间: ',CON2STR(今日空间,2))),COLORCYAN;}
DRAWTEXT_FIX(1,0.6,0.09,0,STRCAT('尾盘5分钟差值: ',CON2STR(尾盘空间,2))),COLORCYAN;
A0:=最大亏损;
今日开仓:=A0/今日空间,NODRAW;
尾盘开仓:A0/尾盘空间,NODRAW;
DRAWTEXT_FIX(ISLASTBAR,0.0,0.09,0.0,'资金管理:合理控制仓位,好点位都是补出来的')COLORRED;
DRAWTEXT_FIX(1,0.7,0.09,0,STRCAT(' 尾盘最大开仓股数: ',CON2STR(尾盘开仓,2))),COLORMAGENTA;

指标公式动态翻译

SHORT赋值:12
LONG赋值:26
M赋值:9
最大亏损赋值:5000
DIF赋值:收盘价的SHORT日指数移动平均 - 收盘价的LONG日指数移动平均
DEA赋值:DIF的M日指数移动平均
MACD赋值:2*(DIF-DEA),STICK
输出
多空分界:收盘价的50日简单移动平均,线宽为1,画青色,POINTDOT
TOZ赋值:收盘价的50日简单移动平均,画黄色,DOTLINE
TMACD赋值:收盘价的50日简单移动平均+(MACD.MACD)*3
HD0赋值:DIF上穿DEA
金收赋值:上次HD0距今天数日前的最低价,画黄色,DOTLINE

当满足条件是否最后一个周期时,在金收位置书写数字,画青色
LD0赋值:DEA上穿DIF
输出
死收:上次LD0距今天数日前的最高价,COLOR00FF00,DOTLINE
JCSC赋值:(M-1)/(M+1)*DEA/(1-2/(M+1))
DD赋值:(MACD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1))
输出
DIF拐头价:(DIF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*收盘价的SHORT日指数移动平均+(SHORT+1)*(LONG-1)*收盘价的LONG日指数移动平均)/(2*((LONG+1)-(SHORT+1)))画黄色,线宽为1
柱变向价赋值:(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*收盘价的SHORT日指数移动平均+(SHORT+1)*(LONG-1)*收盘价的LONG日指数移动平均)/(2*((LONG+1)-(SHORT+1))),画白色,线宽为1

画带状线

画带状线
黄铢消失见顶赋值:如果柱变向价>=DIF拐头价,返回DIF拐头价,否则返回无效数,画黄色,CIRCLEDOT,线宽为1
金叉赋值:如果柱变向价>=DIF拐头价,返回多空分界,否则返回无效数,画黄色,CIRCLEDOT,线宽为1
输出
金死叉价:(JCSC*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*收盘价的SHORT日指数移动平均+(SHORT+1)*(LONG-1)*收盘价的LONG日指数移动平均)/(2*((LONG+1)-(SHORT+1)))画青色,NODRAW
MACD走平时股价赋值:(((M+1)*(2*1日前的DEA*(M-1)+1日前的MACD*(M+1)))/(2*(M+1)*(M-1))+(1日前的收盘价的26日指数移动平均*(26-1)/(26+1))-(1日前的收盘价的12日指数移动平均*(12-1)/(12+1)))*(12+1)*(26+1)/(2*(26-12))
ES赋值:1日前的收盘价的26日指数移动平均
EP赋值:1日前的收盘价的12日指数移动平均
DI赋值:1日前的DIF
输出
DIF穿零价:((12+1)*(26-1)*ES-(26+1)*(12-1)*EP)/(2*(26+1)-2*(12+1)),NODRAW,画白色


当满足条件1时,在横轴0.7纵轴0.01位置书写文字,画青色
ZJ赋值:DIF>DEA
HY赋值:DIF<DEA
XG1赋值:ZJ AND 收盘价>死收 AND 收盘价>多空分界

当满足条件XG1时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000AA

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000055

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR000066

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR000077

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR000088

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为1.7,0不为0则画空心柱.,COLOR000099

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为1.2,0不为0则画空心柱.,COLOR0000AA

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为0.7,0不为0则画空心柱.,COLOR0000CC

当满足条件XG1时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR0000FF
W1赋值: 收盘价<死收 AND ZJ

当满足条件W1时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,COLORFF55FF

当满足条件W1时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLOR880088

当满足条件W1时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLORAA00AA

当满足条件W1时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLORCC00CC

当满足条件W1时,在收盘价和开盘价位置之间画柱状线,宽度为1.1,0不为0则画空心柱.,COLOREE00EE

当满足条件W1时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFF44FF
W2赋值: 收盘价<多空分界 AND ZJ

当满足条件W2时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,COLORFF55FF

当满足条件W2时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLOR880088

当满足条件W2时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLORAA00AA

当满足条件W2时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLORCC00CC

当满足条件W2时,在收盘价和开盘价位置之间画柱状线,宽度为1.1,0不为0则画空心柱.,COLOREE00EE

当满足条件W2时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFF44FF
XG2赋值:收盘价<DIF拐头价 AND HY

当满足条件XG2时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00

当满足条件XG2时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR009900

当满足条件XG2时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00BB00

当满足条件XG2时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00DD00

当满足条件XG2时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR00FF00
XG3赋值:收盘价>DIF拐头价 AND HY

当满足条件XG3时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00

当满足条件XG3时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR009900

当满足条件XG3时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00BB00

当满足条件XG3时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00DD00

当满足条件XG3时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR00FF00
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
输出
K:RSV的3日[1日权重]移动平均,画白色,线宽为1,NODRAW
输出
D:K的3日[1日权重]移动平均,画黄色,线宽为1,NODRAW
LC赋值:1日前的收盘价
RSI1赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100

如果统计3日中满足RSI1>80的天数=3,返回最高价,否则返回无效数,POINTDOT,画绿色,线宽为8

如果统计3日中满足RSI1<20的天数=3,返回最低价,否则返回无效数,POINTDOT,画黄色,线宽为8

如果统计3日中满足K>80的天数=3,返回最高价,否则返回无效数,POINTDOT,画绿色,线宽为5

如果统计3日中满足K<20的天数=3,返回最低价,否则返回无效数,POINTDOT,COLORFF33FF,线宽为5
今日空间赋值:收盘价-1日前的金死叉价画绿色,NODRAW
输出
尾盘空间:收盘价-金死叉价,NODRAW


当满足条件1时,在横轴0.6纵轴0.09位置书写文字,画青色
A0赋值:最大亏损
今日开仓赋值:A0/今日空间,NODRAW
输出
尾盘开仓:A0/尾盘空间,NODRAW

当满足条件是否最后一个周期时,在横轴0.0纵轴0.09位置书写文字画红色

当满足条件1时,在横轴0.7纵轴0.09位置书写文字,画洋红色
 

以上关于量王叠现通达信指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章