通达信火火短线进攻信号指标公式

来源:中金指南

公式指标源码

{金三角主图}
火火进攻线:ema((CLOSE+OPEN)/2,7.618),COLOR0000FF,LINETHICK1;
火火安全线:Ema((CLOSE+OPEN)/2,28.618),COLOR00FF00,LINETHICK1;
stICKLINE(火火进攻线>火火安全线,火火进攻线,火火安全线,0,0),COLOR000080;
STICKLINE(火火进攻线<火火安全线,火火进攻线,火火安全线,0,0),COLOR408000;
JJ:=AMOUNT/vol/100,COLORWHITE,LINETHICK2;
JJ3:=MEMA(MEMA((AMO+REF(AMO,1)+REF(AMO,2))/(V+REF(V,1)+REF(V,2))/100,2),2),COLORLICYAN,LINETHICK2;
JJ4:=MEMA(MEMA((AMO+REF(AMO,1)+REF(AMO,2)+REF(AMO,3))/(V+REF(V,1)+REF(V,2)+REF(V,3))/100,2),2),COLORLIMAGENTA,LINETHICK1;
JJ5:=MEMA(MEMA((AMO+REF(AMO,1)+REF(AMO,2)+REF(AMO,3)+REF(AMO,4))/(V+REF(V,1)+REF(V,2)+REF(V,3)+REF(V,4))/100,2),2),COLORYELLOW,LINETHICK1;
JJ8:=MEMA(MEMA(MA(AMOUNT,8)/MA(VOL,8)/100,2),2),COLORMAGENTA,LINETHICK1;
JJ10:=MEMA(MEMA(MA(AMOUNT,10)/MA(VOL,10)/100,2),2),COLORMAGENTA,LINETHICK1;
JJ13:=MA(AMOUNT,13)/MA(VOL,13)/100,COLORRED;
JJ20:=MEMA(MEMA(MA(AMOUNT,20)/MA(VOL,20)/100,2),2),COLORGREEN,LINETHICK2;
JJ30:=(MA(AMOUNT,30)/MA(VOL,30)/100),COLORBLUE,LINETHICK2;
JJ60:=(MA(AMOUNT,60)/MA(VOL,60)/100),COLORLIBLUE,LINETHICK3;
JJ89:=MEMA(MEMA((MA(AMOUNT,89)/MA(VOL,89)/100),2),2),COLORGRAY,DOTLINE;
JJ120:=MEMA(MEMA(MEMA((MA(AMOUNT,120)/MA(VOL,120)/100),8),8),8),COLORWHITE,LINETHICK3;
JJ240:=MEMA(MEMA(MEMA((MA(AMOUNT,240)/MA(VOL,240)/100),8),8),8),COLORBROWN,LINETHICK4;
JJ480:=MEMA(MEMA(MEMA((MA(AMOUNT,480)/MA(VOL,480)/100),8),8),8),COLORBROWN,LINETHICK5;
顶分型:=REF(HIGH,1)>REF(HIGH,2) AND HIGH<REF(HIGH,1) AND REF(LOW,1)>REF(LOW,2) AND REF(LOW,1)>LOW AND REF(HIGH,1)=HHV(HIGH,10);
DRAWTEXT(顶分型,REF(HIGH,1)/0.91,'【顶】'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.92,'.'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.93,'.'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.94,'.'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.95,'.'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.96,'.'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.97,'.'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.98,'.'),COLORGREEN;
DRAWTEXT(顶分型,REF(HIGH,1)/0.99,'.'),COLORGREEN;
底分型:=REF(HIGH,1)<REF(HIGH,2) AND HIGH>REF(HIGH,1) AND REF(LOW,1)<REF(LOW,2) AND REF(LOW,1)<LOW AND REF(LOW,1)=LLV(LOW,10);
DRAWTEXT(底分型,REF(LOW,1)*0.91,'【底】'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.92,'.'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.93,'.'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.94,'.'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.95,'.'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.96,'.'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.97,'.'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.98,'.'),COLORRED;
DRAWTEXT(底分型,REF(LOW,1)*0.99,'.'),COLORRED;
一穿三:=crOSS(C,JJ5) AND CROSS(C,JJ8) AND CROSS(C,JJ20);
STICKLINE(一穿三,C,O,3.1,0),COLORFF00FF;
STICKLINE(一穿三,H,L,0,0),COLORFF00FF;
DRAWTEXT(一穿三,LOW,'←穿三'),COLORFF00FF;
死穿:=CROSS(JJ5,C) AND CROSS(JJ8,C) AND CROSS(JJ20,C);
STICKLINE(死穿,C,O,3.1,0),COLORFF8000;
STICKLINE(死穿,H,L,0,0),COLORFF8000;
DRAWTEXT(死穿,H,'←死穿'),COLORFF8000;
涨停:=IF(REF(C,1)*1.1-C<0.005,1,0);
STICKLINE((CLOSE/REF(CLOSE,1)-1)*100>=9.5,C,O,3.1,0),COLORYELLOW;
STICKLINE((CLOSE/REF(CLOSE,1)-1)*100>=9.5,H,L,0,0),COLORYELLOW;
STICKLINE((CLOSE/REF(CLOSE,1)-1)*100<=-9.5,C,O,3.1,0),COLOR00FF00;
STICKLINE((CLOSE/REF(CLOSE,1)-1)*100<=-9.5,H,L,0,0),COLOR00FF00;
金叉:=CROSS(JJ5,JJ8) AND C>JJ5 AND C>JJ20;
STICKLINE(金叉,C,O,3.1,0),COLOR0000FF;
STICKLINE(金叉,H,L,0,0),COLOR0000FF;
DRAWTEXT(金叉,LOW*0.95,'【多】'),COLOR8000FF;
DRAWTEXT(金叉,LOW*0.96,'.'),COLOR8000FF;
DRAWTEXT(金叉,LOW*0.97,'.'),COLOR8000FF;
DRAWTEXT(金叉,LOW*0.98,'.'),COLOR8000FF;
DRAWTEXT(金叉,LOW*0.99,'.'),COLOR8000FF;
跌8点多:=C<REF(C,1)*0.935 OR (O>REF(C,1)*1.05 AND REF(涨停,1) AND C<O*0.96);
金三角:=COUNT(REF(跌8点多,1),10) AND 涨停 AND C>JJ AND JJ5>JJ8 AND JJ8>JJ10;
STICKLINE(金三角,C,O,3.1,0),COLORYELLOW;
STICKLINE(金三角,H,L,0,0),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.91,'▲金三角▲'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.92,'.'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.93,'.'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.94,'.'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.95,'.'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.96,'.'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.97,'.'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.98,'.'),COLORYELLOW;
DRAWTEXT(金三角,LOW*0.99,'.'),COLORYELLOW;
BUY1:=zig(3,10);
SELL1:=MA(BUY1,2);
出B:DRAWICON(CROSS(BUY1,SELL1),LOW*0.95,7);
出底:DRAWICON(CROSS(SELL1,BUY1),HIGH/0.95,8);
B点标记:=BArslAST(CROSS(BUY1,SELL1));
B点成交量:=IF(B点标记=0,VOL,0);
B点一点五倍:=B点成交量*1.5;
是否有S点:=SUM(CROSS(SELL1,BUY1),B点标记);{0:在B~S之间,1:在S~B之间};
B点成交量辅助:=HHV(B点一点五倍,B点标记+1);
首次倍数1:=VOL>B点成交量辅助;
首次倍数2:=VOL>B点成交量辅助 AND 是否有S点=0;
倍量次数:=SUM(首次倍数2,B点标记+1);
首次倍量:=CROSS(倍量次数,0.5)*2;
B点收价1:=HHV(CLOSE,B点标记+1);
B点收价2:=REF(B点收价1,B点标记);
新价大于B价:=CLOSE>B点收价2;
G点:=首次倍量 AND 新价大于B价;
DRAWTEXT(G点,LOW*0.91,'▲G点▲'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.10,0.01,1, DYBLOCK), COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.20,0.01,1, HYBLOCK), COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.55,0.10,1, GNBLOCK), COLORWHITE;
{神奇九转}
B:=C<REF(C,4);
N:=CURRBARSCOUNT;
B1:=(N=6 AND REFXV(COUNT(B,6),5)=6) OR (N=7 AND REFXV(COUNT(B,7),6)=7) OR (N=8 AND REFXV(COUNT(B,8),7)=8) OR (N>=9 AND REFXV(COUNT(B,9),8)=9);
DRAWNUMBER(B1 AND REF(B,1)=0,L,1),COLORMAGENTA;
B2:=(N=5 AND REFXV(COUNT(B,6),4)=6) OR (N=6 AND REFXV(COUNT(B,7),5)=7) OR (N=7 AND REFXV(COUNT(B,8),6)=8) OR (N>=8 AND REFXV(COUNT(B,9),7)=9);
DRAWNUMBER(B2 AND REF(B,2)=0,L,2),COLORMAGENTA;
B8:=(N=1 AND COUNT(B,8)=8) OR (N>=2 AND REFXV(COUNT(B,9),1)=9);
DRAWNUMBER(B8 AND REF(B,8)=0,L,8),COLORMAGENTA;
B9:=(N>=1 AND COUNT(B,9)=9);
DRAWNUMBER(B9 AND REF(B,9)=0,L,9),COLORYELLOW;
S:=C>REF(C,4);
S1:=(N=6 AND REFXV(COUNT(S,6),5)=6) OR (N=7 AND REFXV(COUNT(S,7),6)=7) OR (N=8 AND REFXV(COUNT(S,8),7)=8) OR (N>=9 AND REFXV(COUNT(S,9),8)=9);
DRAWNUMBER(S1 AND REF(S,1)=0,H,1),COLORMAGENTA,DRAWAbovE;
S2:=(N=5 AND REFXV(COUNT(S,6),4)=6) OR (N=6 AND REFXV(COUNT(S,7),5)=7) OR (N=7 AND REFXV(COUNT(S,8),6)=8) OR (N>=8 AND REFXV(COUNT(S,9),7)=9);
DRAWNUMBER(S2 AND REF(S,2)=0,H,2),COLORMAGENTA,DRAWABOVE;
S8:=(N=1 AND COUNT(S,8)=8) OR (N>=2 AND REFXV(COUNT(S,9),1)=9);
DRAWNUMBER(S8 AND REF(S,8)=0,H,8),COLORMAGENTA,DRAWABOVE;
S9:=(N>=1 AND COUNT(S,9)=9);
DRAWNUMBER(S9 AND REF(S,9)=0,H,9),COLORGREEN,DRAWABOVE;

公式指标动态翻译

输出
火火进攻线:(收盘价+开盘价)/2的7.618日指数移动平均,COLOR0000FF,线宽为1
输出
火火安全线:(收盘价+开盘价)/2的28.618日指数移动平均,COLOR00FF00,线宽为1

当满足条件火火进攻线>火火安全线时,在火火进攻线和火火安全线位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR000080

当满足条件火火进攻线<火火安全线时,在火火进攻线和火火安全线位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR408000
JJ赋值:成交额(元)/成交量(手)/100,画白色,线宽为2
JJ3赋值:(成交额(元)+1日前的成交额(元)+2日前的成交额(元))/(成交量(手)+1日前的成交量(手)+2日前的成交量(手))/100的2日平滑移动平均的2日平滑移动平均,画淡青色,线宽为2
JJ4赋值:(成交额(元)+1日前的成交额(元)+2日前的成交额(元)+3日前的成交额(元))/(成交量(手)+1日前的成交量(手)+2日前的成交量(手)+3日前的成交量(手))/100的2日平滑移动平均的2日平滑移动平均,画淡洋红色,线宽为1
JJ5赋值:(成交额(元)+1日前的成交额(元)+2日前的成交额(元)+3日前的成交额(元)+4日前的成交额(元))/(成交量(手)+1日前的成交量(手)+2日前的成交量(手)+3日前的成交量(手)+4日前的成交量(手))/100的2日平滑移动平均的2日平滑移动平均,画黄色,线宽为1
JJ8赋值:成交额(元)的8日简单移动平均/成交量(手)的8日简单移动平均/100的2日平滑移动平均的2日平滑移动平均,画洋红色,线宽为1
JJ10赋值:成交额(元)的10日简单移动平均/成交量(手)的10日简单移动平均/100的2日平滑移动平均的2日平滑移动平均,画洋红色,线宽为1
JJ13赋值:成交额(元)的13日简单移动平均/成交量(手)的13日简单移动平均/100,画红色
JJ20赋值:成交额(元)的20日简单移动平均/成交量(手)的20日简单移动平均/100的2日平滑移动平均的2日平滑移动平均,画绿色,线宽为2
JJ30赋值:(成交额(元)的30日简单移动平均/成交量(手)的30日简单移动平均/100),画蓝色,线宽为2
JJ60赋值:(成交额(元)的60日简单移动平均/成交量(手)的60日简单移动平均/100),画淡蓝色,线宽为3
JJ89赋值:(成交额(元)的89日简单移动平均/成交量(手)的89日简单移动平均/100)的2日平滑移动平均的2日平滑移动平均,画深灰色,DOTLINE
JJ120赋值:(成交额(元)的120日简单移动平均/成交量(手)的120日简单移动平均/100)的8日平滑移动平均的8日平滑移动平均的8日平滑移动平均,画白色,线宽为3
JJ240赋值:(成交额(元)的240日简单移动平均/成交量(手)的240日简单移动平均/100)的8日平滑移动平均的8日平滑移动平均的8日平滑移动平均,画棕色,线宽为4
JJ480赋值:(成交额(元)的480日简单移动平均/成交量(手)的480日简单移动平均/100)的8日平滑移动平均的8日平滑移动平均的8日平滑移动平均,画棕色,线宽为5
顶分型赋值:1日前的最高价>2日前的最高价 AND 最高价<1日前的最高价 AND 1日前的最低价>2日前的最低价 AND 1日前的最低价>最低价 AND 1日前的最高价=10日内最高价的最高值

当满足条件顶分型时,在1日前的最高价/0.91位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.92位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.93位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.94位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.95位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.96位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.97位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.98位置书写文字,画绿色

当满足条件顶分型时,在1日前的最高价/0.99位置书写文字,画绿色
底分型赋值:1日前的最高价<2日前的最高价 AND 最高价>1日前的最高价 AND 1日前的最低价<2日前的最低价 AND 1日前的最低价<最低价 AND 1日前的最低价=10日内最低价的最低值

当满足条件底分型时,在1日前的最低价*0.91位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.92位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.93位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.94位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.95位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.96位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.97位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.98位置书写文字,画红色

当满足条件底分型时,在1日前的最低价*0.99位置书写文字,画红色
一穿三赋值:收盘价上穿JJ5 AND 收盘价上穿JJ8 AND 收盘价上穿JJ20

当满足条件一穿三时,在收盘价和开盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLORFF00FF

当满足条件一穿三时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF00FF

当满足条件一穿三时,在最低价位置书写文字,COLORFF00FF
死穿赋值:JJ5上穿收盘价 AND JJ8上穿收盘价 AND JJ20上穿收盘价

当满足条件死穿时,在收盘价和开盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLORFF8000

当满足条件死穿时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF8000

当满足条件死穿时,在最高价位置书写文字,COLORFF8000
涨停赋值:如果1日前的收盘价*1.1-收盘价<0.005,返回1,否则返回0

当满足条件(收盘价/1日前的收盘价-1)*100>=9.5时,在收盘价和开盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,画黄色

当满足条件(收盘价/1日前的收盘价-1)*100>=9.5时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色

当满足条件(收盘价/1日前的收盘价-1)*100<=-9.5时,在收盘价和开盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLOR00FF00

当满足条件(收盘价/1日前的收盘价-1)*100<=-9.5时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00
金叉赋值:JJ5上穿JJ8 AND 收盘价>JJ5 AND 收盘价>JJ20

当满足条件金叉时,在收盘价和开盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLOR0000FF

当满足条件金叉时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000FF

当满足条件金叉时,在最低价*0.95位置书写文字,COLOR8000FF

当满足条件金叉时,在最低价*0.96位置书写文字,COLOR8000FF

当满足条件金叉时,在最低价*0.97位置书写文字,COLOR8000FF

当满足条件金叉时,在最低价*0.98位置书写文字,COLOR8000FF

当满足条件金叉时,在最低价*0.99位置书写文字,COLOR8000FF
跌8点多赋值:收盘价<1日前的收盘价*0.935 OR (开盘价>1日前的收盘价*1.05 AND 1日前的涨停 AND 收盘价<开盘价*0.96)
金三角赋值:统计10日中满足1日前的跌8点多的天数 AND 涨停 AND 收盘价>JJ AND JJ5>JJ8 AND JJ8>JJ10

当满足条件金三角时,在收盘价和开盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,画黄色

当满足条件金三角时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色

当满足条件金三角时,在最低价*0.91位置书写文字,画黄色

当满足条件金三角时,在最低价*0.92位置书写文字,画黄色

当满足条件金三角时,在最低价*0.93位置书写文字,画黄色

当满足条件金三角时,在最低价*0.94位置书写文字,画黄色

当满足条件金三角时,在最低价*0.95位置书写文字,画黄色

当满足条件金三角时,在最低价*0.96位置书写文字,画黄色

当满足条件金三角时,在最低价*0.97位置书写文字,画黄色

当满足条件金三角时,在最低价*0.98位置书写文字,画黄色

当满足条件金三角时,在最低价*0.99位置书写文字,画黄色
BUY1赋值:收盘价10%的之字转向
SELL1赋值:BUY1的2日简单移动平均
输出
出B:当满足条件BUY1上穿SELL1时,在最低价*0.95位置画7号图标
输出
出底:当满足条件SELL1上穿BUY1时,在最高价/0.95位置画8号图标
B点标记赋值:上次BUY1上穿SELL1距今天数
B点成交量赋值:如果B点标记=0,返回成交量(手),否则返回0
B点一点五倍赋值:B点成交量*1.5
是否有S点赋值:SELL1上穿BUY1的B点标记日累和

B点成交量辅助赋值:B点标记+1日内B点一点五倍的最高值
首次倍数1赋值:成交量(手)>B点成交量辅助
首次倍数2赋值:成交量(手)>B点成交量辅助 AND 是否有S点=0
倍量次数赋值:首次倍数2的B点标记+1日累和
首次倍量赋值:倍量次数上穿0.5*2
B点收价1赋值:B点标记+1日内收盘价的最高值
B点收价2赋值:B点标记日前的B点收价1
新价大于B价赋值:收盘价>B点收价2
G点赋值:首次倍量 AND 新价大于B价

当满足条件G点时,在最低价*0.91位置书写文字,画黄色

当满足条件是否最后一个周期时,在横轴0.10纵轴0.01位置书写文字, 画黄色

当满足条件是否最后一个周期时,在横轴0.20纵轴0.01位置书写文字, 画黄色

当满足条件是否最后一个周期时,在横轴0.55纵轴0.10位置书写文字, 画白色
B赋值:收盘价<4日前的收盘价
N赋值:到最后交易的周期
B1赋值:(N=6 AND 5日后的(未作平滑处理)统计6日中满足B的天数=6) OR (N=7 AND 6日后的(未作平滑处理)统计7日中满足B的天数=7) OR (N=8 AND 7日后的(未作平滑处理)统计8日中满足B的天数=8) OR (N>=9 AND 8日后的(未作平滑处理)统计9日中满足B的天数=9)

当满足条件B1ANDREF(B,1)=0时,在最低价位置书写数字,画洋红色
B2赋值:(N=5 AND 4日后的(未作平滑处理)统计6日中满足B的天数=6) OR (N=6 AND 5日后的(未作平滑处理)统计7日中满足B的天数=7) OR (N=7 AND 6日后的(未作平滑处理)统计8日中满足B的天数=8) OR (N>=8 AND 7日后的(未作平滑处理)统计9日中满足B的天数=9)

当满足条件B2ANDREF(B,2)=0时,在最低价位置书写数字,画洋红色
B8赋值:(N=1 AND 统计8日中满足B的天数=8) OR (N>=2 AND 1日后的(未作平滑处理)统计9日中满足B的天数=9)

当满足条件B8ANDREF(B,8)=0时,在最低价位置书写数字,画洋红色
B9赋值:(N>=1 AND 统计9日中满足B的天数=9)

当满足条件B9ANDREF(B,9)=0时,在最低价位置书写数字,画黄色
S赋值:收盘价>4日前的收盘价
S1赋值:(N=6 AND 5日后的(未作平滑处理)统计6日中满足S的天数=6) OR (N=7 AND 6日后的(未作平滑处理)统计7日中满足S的天数=7) OR (N=8 AND 7日后的(未作平滑处理)统计8日中满足S的天数=8) OR (N>=9 AND 8日后的(未作平滑处理)统计9日中满足S的天数=9)

当满足条件S1ANDREF(S,1)=0时,在最高价位置书写数字,画洋红色,显示在位置之上
S2赋值:(N=5 AND 4日后的(未作平滑处理)统计6日中满足S的天数=6) OR (N=6 AND 5日后的(未作平滑处理)统计7日中满足S的天数=7) OR (N=7 AND 6日后的(未作平滑处理)统计8日中满足S的天数=8) OR (N>=8 AND 7日后的(未作平滑处理)统计9日中满足S的天数=9)

当满足条件S2ANDREF(S,2)=0时,在最高价位置书写数字,画洋红色,显示在位置之上
S8赋值:(N=1 AND 统计8日中满足S的天数=8) OR (N>=2 AND 1日后的(未作平滑处理)统计9日中满足S的天数=9)

当满足条件S8ANDREF(S,8)=0时,在最高价位置书写数字,画洋红色,显示在位置之上
S9赋值:(N>=1 AND 统计9日中满足S的天数=9)

当满足条件S9ANDREF(S,9)=0时,在最高价位置书写数字,画绿色,显示在位置之上
 

火火短线进攻信号指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章