通达信股票抄底选股指标公式

来源:中金指南

公式指标源码

N:=24;
AN:=ma(C,N);
A:=REF(C,4)>REF(C,3);
A1:=REF(C,3)>REF(C,2);
A2:=REF(C,2)>REF(C,1);
A3:=A AND A1 AND A2;
A4:=C/REF(C,1)>1.065;
A5:=BArslAst(A4);
A6:= A5>6 AND C>REF(C,1)*1.03 ;
B:=ema(MAX(C-REF(C,1),0),5)/EMA(Abs(C-REF(C,1)),5)*100;
B1:=EMA(MAX(C-REF(C,1),0),8)/EMA(ABS(C-REF(C,1)),8)*100;
B2:=REF(C,3)>REF(C,2) AND REF(C,2)>REF(C,1) AND REF(C,4)>REF(C,3);
B3:=crOSS(B,20) AND (CROSS(B,B1) );
XG:= A3 AND A6 AND B3 ;
D1:=L<AN;
D2:=C>AN;
D3:=C/REF(C,1)<AN;
D4:=CROSS(C,AN) AND V/REF(MA(V,5),1)>1.016;
XG1:= D3 AND D4 AND D1 AND D2 ;
股票抄底:XG1 AND XG;

公式指标动态翻译

N赋值:24
AN赋值:收盘价的N日简单移动平均
A赋值:4日前的收盘价>3日前的收盘价
A1赋值:3日前的收盘价>2日前的收盘价
A2赋值:2日前的收盘价>1日前的收盘价
A3赋值:A AND A1 AND A2
A4赋值:收盘价/1日前的收盘价>1.065
A5赋值:上次A4距今天数
A6赋值: A5>6 AND 收盘价>1日前的收盘价*1.03 
B赋值:收盘价-1日前的收盘价和0的较大值的5日指数移动平均/收盘价-1日前的收盘价的绝对值的5日指数移动平均*100
B1赋值:收盘价-1日前的收盘价和0的较大值的8日指数移动平均/收盘价-1日前的收盘价的绝对值的8日指数移动平均*100
B2赋值:3日前的收盘价>2日前的收盘价 AND 2日前的收盘价>1日前的收盘价 AND 4日前的收盘价>3日前的收盘价
B3赋值:B上穿20 AND (B上穿B1 )
XG赋值: A3 AND A6 AND B3 
D1赋值:最低价<AN
D2赋值:收盘价>AN
D3赋值:收盘价/1日前的收盘价<AN
D4赋值:收盘价上穿AN AND 成交量(手)/1日前的成交量(手)的5日简单移动平均>1.016
XG1赋值: D3 AND D4 AND D1 AND D2 
输出
股票抄底:XG1 AND XG
 

股票抄底选股指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章