通达信量价弱转强趋势指标公式

来源:中金指南

公式指标源码

{买入启动牛股}
AA05:=ma(C,5),COLOR0099CC;五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(ema((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10),COLOR00FF00;AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
{VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);}
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND crOSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
{DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;}
{量能}
volUME:=VOL,VOLstICK;
AA:=VOL>REF(V,1)*1.9;{倍量}
{AA1:=VOL<REF(LLV(VOL,13),1);}
AA1:=V/REF(V,1)<=0.6;{缩倍量}
{STICKLINE(AA,0,VOLUME,2,0),COLORYELLOW;
STICKLINE(AA1,0,VOLUME,2,0),COLOR1D7300;}
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5。,TOTAL,MTIME);
VVOL:=IF(CURRBARSCOUNT=1,AMOUNT/100000000*TOTAL/CTIME,DRAWNULL),NODRAW;
额:=AMOUNT/100000000,VOLSTICK;{COLORFF00FF}
MAVOL1:=EMA((EMA(额,2)+EMA(额,3))/2,1);
MAVOL2:=EMA(EMA(额,8),1);
AMO135:=MA(AMO/100000000,135),COLORGREEN;
VAR1:=AMOUNT/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
流入亿:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/100000000,COLORRED,NODRAW;
流出亿:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN- LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-AMOUNT/2))/100000000,COLORMAGENTA,NODRAW;
差亿:=流入亿+流出亿,COLORRED,NODRAW;
净:=EMA(EMA(差亿,2),2),COLOR00FFFF,NODRAW;
净1:=EMA((EMA(净,2)+EMA(净,3))/2,1);{EMA(净,2);}
流:=EMA(净1,8);
净流:=EMA(净1+流,3)*1.23,COLORLIRED;{原3*/1.23*}
GJJ:=EMA(净流,8);
LLJX:=EMA((EMA(净流,2)+EMA(净流,3))/2,1);
流量基线:=GJJ,COLORYELLOW,LINETHICK2;
流量:=LLJX,COLORWHITE,LINETHICK2;
净流量:=净流,COLORMAGENTA,LINETHICK2;
流量上穿:=BETWEEN(BArslASTCOUNT(流量>流量基线),1,2);
资金净流上穿:=BETWEEN(BARSLASTCOUNT(净流量>流量),1,2);
成交量上穿:=BETWEEN(BARSLASTCOUNT(MAVOL1>MAVOL2),1,2);
{主力监控 筹码}
EEDDS5:=EMA(EMA(CLOSE,9),9);
主力监控:=(EEDDS5-REF(EEDDS5,1))/REF(EEDDS5,1);
好选股:=CROSS(主力监控,0);
EEDDS1:=IF(好选股,1,0),LINETHICK1,COLORRED;
EEDDS2:=IF(主力监控>REF(主力监控,1) AND 主力监控>0,主力监控,0),COLORRED,NODRAW;
EEDDS4:=100*WINNER(CLOSE*0.95);
{STICKLINE(EEDDS4>50 AND COST(85)<CLOSE AND 主力监控>0,主力监控,0,1,0),COLORMAGENTA;
EEDDS3:IF(EEDDS4>50 AND COST(85)<CLOSE AND 主力监控>0,主力监控,0),COLORFF00FF,NODRAW;}
变强:=主力监控>REF(主力监控,1) AND 主力监控>0;
集中:=EEDDS4>50 AND COST(85)<CLOSE AND 主力监控>0;
M:=macd.MacD(12,26,9),NODRAW;
B:=C/REF(C,1)>1.098;
A:=V/REF(V,1)>2 AND V/MA(V,60)>2;
启动:=CROSS(M,0) AND B AND A,COLORRED;
J:=REF(H,BARSLAST(启动)),NODRAW;
选股:=CROSS(C,J);
转强:((加仓 OR 强势狙击) AND 变强)*2,COLORYELLOW;
筹码强势:((加仓 OR 强势狙击) AND 集中)*2,COLORMAGENTA;
量能确立:((加仓 OR 强势狙击) AND (资金净流上穿 AND 成交量上穿))*3,COLORRED;
量价启动:((启动 OR 选股) AND (变强 OR 集中))*4,COLORLIMAGENTA;
XG买入牛股:加仓 AND (资金净流上穿 OR 成交量上穿 OR 流量上穿);
XG再次启动:强势狙击 AND (资金净流上穿 OR 成交量上穿 OR 流量上穿);

公式指标动态翻译

AA05赋值:收盘价的5日简单移动平均,COLOR0099CC
五日乖离率赋值:(收盘价-AA05)/AA05*100
BB05赋值:(AA05/1日前的AA05-1)*100的反正切*180/3.1416
速度5赋值:(AA05-1日前的AA05)/1日前的AA05的3日指数移动平均*100的3日[1日权重]移动平均
加速度5赋值:(速度5-1日前的速度5)的3日指数移动平均
AA10赋值:收盘价的10日简单移动平均,COLOR00FF00
AA20赋值:收盘价的20日简单移动平均
BB10赋值:(AA10/1日前的AA10-1)*100的反正切*180/3.1416
AA30赋值:收盘价的30日简单移动平均
三拾日乖离率赋值:(收盘价-AA30)/AA30*100
BB30赋值:(AA30/1日前的AA30-1)*100的反正切*180/3.1416
强势狙击赋值:BB30>30ANDBB10>45ANDCROSS(BB05,60)的10日过滤
加仓赋值:统计5日中满足BB05上穿30的天数>=1ANDAA05>1日前的AA05AND三拾日乖离率>1日前的三拾日乖离率ANDAA10>1日前的AA10AND加速度5>1日前的加速度5AND速度5>1日前的速度5的10日过滤 
清仓赋值:统计5日中满足30上穿BB05的天数>=1AND(收盘价>AA30ORO>AA30)ANDAA05<1日前的AA05AND三拾日乖离率<1日前的三拾日乖离率ANDAA10<1日前的AA10的10日过滤
JC赋值:0上穿五日乖离率 AND 三拾日乖离率<1日前的三拾日乖离率 AND AA10>1日前的AA10 
减仓赋值:JC的10日过滤
MR赋值:统计3日中满足五日乖离率上穿0的天数>=1 AND 三拾日乖离率>1日前的三拾日乖离率 AND AA05>1日前的AA05 AND (收盘价/1日前的收盘价-1)*100>5 AND 1日前的收盘价<AA30
买入赋值:MR的10日过滤
VOLUME赋值:成交量(手),VOLSTICK
AA赋值:成交量(手)>1日前的成交量(手)*1.9
AA1赋值:成交量(手)/1日前的成交量(手)<=0.6
TOTAL赋值:如果周期类型=1,返回5,否则返回如果周期类型=2,返回15,否则返回如果周期类型=3,返回30,否则返回如果周期类型=4,返回60,否则返回如果周期类型=5,返回总分钟数,否则返回1
MTIME赋值:当前离开盘分钟数关于TOTAL的模
CTIME赋值:如果MTIME<0.5。,返回TOTAL,否则返回MTIME
VVOL赋值:如果到最后交易的周期=1,返回成交额(元)/100000000*TOTAL/CTIME,否则返回无效数,NODRAW
额赋值:成交额(元)/100000000,VOLSTICK
MAVOL1赋值:(额的2日指数移动平均+额的3日指数移动平均)/2的1日指数移动平均
MAVOL2赋值:额的8日指数移动平均的1日指数移动平均
AMO135赋值:成交额(元)/100000000的135日简单移动平均,画绿色
VAR1赋值:成交额(元)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
流入亿赋值:如果收阳线,返回VAR1*(最高价-最低价),否则返回如果收阴线,返回VAR1*((最高价-开盘价)+(收盘价-最低价)),否则返回成交额(元)/2/100000000,画红色,NODRAW
流出亿赋值:如果收阳线,返回0-VAR1*((最高价-收盘价)+(开盘价-最低价)),否则返回如果收阴线,返回0-VAR1*(最高价-最低价),否则返回0-成交额(元)/2/100000000,画洋红色,NODRAW
差亿赋值:流入亿+流出亿,画红色,NODRAW
净赋值:差亿的2日指数移动平均的2日指数移动平均,COLOR00FFFF,NODRAW
净1赋值:(净的2日指数移动平均+净的3日指数移动平均)/2的1日指数移动平均
流赋值:净1的8日指数移动平均
净流赋值:净1+流的3日指数移动平均*1.23,画淡红色
GJJ赋值:净流的8日指数移动平均
LLJX赋值:(净流的2日指数移动平均+净流的3日指数移动平均)/2的1日指数移动平均
流量基线赋值:GJJ,画黄色,线宽为2
流量赋值:LLJX,画白色,线宽为2
净流量赋值:净流,画洋红色,线宽为2
流量上穿赋值:条件连续成立次数位于1和2之间
资金净流上穿赋值:条件连续成立次数位于1和2之间
成交量上穿赋值:条件连续成立次数位于1和2之间
EEDDS5赋值:收盘价的9日指数移动平均的9日指数移动平均
主力监控赋值:(EEDDS5-1日前的EEDDS5)/1日前的EEDDS5
好选股赋值:主力监控上穿0
EEDDS1赋值:如果好选股,返回1,否则返回0,线宽为1,画红色
EEDDS2赋值:如果主力监控>1日前的主力监控AND主力监控>0,返回主力监控,否则返回0,画红色,NODRAW
EEDDS4赋值:100*以收盘价*0.95计算的获利盘比例
变强赋值:主力监控>1日前的主力监控 AND 主力监控>0
集中赋值:EEDDS4>50 AND 获利盘为85%的成本分布<收盘价 AND 主力监控>0
M赋值:平滑异同平均的MACD(12,26,9),NODRAW
B赋值:收盘价/1日前的收盘价>1.098
A赋值:成交量(手)/1日前的成交量(手)>2 AND 成交量(手)/成交量(手)的60日简单移动平均>2
启动赋值:M上穿0 AND B AND A,画红色
J赋值:上次启动距今天数日前的最高价,NODRAW
选股赋值:收盘价上穿J
输出
转强:((加仓 OR 强势狙击) AND 变强)*2,画黄色
输出
筹码强势:((加仓 OR 强势狙击) AND 集中)*2,画洋红色
输出
量能确立:((加仓 OR 强势狙击) AND (资金净流上穿 AND 成交量上穿))*3,画红色
输出
量价启动:((启动 OR 选股) AND (变强 OR 集中))*4,画淡洋红色
输出
XG买入牛股:加仓 AND (资金净流上穿 OR 成交量上穿 OR 流量上穿)
输出
XG再次启动:强势狙击 AND (资金净流上穿 OR 成交量上穿 OR 流量上穿)

量价弱转强趋势指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章