通达信筹码趋势启动指标公式

来源:中金指南

公式指标源码

X_1:=CLOSE/REF(CLOSE,1)>1.02;
X_2:=vol>ma(VOL,5);
X_3:=X_1 AND X_2;
X_4:=IF(X_3,70,0);
X_5:=X_4;
X_6:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
X_7:=IF(CLOSE>OPEN,X_6*(HIGH-LOW),IF(CLOSE<OPEN,X_6*(HIGH-OPEN+(CLOSE-LOW)),VOL/2));
X_8:=X_7/VOL*100;
X_9:=X_8>=80;
X_10:=ATAN((ema(CLOSE,5)/REF(EMA(CLOSE,5),1)-1)*100)*57.299999;
X_11:=ATAN((EMA(CLOSE,10)/REF(EMA(CLOSE,10),1)-1)*100)*57.299999;
X_12:=ATAN((EMA(CLOSE,20)/REF(EMA(CLOSE,20),1)-1)*100)*57.299999;
X_13:=X_10>=60 AND X_11>13;
X_14:=IF(CLOSE>REF(CLOSE,1),88,0);
X_15:=IF(CLOSE/REF(CLOSE,1)>1.02 AND HIGH/CLOSE<1.01 AND X_14>0,91,0);
X_16:=FILTER(X_15>1,5);
X_17:=MA(CLOSE,90);
X_18:=MA(CLOSE,288);
X_19:=IF(1.1>SMA(CLOSE,2,1)/SMA(CLOSE,13,2)>1.03,SMA(HIGH,21,5)*1.05,SMA(HIGH,21,2)*1.05);
X_20:=IF(1.09>SMA(CLOSE,5,1)/SMA(CLOSE,15,1)>0.3,SMA(LOW,10,1),SMA(LOW,5,1));
X_21:=IF(MA(VOL,2)>MA(VOL,3)/2>MA(VOL,5),SMA(HIGH,2,1),SMA(CLOSE,3,1));
X_22:=IF(MA(VOL,3)>MA(VOL,5)>MA(VOL,9),SMA(CLOSE,3,1),SMA(CLOSE,5,1));
X_23:=crOSS(X_21,X_19) OR CROSS(X_17,X_20) OR CROSS(X_19,X_18);
X_24:=X_16 OR X_23;
X_25:=CLOSE/REF(CLOSE,3)*100-100;
X_26:=stICKLINE(X_25>12,0,50,2,0);
X_27:=MA(CLOSE,5);
X_28:=MA(CLOSE,10);
X_29:=MA(VOL,10);
X_30:=HHV(HIGH,5)=HHV(HIGH,0) AND BARSCOUNT(CLOSE)>=5;
X_31:=CLOSE>REF(CLOSE,1)*1.02;
X_32:=VOL>X_29;
X_33:=OPEN>X_28 AND CLOSE>X_27;
X_34:=X_30 AND X_31 AND X_32 AND X_33;
X_35:=X_25 OR X_34;
X_5 AND X_9 AND X_13 AND X_24 AND X_35,COLORMAGENTA,LINETHICK4;

公式指标动态翻译

X_1赋值:收盘价/1日前的收盘价>1.02
X_2赋值:成交量(手)>成交量(手)的5日简单移动平均
X_3赋值:X_1 AND X_2
X_4赋值:如果X_3,返回70,否则返回0
X_5赋值:X_4
X_6赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
X_7赋值:如果收阳线,返回X_6*(最高价-最低价),否则返回如果收阴线,返回X_6*(最高价-开盘价+(收盘价-最低价)),否则返回成交量(手)/2
X_8赋值:X_7/成交量(手)*100
X_9赋值:X_8>=80
X_10赋值:(收盘价的5日指数移动平均/1日前的收盘价的5日指数移动平均-1)*100的反正切*57.299999
X_11赋值:(收盘价的10日指数移动平均/1日前的收盘价的10日指数移动平均-1)*100的反正切*57.299999
X_12赋值:(收盘价的20日指数移动平均/1日前的收盘价的20日指数移动平均-1)*100的反正切*57.299999
X_13赋值:X_10>=60 AND X_11>13
X_14赋值:如果收盘价>1日前的收盘价,返回88,否则返回0
X_15赋值:如果收盘价/1日前的收盘价>1.02ANDHIGH/收盘价<1.01ANDX_14>0,返回91,否则返回0
X_16赋值:X_15>1的5日过滤
X_17赋值:收盘价的90日简单移动平均
X_18赋值:收盘价的288日简单移动平均
X_19赋值:如果1.1>收盘价的2日[1日权重]移动平均/收盘价的13日[2日权重]移动平均>1.03,返回最高价的21日[5日权重]移动平均*1.05,否则返回最高价的21日[2日权重]移动平均*1.05
X_20赋值:如果1.09>收盘价的5日[1日权重]移动平均/收盘价的15日[1日权重]移动平均>0.3,返回最低价的10日[1日权重]移动平均,否则返回最低价的5日[1日权重]移动平均
X_21赋值:如果成交量(手)的2日简单移动平均>成交量(手)的3日简单移动平均/2>成交量(手)的5日简单移动平均,返回最高价的2日[1日权重]移动平均,否则返回收盘价的3日[1日权重]移动平均
X_22赋值:如果成交量(手)的3日简单移动平均>成交量(手)的5日简单移动平均>成交量(手)的9日简单移动平均,返回收盘价的3日[1日权重]移动平均,否则返回收盘价的5日[1日权重]移动平均
X_23赋值:X_21上穿X_19 OR X_17上穿X_20 OR X_19上穿X_18
X_24赋值:X_16 OR X_23
X_25赋值:收盘价/3日前的收盘价*100-100
X_26赋值:当满足条件X_25>12时,在0和50位置之间画柱状线,宽度为2,0不为0则画空心柱.
X_27赋值:收盘价的5日简单移动平均
X_28赋值:收盘价的10日简单移动平均
X_29赋值:成交量(手)的10日简单移动平均
X_30赋值:5日内最高价的最高值=0日内最高价的最高值 AND 收盘价的有效数据周期数>=5
X_31赋值:收盘价>1日前的收盘价*1.02
X_32赋值:成交量(手)>X_29
X_33赋值:开盘价>X_28 AND 收盘价>X_27
X_34赋值:X_30 AND X_31 AND X_32 AND X_33
X_35赋值:X_25 OR X_34

X_5 AND X_9 AND X_13 AND X_24 AND X_35,画洋红色,线宽为4
 

筹码趋势启动指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章