通达信高点划线主图指标公式

来源:中金指南

公式指标源码

趋势:ma(MA(CLOSE,3),3),COLOR00DD00;
持股:IF(C>趋势,趋势,DRAWNULL),COLORDD00DD;
N:=25;
AA:=50;
BB:=3;
高1:=REF(HHV(H,AA),BB);
低1:=REF(LLV(L,AA),BB);
DRAWBAND(REFDATE(低1,DATE),RGB(0,20,125),LLV(L,AA),RGB(50,10,100));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORFFFF00;
一:REFDATE(H1,DATE),DOTLINE,COLORYELLOW;
二:REFDATE(H2,DATE),DOTLINE,COLORMAGENTA;
三:REFDATE(H3,DATE),DOTLINE,COLOR00FFFF;
四:REFDATE(H4,DATE),DOTLINE,COLORMAGENTA;
五:REFDATE(H5,DATE),DOTLINE,COLORYELLOW;
低:REFDATE(低1,DATE),COLOR00FF00;
TT3:=(CURRBARSCOUNT=5);
TT4:=(CURRBARSCOUNT=1);
DRAWNUMBER(TT3 AND 顶,顶,顶),COLOR999900;
DRAWTEXT(TT4 AND 顶,顶,'顶'),COLOR208FFF;
DRAWNUMBER(TT3 AND 五,五,五),COLOR999999;
DRAWTEXT(TT4 AND 五,五,'0.191'),COLOR208FFF;
DRAWNUMBER(TT3 AND 低,低*1.01,低),COLOR999900;
DRAWTEXT(TT4 AND 低,低*1.009,'底'),COLOR208FFF;

公式指标动态翻译

输出趋势:收盘价的3日简单移动平均的3日简单移动平均,COLOR00DD00
输出
持股:如果收盘价>趋势,返回趋势,否则返回无效数,COLORDD00DD
N赋值:25
AA赋值:50
BB赋值:3
高1赋值:BB日前的AA日内最高价的最高值
低1赋值:BB日前的AA日内最低价的最低值

画带状线

K线
H1赋值:高1-(高1-低1)*0.191
H2赋值:高1-(高1-低1)*0.382
H3赋值:高1-(高1-低1)*0.5
H4赋值:高1-(高1-低1)*0.618
H5赋值:高1-(高1-低1)*0.809
输出
顶:日期日高1,COLORFFFF00
输出
一:日期日H1,DOTLINE,画黄色
输出
二:日期日H2,DOTLINE,画洋红色
输出
三:日期日H3,DOTLINE,COLOR00FFFF
输出
四:日期日H4,DOTLINE,画洋红色
输出
五:日期日H5,DOTLINE,画黄色
输出
低:日期日低1,COLOR00FF00
TT3赋值:(到最后交易的周期=5)
TT4赋值:(到最后交易的周期=1)

当满足条件TT3AND顶时,在顶位置书写数字,COLOR999900

当满足条件TT4AND顶时,在顶位置书写文字,COLOR208FFF

当满足条件TT3AND五时,在五位置书写数字,COLOR999999

当满足条件TT4AND五时,在五位置书写文字,COLOR208FFF

当满足条件TT3AND低时,在低*1.01位置书写数字,COLOR999900

当满足条件TT4AND低时,在低*1.009位置书写文字,COLOR208FFF
 

高点划线主图指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章