通达信买卖金点指标公式

来源:中金指南

公式指标源码

ma5:=MA(CLOSE,5);
MA15:=MA(CLOSE,15);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
离散量30:100*(MA5-(MA15+MA30)/2)/MA30,COLORYELLOW,LINETHICK1;
离散量60:100*(MA5-(MA15+MA30+MA60)/3)/MA60,COLORCYAN;
粘合K:-2*(离散量30-离散量60),COLORRED,LINETHICK2;
粘合D:=ema(粘合K,3),COLORYELLOW;
主升:BArslAst(crOSS(粘合K,粘合D))*(粘合K>粘合D),NODRAW,COLORGREEN;
粘合:=Abs(粘合K)+ABS(离散量60),COLORGREEN;
{离差:当此数>0时,表示"离散量30"在"粘合K"的下方,但只有在"离散量30"上升时才有数}
离差:(粘合K-离散量30)*(离散量30>REF(离散量30,1)),NODRAW;
{关注1:粘合K在0轴附近,同时粘合K与离散量30都处于上升趋势时}
CC:=粘合K-离散量30;
GZ1:=(ABS(粘合-粘合K)<3 AND 粘合K>粘合D) OR (粘合K>-0.5 AND 粘合K<1 AND 粘合K>粘合D) OR (CC>0 AND CC<2 AND 离散量30>REF(离散量30,1));
STICKLINE(GZ1,0,-1,0.8,1),COLORYELLOW;
关注1:IF(GZ1,1,0),COLORYELLOW,NODRAW;
{关注2:包含关注1=1,同时处于上升趋势时}
VAR1:=IF(GZ1=1 AND 粘合K>REF(粘合K,1),1/ABS(粘合-粘合K),0);
GZ2:=IF(VAR1>10,10,IF(VAR1<0.5,0,IF(VAR1<1,1,VAR1)));
STICKLINE(GZ2>0,0,-GZ2,2,0),COLORMAGENTA;
关注2:IF(GZ2>0,1,0),COLORMAGENTA,NODRAW;
{老鸭嘴:有只在粘合K处于上升趋势时,使用此指标一定要注意"粘合K"的趋势}
VAR3:=REF(离散量30,3)>=REF(离散量30,1) AND REF(离散量30,1)<=离散量30 AND (离散量30-粘合K<2) AND 主升>0;
STICKLINE(VAR3,粘合K+1,粘合K-1,1,0),COLORGREEN;
鸭嘴:IF(VAR3,1,0),COLORGREEN,NODRAW;
{三金点:当关注1、关注2、老鸭嘴同时为1时};
三金点:关注1+关注2+鸭嘴,NODRAW;
{判断超跌反弹}
VAR4:=IF(离散量30<-5 AND REF(离散量30,2)>REF(离散量30,1) AND 离散量30>REF(离散量30,1),1,0);
STICKLINE(VAR4,离散量30+2,离散量30,1,0),COLORYELLOW;
反弹:IF(VAR4,1,0),COLORYELLOW,NODRAW;
0,COLORWHITE;

公式指标动态翻译

MA5赋值:收盘价的5日简单移动平均
MA15赋值:收盘价的15日简单移动平均
MA30赋值:收盘价的30日简单移动平均
MA60赋值:收盘价的60日简单移动平均
输出
离散量30:100*(MA5-(MA15+MA30)/2)/MA30,画黄色,线宽为1
输出
离散量60:100*(MA5-(MA15+MA30+MA60)/3)/MA60,画青色
输出
粘合K:-2*(离散量30-离散量60),画红色,线宽为2
粘合D赋值:粘合K的3日指数移动平均,画黄色
输出
主升:上次粘合K上穿粘合D距今天数*(粘合K>粘合D),NODRAW,画绿色
粘合赋值:粘合K的绝对值+离散量60的绝对值,画绿色
输出

离差:(粘合K-离散量30)*(离散量30>1日前的离散量30),NODRAW
CC赋值:粘合K-离散量30
GZ1赋值:(粘合-粘合K的绝对值<3 AND 粘合K>粘合D) OR (粘合K>-0.5 AND 粘合K<1 AND 粘合K>粘合D) OR (CC>0 AND CC<2 AND 离散量30>1日前的离散量30)

当满足条件GZ1时,在0和-1位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,画黄色
输出
关注1:如果GZ1,返回1,否则返回0,画黄色,NODRAW
VAR1赋值:如果GZ1=1AND粘合K>1日前的粘合K,返回1/粘合-粘合K的绝对值,否则返回0
GZ2赋值:如果VAR1>10,返回10,否则返回如果VAR1<0.5,返回0,否则返回如果VAR1<1,返回1,否则返回VAR1

当满足条件GZ2>0时,在0和-GZ2位置之间画柱状线,宽度为2,0不为0则画空心柱.,画洋红色
输出
关注2:如果GZ2>0,返回1,否则返回0,画洋红色,NODRAW
VAR3赋值:3日前的离散量30>=1日前的离散量30 AND 1日前的离散量30<=离散量30 AND (离散量30-粘合K<2) AND 主升>0

当满足条件VAR3时,在粘合K+1和粘合K-1位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
输出
鸭嘴:如果VAR3,返回1,否则返回0,画绿色,NODRAW


输出
三金点:关注1+关注2+鸭嘴,NODRAW
VAR4赋值:如果离散量30<-5ANDREF(离散量30,2)>1日前的离散量30AND离散量30>1日前的离散量30,返回1,否则返回0

当满足条件VAR4时,在离散量30+2和离散量30位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
输出
反弹:如果VAR4,返回1,否则返回0,画黄色,NODRAW

0,画白色
 

通达信买卖金点指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章