通达信资金穿透超级单指标公式

来源:中金指南

公式指标源码

{使用说明:绿柱转红柱是买入信号,红柱过中轨为强势信号,可重点关注。}

Z:=ma(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
波段进场:IF(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2),80,50);
反弹进场:IF(REF(VAR4,1)<5 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND VAR3<-0.3,80,50);
超跌进场:IF(crOSS(VAR4,5) AND VAR3<-0.4,80,50),COLORMAGENTA;
stICKLINE(C>=MA(C,10),VAR4,REF(VAR4,1),3,0),COLORRED;
STICKLINE(C<MA(C,10),VAR4,REF(VAR4,1),3,0),COLORGREEN;
AA:95,COLORGREEN;
BB:5,COLORCYAN;

公式指标动态翻译

Z赋值:收盘价的120日简单移动平均
VAR3赋值:(收盘价的5日简单移动平均-Z)/Z
输出
VAR4:(收盘价-10日内最低价的最低值)/(10日内最高价的最高值-10日内最低价的最低值)*100的3日简单移动平均
输出
波段进场:如果收盘价>ZANDREF(VAR4,1)<30ANDVAR4>1日前的VAR4ANDREF(VAR4,1)<2日前的VAR4,返回80,否则返回50
输出
反弹进场:如果1日前的VAR4<5ANDVAR4>1日前的VAR4ANDREF(VAR4,1)<2日前的VAR4ANDVAR3<-0.3,返回80,否则返回50
输出
超跌进场:如果VAR4上穿5ANDVAR3<-0.4,返回80,否则返回50,画洋红色

当满足条件收盘价>=收盘价的10日简单移动平均时,在VAR4和1日前的VAR4位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色

当满足条件收盘价<收盘价的10日简单移动平均时,在VAR4和1日前的VAR4位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
输出
AA:95,画绿色
输出
布林极限:5,画青色

资金穿透超级单指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章