通达信疯牛出栏指标公式

来源:中金指南

公式指标源码

DRAWGBK(C>0, RGB(20,10,111110),RGB(50,60,150),0,'11',0);
V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);
abv:=ma(SUM(IF(CLOSE>REF(CLOSE,1),vol,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=ema(ABV,12);
M2:=EMA(ABV,26);
mtm:=CLOSE-REF(CLOSE,1);
mms:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(Abs(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MTGJ:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTGJ,9),9)/EMA(EMA(ABS(MTGJ),9),9);
MAZL:=MA(ZLGJ,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(HIGH+OPEN+LOW+(2)*(CLOSE))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主力轨迹:IF(ABV>M2 AND MMS>MML AND crOSS(ZLGJ,MAZL) AND ZLGJ>REF(ZLGJ,1) AND MAZL>REF(MAZL,1),55,0),COLORFFCC66,POINTDOT;
stICKLINE(主力轨迹,55,0,4,1),COLORFFCC66;
DRAWTEXT((TROUGHBARS(3,18,1)=0) AND (HIGH>(LOW)*(1.04)),40,'¥鬼子进村'),COLORFF00FF;
VARC:=(zig(3,18)>REF(ZIG(3,18),1)) AND (REF(ZIG(3,18),1)<=REF(ZIG(3,18),2));
VARD:=(ZIG(3,18)<REF(ZIG(3,18),1)) AND (REF(ZIG(3,18),1)>=REF(ZIG(3,18),2));
STICKLINE((VARC=1),30,0,5,0),COLOR0000FF;
DRAWTEXT((VARC=1),42,'¥抢粮食'),COLOR0000FF;
STICKLINE((VARD=1),100,85,5,0),COLORFF0000;
DRAWTEXT((PEAKBARS(3,18,1)=0) AND ((HIGH)*(0.96)>LOW),80,'注意转折'),COLORFF0000;
AA := REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),34,1)/SMA(ABS(CLOSE-AA),34,1)*1000;
HHH:=BBB-LLV(BBB,36);
短期:=(MA(HHH,2)*3+HHH*13)/16;
中期:=MA(HHH,10);
差值:短期-中期,NODRAW;
CCC:=LLV(BBB,36)-BBB;
短期二:=(MA(CCC,2)*3+CCC*13)/16;
中期二:=MA(CCC,10);
VB:2*(短期-中期),NODRAW;
乖离率6:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
乖离率12:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
乖离率24:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
ZP:=乖离率6<-6 AND 乖离率12<-10 AND 乖离率24<-16;
DRAWICON(ZP,-50,26);
STICKLINE(VB>=0 AND VB>REF(VB,1),0,VB,1,0),COLORRED;
STICKLINE(VB>=0 AND VB<REF(VB,1),0,VB,1,1),COLORRED;
STICKLINE(VB<0 AND 中期>REF(中期,1),0,VB,1,1),COLORRED;
STICKLINE(VB<0 AND VB<REF(VB,1),0,VB,1,0),COLORGREEN;
STICKLINE(VB<0 AND VB>REF(VB,1),0,VB,1,1),COLORGREEN;
STICKLINE(VB<0 AND 中期>REF(中期,1),0,VB,2,-1),COLORRED;
STICKLINE(VB>=0 AND 中期<REF(中期,1),0,VB,2,-1),COLORGREEN;
STICKLINE(短期<3,VB,0,1,0),COLORYELLOW;
准备买:IF(短期<3,8,0),COLORYELLOW,NODRAW;
STICKLINE(短期=0,VB,0,1,0),COLORMAGENTA;
买入:IF(短期=0,8,0),COLORMAGENTA,NODRAW;
DRAWICON(MA(短期,3)=0,VB,1);
加仓:IF(MA(短期,3)=0,8,0),COLORRED ,NODRAW;
STICKLINE(差值>60 AND VB>0 AND 中期>50,VB,0,1,0),COLORBLUE;
准备卖:IF(差值>60 AND VB>0 AND 中期>50,4,0),COLORBLUE;
STICKLINE(差值>60 AND VB>0 AND 中期>100,VB,0,1,0),COLORCYAN;
卖出:IF(差值>60 AND VB>0 AND 中期>100,4,0),COLORCYAN;
坚决卖:IF(EVERY(差值>60 AND VB>0 AND 中期>100,2),4,0),COLORGREEN;
DRAWICON(EVERY(差值>60 AND VB>0 AND 中期>100,2),VB,2);
STICKLINE(VB>100,100,VB,1,0),COLORBROWN;
STICKLINE(VB>200,200,VB,1,0),COLORLIRED;
100,DOTLINE,COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,'准备买~黄色'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.12,0,0,'买入~洋红色'),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.24,0,0,'加仓~红箭头'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.36,0,0,'准备卖~蓝色'),COLORBLUE;
DRAWTEXT_FIX(ISLASTBAR,0.48,0,0,'卖出~青色'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.60,0,0,'坚决卖~绿箭头'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,'{红色柱~买入}'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.24,0,'{绿色柱~卖出}'),COLORGREEN;
疯牛极端预警线:32.,COLORRED,LINETHICK2;

公式指标动态翻译

填充背景
V2V赋值:成交量(手)/1日前的成交量(手)>=1.9 AND 收盘价>1日前的收盘价
ABV赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回如果收盘价<1日前的收盘价,返回-成交量(手),否则返回0的历史累和/25000的2日简单移动平均
M1赋值:ABV的12日指数移动平均
M2赋值:ABV的26日指数移动平均
MTM赋值:收盘价-1日前的收盘价
MMS赋值:((100)*(MTM的6日指数移动平均的6日指数移动平均))/(MTM的绝对值的6日指数移动平均的6日指数移动平均)
MMM赋值:((100)*(MTM的12日指数移动平均的12日指数移动平均))/(MTM的绝对值的12日指数移动平均的12日指数移动平均)
MML赋值:((100)*(MTM的26日指数移动平均的26日指数移动平均))/(MTM的绝对值的26日指数移动平均的26日指数移动平均)
MTGJ赋值:收盘价-1日前的收盘价
ZLGJ赋值:100*MTGJ的9日指数移动平均的9日指数移动平均/MTGJ的绝对值的9日指数移动平均的9日指数移动平均
MAZL赋值:ZLGJ的5日简单移动平均
A赋值:((成交量(手))/(当前流通股本(手)))*(100)
S赋值:((A的30日简单移动平均)/(大盘的成交额的10日简单移动平均))*(大盘的成交额的60日简单移动平均)
Y赋值:((A的120日简单移动平均)/(大盘的成交额的10日简单移动平均))*(大盘的成交额的60日简单移动平均)
X赋值:1
V1赋值:(最高价+开盘价+最低价+(2)*(收盘价))/(5)
V2赋值:1日前的V1
V3赋值:V1-V2和0的较大值
V4赋值:V1-V2的绝对值
V5赋值:V3的10日[1日权重]移动平均
V6赋值:V4的10日[1日权重]移动平均
V8赋值:统计5日中满足((V5)/(V6)<0.2)的天数
V9赋值:统计10日中满足(10日内V1的最低值=V1)的天数
输出
主力轨迹:如果ABV>M2ANDMMS>MMLANDCROSS(ZLGJ,MAZL)ANDZLGJ>1日前的ZLGJANDMAZL>1日前的MAZL,返回55,否则返回0,COLORFFCC66,POINTDOT

当满足条件主力轨迹时,在55和0位置之间画柱状线,宽度为4,1不为0则画空心柱.,COLORFFCC66

当满足条件(收盘价18%之字转向的前1个波谷位置=0)AND(最高价>(最低价)*(1.04))时,在40位置书写文字,COLORFF00FF
VARC赋值:(收盘价18%的之字转向>1日前的收盘价18%的之字转向) AND (1日前的收盘价18%的之字转向<=2日前的收盘价18%的之字转向)
VARD赋值:(收盘价18%的之字转向<1日前的收盘价18%的之字转向) AND (1日前的收盘价18%的之字转向>=2日前的收盘价18%的之字转向)

当满足条件(VARC=1)时,在30和0位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR0000FF

当满足条件(VARC=1)时,在42位置书写文字,COLOR0000FF

当满足条件(VARD=1)时,在100和85位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF0000

当满足条件(收盘价18%之字转向的前1个波峰位置=0)AND((最高价)*(0.96)>最低价)时,在80位置书写文字,COLORFF0000
赋值: 1日前的收盘价
BBB赋值:收盘价-AA和0的较大值的34日[1日权重]移动平均/收盘价-AA的绝对值的34日[1日权重]移动平均*1000
HHH赋值:BBB-36日内BBB的最低值
短期赋值:(HHH的2日简单移动平均*3+HHH*13)/16
中期赋值:HHH的10日简单移动平均
输出
差值:短期-中期,NODRAW
CCC赋值:36日内BBB的最低值-BBB
短期二赋值:(CCC的2日简单移动平均*3+CCC*13)/16
中期二赋值:CCC的10日简单移动平均
输出
VB:2*(短期-中期),NODRAW
乖离率6赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
乖离率12赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100
乖离率24赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
ZP赋值:乖离率6<-6 AND 乖离率12<-10 AND 乖离率24<-16

当满足条件ZP时,在-50位置画26号图标

当满足条件VB>=0ANDVB>1日前的VB时,在0和VB位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色

当满足条件VB>=0ANDVB<1日前的VB时,在0和VB位置之间画柱状线,宽度为1,1不为0则画空心柱.,画红色

当满足条件VB<0AND中期>1日前的中期时,在0和VB位置之间画柱状线,宽度为1,1不为0则画空心柱.,画红色

当满足条件VB<0ANDVB<1日前的VB时,在0和VB位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色

当满足条件VB<0ANDVB>1日前的VB时,在0和VB位置之间画柱状线,宽度为1,1不为0则画空心柱.,画绿色

当满足条件VB<0AND中期>1日前的中期时,在0和VB位置之间画柱状线,宽度为2,-1不为0则画空心柱.,画红色

当满足条件VB>=0AND中期<1日前的中期时,在0和VB位置之间画柱状线,宽度为2,-1不为0则画空心柱.,画绿色

当满足条件短期<3时,在VB和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
输出
准备买:如果短期<3,返回8,否则返回0,画黄色,NODRAW

当满足条件短期=0时,在VB和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画洋红色
输出
买入:如果短期=0,返回8,否则返回0,画洋红色,NODRAW

当满足条件短期的3日简单移动平均=0时,在VB位置画1号图标
输出
加仓:如果短期的3日简单移动平均=0,返回8,否则返回0,画红色 ,NODRAW

当满足条件差值>60ANDVB>0AND中期>50时,在VB和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画蓝色
输出
准备卖:如果差值>60ANDVB>0AND中期>50,返回4,否则返回0,画蓝色

当满足条件差值>60ANDVB>0AND中期>100时,在VB和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画青色
输出
卖出:如果差值>60ANDVB>0AND中期>100,返回4,否则返回0,画青色
输出
坚决卖:如果最近2日一直存在差值>60ANDVB>0AND中期>100,返回4,否则返回0,画绿色

当满足条件最近2日一直存在差值>60ANDVB>0AND中期>100时,在VB位置画2号图标

当满足条件VB>100时,在100和VB位置之间画柱状线,宽度为1,0不为0则画空心柱.,画棕色

当满足条件VB>200时,在200和VB位置之间画柱状线,宽度为1,0不为0则画空心柱.,画淡红色

100,DOTLINE,画深灰色

当满足条件是否最后一个周期时,在横轴0纵轴0位置书写文字,画黄色

当满足条件是否最后一个周期时,在横轴0.12纵轴0位置书写文字,画洋红色

当满足条件是否最后一个周期时,在横轴0.24纵轴0位置书写文字,画红色

当满足条件是否最后一个周期时,在横轴0.36纵轴0位置书写文字,画蓝色

当满足条件是否最后一个周期时,在横轴0.48纵轴0位置书写文字,画青色

当满足条件是否最后一个周期时,在横轴0.60纵轴0位置书写文字,画绿色

当满足条件是否最后一个周期时,在横轴0纵轴0.12位置书写文字,画红色

当满足条件是否最后一个周期时,在横轴0纵轴0.24位置书写文字,画绿色
输出
疯牛极端预警线:32.,画红色,线宽为2

疯牛出栏指标公式使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章