频谱买卖(同花顺公源码)

/////////////////////////////////////////////////////
CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
主力线:(EMA(CS,3)-50)*2;
极弱:=-80;
强势:=60;
风险:=80;
弱势:=-60;
主力线,COLORSTICK;
今日保护价:=(REF(C,1)+REF(C,2)+O)/3,linethick0;
VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;
STICKLINE(CROSS(75.9,VAR2),主力线+5,主力线-5,3,0),coloryellow;
DRAWTEXT(CROSS(主力线,78),78,'清仓'),colorred;
DRAWTEXT(CROSS(主力线,强势),60,'飙升'),coloryellow;
DRAWTEXT(CROSS(主力线,-80),-80,'吸'),colorcyan;
////////////////////////////////////////////////////////////////////////////////////////////////////////////////
//超准极品低 3.9  标识:进2,出2
position21b:=H*0.9;  //进
position22s:=H*1.2; //出
position23b:=L*0.78; //三角形
position24b:=L*0.6; //空心三角形
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,55),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);
VAR12:=EMA(CLOSE,5)*(-1);
//STICKLINE(VAR8>REF(VAR8,1),0,VAR8,6,1),COLOR10FFFF,LINETHICK3;
//备钱:IF(VAR8>REF(VAR8,1),0,VAR8),COLOR0FFFFF;
//界:0,COLORFFFFFF,LINETHICK1;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
//STICKLINE(XL3,0,VAR8*3,8,0),colorred;
//启动:IF(XL3,0,VAR8*3),colorred;
VA:=(2*C+H+L)/4;
VB:=LLV(L,5);
VC:=HHV(H,5);
散户:= EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4);
庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2);
DRAWTEXT(CROSS(散户,庄家) AND 散户<30 ,position21b,'进2'),colorlimagenta;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,position22s,'出2'),COLOR00FF00;
极品底:=IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2,COLORFF00FF;
DRAWICON(极品底=23,40,1),LINETHICK2,COLORFFFFFF;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
//有小手指标 所以不用这个了
//DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,,'进'),COLORFFFF00;
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19  ,L*0.6,'▲'),colorred;
//DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,40,'▲'),colorred;
//DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,50,'↑'),colorred;
QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8);
QVAR1D:=SMA(QVAR1A,21,8);
机会来临:=SMA(QVAR1C,13,8),colorred;
AAS:=FILTER((COUNT((机会来临-QVAR1D<(-65)),3)=3),34);
波段买点:=IF(AAS,15,0),COLORFFFFFF,STICK,LINETHICK6;
DRAWTEXT(波段买点  AND 主力线-MA(主力线,3)>0 ,L*0.5,'△'),colorred;
////////////////////////////////////////////////////////////////////////
//黄金买卖线 3.4+   画 进1 和出1
position2b:=100;
position2s:=200;//卖出位置
//黄金买卖线 3.4+
AA11:=(O+H+L+C)/4;
BB11:=MA(AA11,3);
CC11:=SUM(IF(AA11>REF(AA11,1),AA11*VOL,0),4)/SUM(IF(AA11<REF(AA11,1),AA11*VOL,0),4);
DD2:=REF(100-(100/(1+CC11)),1);
A11:=HHV(AA11,15);
A21:=LLV(AA11,15);
A31:=A11-A21;
A41:=EMA((AA11-A21)/A31,2)*100;
B11:=HHV(AA11,60);
B21:=LLV(AA11,60);
B31:=B11-B21;
B41:=EMA((AA11-B21)/B31,2)*100;
C11:=HHV(AA11,240);
C21:=LLV(AA11,240);
C31:=C11-C21;
C41:=EMA((AA11-C21)/C31,2)*100;
短期1:=A41,COLOR0000FF;
中期1:=B41,colorgreen;
长期1:=C41,COLOR00DEDE,LINETHICK1;
//STICKLINE(短期1>90 AND 中期1>70,86,94,6,0),COLOR00FF00;
//STICKLINE(短期1<5 AND 中期1<30,0,8,6,0);
IF(FILTER(中期1<REF(中期1,1)AND 中期1>90 AND BB11<REF(BB11,1),5),80,100),colorblue,LINETHICK2;
IF(FILTER(中期1>REF(中期1,1)AND 中期1<5 AND C>REF(C,1),5),20,0),COLORDE00DE,LINETHICK2;
D1:=中期1>REF(中期1,1)AND 短期1>REF(短期1,1)AND 长期1>REF(长期1,1)AND 长期1<8 AND 中期1<10 AND 短期1<15;
D2:=CROSS(短期1,中期1)AND 中期1<8;
D3:=CROSS(短期1,长期1)AND 长期1<8 AND 中期1<20;
//DRAWICON(FILTER((中期1<REF(中期1,1)AND 短期1<REF(短期1,1)AND 长期1<REF(长期1,1)AND 中期1>95 AND 短期1>85)OR (长期1>100 AND 中期1>100 AND 短期1>100),5),0,4); //哭脸
DRAWTEXT(FILTER((D1 OR D2 OR D3) AND DD2<15 AND C>REF(C,1),5),L*0.4,'进1'),coloryellow; //笑脸
DRAWTEXT(FILTER((中期1<REF(中期1,1)AND 短期1<REF(短期1,1)AND 长期1<REF(长期1,1)AND 中期1>95 AND 短期1>85)OR (长期1>100 AND 中期1>100 AND 短期1>100),5),120,'出1'),coloryellow;
//////////////////////////////////////////////////////////////////////
////SKDJ抄底逃顶 4.2   显示小手 股民学院 www.zjznw.com
position1b:=30;
var1:=REF(CLOSE,1);
var2:=SMA(MAX(CLOSE-var1,0),7,1)/SMA(ABS(CLOSE-var1),7,1)*100,coloryellow;
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/30;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
AA:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND C>O;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/30;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
AA:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND C>O;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
//STICKLINE(VAR9>VARA,VAR9,VARA,8,0), colormagenta;
//STICKLINE(VAR9<=VARA,VAR9,VARA,8,0), colorgreen;
//STICKLINE(AA,0,10,10,0),colorblue;
DIF:=EMA(CLOSE,9)-EMA(CLOSE,150),NODRAW;
DEA:=EMA(DIF,12),NODRAW;
MACD:=2*(DIF-DEA),COLORSTICK;
DIK:=4*DIF-3*DEA,coloryellow;
DED:=EMA(DIK,1),colorgreen;
IF(C>DED,DED,DRAWNULL),colorred,LINETHICK3;
IF(DED<=REF(DED,1),DED,DRAWNULL),colorgreen,LINETHICK3;
启动点:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)
AND REF(MACD ,2)<REF(MACD ,3)
AND REF(MACD ,3)<REF(MACD ,4);
DRAWICON(启动点,40,11);//小手图标

相关文章