回头疯牛(同花顺公式源码)

EMA30:EMA(CLOSE,30),colorbrown;
EMA5:=EMA(CLOSE,5);X2:=EMA5;X3:=EMA30;
主升:=C>X2 AND C>X3;主跌:=C<X3;
回调:=C<X2 AND C>X3;反弹:=C>X2 AND C<X3;
STICKLINE(主升,CLOSE,O,8.0,0),COLOR0000BB;
STICKLINE(主升,CLOSE,O,3,0),COLOR0000CC;
STICKLINE(主升,CLOSE,O,1.5,0),COLOR0000DD;
STICKLINE(主升,CLOSE,O,1,0),COLOR0000EE;
STICKLINE(主升,CLOSE,O,0.5,0),COLOR0000FF;
STICKLINE(主升,H,L,0,0),COLOR0000FF;
STICKLINE(主跌,CLOSE,O,8.0,0),COLOR555500;
STICKLINE(主跌,CLOSE,O,3,0),COLOR888800;
STICKLINE(主跌,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(主跌,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(主跌,CLOSE,O,0.5,0),COLOREEEE00;
STICKLINE(主跌,H,L,0,0),COLOREEEE00;
STICKLINE(回调,O,C,8.0,0),COLORBB4400;
STICKLINE(回调,O,C,3,0),COLORCC5500;
STICKLINE(回调,O,C,1.5,0),COLORDD6600;
STICKLINE(回调,O,C,1,0),COLOREE7700;
STICKLINE(回调,O,C,0.5,0),COLORFF8800;
STICKLINE(回调,H,L,0,0),COLORFF8800;
STICKLINE(反弹,O,C,8.0,0),COLOR0077BB;
STICKLINE(反弹,O,C,3,0),COLOR0099CC;
STICKLINE(反弹,O,C,1.5,0),COLOR00BBDD;
STICKLINE(反弹,O,C,1,0),COLOR00DDEE;
STICKLINE(反弹,O,C,0.5,0),COLOR00FFFF;
STICKLINE(反弹,H,L,0,0),COLOR00FFFF;
DRAWTEXT_FIX(C>0,0,0,0,'【█】涨势'),COLOR0000AA;
DRAWTEXT_FIX(C>0,0,0.05,0,'【█】回调'),COLORDD6600;
DRAWTEXT_FIX(C>0,0,0.10,0,'【█】跌势'),COLORAAAA00;
DRAWTEXT_FIX(C>0,0,0.15,0,'【█】反弹'),COLOR00BBDD;
均价线:=AMOUNT/V/100;C2:=REF(C,1);AA1:MA(C,4);
卖出:PARTLINE(aa1,AA1<=REF(AA1,1),colorgreen),LINETHICK2;
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);//股民学院www.zjznw.com
STICKLINE(涨停,OPEN,CLOSE,4.6,0),colorred;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.11,0,BLOCK(0,0));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.17,0,BLOCK(1,0));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.23,0,BLOCK(3,0));
HORLINE(C>0,NEW,1,1);

相关文章