通达信金涨停GJS3公式源码

金涨停:
X_1:=TDXDLL10(395,CLOSE,OPEN,HIGH);
X_2:=TDXDLL10(396,CLOSE,OPEN,HIGH);
X_3:=TDXDLL10(397,CLOSE,OPEN,HIGH);
X_4:=TDXDLL10(398,CLOSE,OPEN,HIGH);
X_5:=TDXDLL10(399,CLOSE,OPEN,HIGH);
X_6:=TDXDLL10(400,CLOSE,OPEN,HIGH);
X_7:=TDXDLL10(401,CLOSE,OPEN,HIGH);
X_8:=TDXDLL10(402,CLOSE,OPEN,HIGH);
X_9:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_10:=EMA(X_9,9);
X_11:=(X_9-X_10)*2;
X_12:=MA(CLOSE,5);
X_13:=MA(CLOSE,30);
X_14:=(CLOSE-X_12)/X_12*100;
X_15:=(CLOSE-X_13)/X_13*100;
X_16:=COUNT(CROSS(X_14,0),3)>=1 AND X_15>REF(X_15,1) AND X_12>REF(X_12,1) AND (CLOSE/REF(CLOSE,1)-1)*100>5 AND REF(CLOSE,1)<X_13;
X_17:=FILTER(X_16,10) AND REF(CLOSE<OPEN AND (CLOSE<REF(LLV(OPEN,3),1) AND CLOSE<REF(LLV(CLOSE,3),1) OR REF(CLOSE<OPEN,1)) OR (REF(COUNT(CLOSE<OPEN,3)=3,1) AND CLOSE>OPEN),1);
X_18:=REF(CLOSE,1)/CLOSE>1.043 AND REF(CLOSE/OPEN<1.003 OR CLOSE/REF(CLOSE,2)>1.037 OR CLOSE/REF(CLOSE,3)>1.037,1);
X_19:=COUNT(CLOSE<OPEN,4)>=3 AND COUNT(CLOSE<OPEN,2)=2 AND CLOSE/OPEN<0.989 AND (REF(CLOSE,2)/CLOSE>1.045 AND REF(CLOSE/OPEN,2)>REF(CLOSE/OPEN,1) AND REF(CLOSE/OPEN,2)>REF(CLOSE/OPEN,3) AND (REF(CLOSE/OPEN<0.989,3) OR CLOSE/REF(CLOSE,1)<0.955) OR REF(CLOSE,5)/CLOSE>1.075) AND (COUNT(CLOSE/REF(CLOSE,1)<0.97,2)>=1 OR (REF(CLOSE>OPEN,3) AND COUNT(CLOSE<OPEN,3)=3));
X_20:=REF(COUNT(CLOSE/REF(CLOSE,1)<0.937,2)=1 OR COUNT(CLOSE<MA(CLOSE,10) OR CLOSE<MA(CLOSE,20) OR (CLOSE<MA(CLOSE,60) AND LOW<MA(CLOSE,20)) AND (CLOSE/REF(CLOSE,1)<0.964 OR (REF(COUNT(CLOSE>OPEN AND HIGH/CLOSE<1.009,3)>=1,1) AND (CLOSE/REF(CLOSE,1)<0.985 OR CLOSE=LOW) AND CLOSE<REF(OPEN,1)) OR X_6),3)>=1 OR (CLOSE/REF(CLOSE,1)<0.955 AND REF(COUNT(HIGH=CLOSE,3)>=1 AND HIGH/CLOSE<1.012 AND COUNT(CLOSE>OPEN,3)=3,1)),1) OR (REF(REF(COUNT(REF(CLOSE>OPEN AND HIGH/CLOSE<1.009,1) AND (CLOSE/REF(CLOSE,1)<0.985 OR CLOSE=LOW) AND CLOSE<REF(OPEN,1),3)>=1,1) AND CLOSE/REF(CLOSE,1)<0.99 AND CLOSE<REF(OPEN,1),1) AND OPEN<REF(CLOSE,1) AND OPEN<MA(CLOSE,10)) OR (OPEN<REF(CLOSE,1) AND REF(HIGH/CLOSE>OPEN/LOW AND OPEN<MA(CLOSE,10) AND OPEN/LOW<1.009 AND CLOSE>OPEN AND REF(COUNT(CLOSE<OPEN AND REF(CLOSE>OPEN AND HIGH/CLOSE<1.009,1),2)>=1,1),1)) OR REF(OPEN<REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)<0.985 AND CLOSE<REF(OPEN,2) AND CLOSE<OPEN AND REF(CLOSE>OPEN AND HIGH/CLOSE<1.009,1),1) OR (REF(CLOSE/REF(CLOSE,1)<=0.995 AND CLOSE<OPEN AND CLOSE<REF(OPEN,1) AND REF(CLOSE/REF(CLOSE,1)>1 AND CLOSE>OPEN,1),1) AND OPEN<MA(CLOSE,10) AND OPEN<REF(OPEN,1)) OR COUNT(REF(CLOSE/REF(CLOSE,1)<0.963 AND REF(COUNT(CLOSE>OPEN,2)=2,1),1) AND LOW<MA(CLOSE,10),2)>=1;
X_21:=X_11>(-0.72) AND (X_9>0 OR (CLOSE<REF(CLOSE,2) AND REF(COUNT(CLOSE>OPEN AND REF(HIGH=CLOSE AND CLOSE/REF(CLOSE,1)>1.095,1),2)=1,1)));
X_22:=REF(REF(CLOSE/REF(CLOSE,1)<0.95 AND REF(COUNT(REF(CLOSE>OPEN AND HIGH/CLOSE<1.009,1) AND (CLOSE/REF(CLOSE,1)<0.986 OR CLOSE=LOW) AND CLOSE<REF(OPEN,1),3)>=1,1),2) AND CLOSE/OPEN>0.995 AND CLOSE/OPEN<1.03 AND CLOSE/OPEN<REF(CLOSE/OPEN,1) AND REF(CLOSE/OPEN>1.007 AND CLOSE>REF(CLOSE,1),1) AND COUNT(CLOSE<MA(CLOSE,60),2)>=1,1);
X_23:=REF(REF(C/REF(C,3)>=1.089 OR REF(X_1>=1.089,4) OR X_2>=1.073 OR X_1>=1.073,6) OR REF(C/REF(C,3)>=1.073,4) OR REF(C/REF(C,3)>=1.073,5) OR REF(C/REF(C,4)>=1.13,3) OR REF(C/REF(C,1)>=1.089,3) OR REF(C/REF(C,2)>=1.13,1) OR REF(C/REF(C,3)>=1.1,1) OR REF(C/REF(C,3)>=1.073,2) OR REF(C/REF(C,4)>=1.073,2) OR REF(C/REF(C,1)>=1.089,1) OR C/REF(C,6)>1.085 OR C/REF(C,2)>=1.089 OR C/REF(C,4)>=1.073,1) OR X_18 OR X_19 AND (C/REF(C,1)<0.957 OR (C/REF(C,3)<0.92 AND REF(C<REF(C,1),1)) OR (C/REF(C,1)<0.965 AND (REF(C<REF(C,1) OR C<O,1) OR C<REF((C+O)/2,2))) OR (C/REF(C,1)<0.966 AND C<REF(O,1) AND L<REF(L,1) AND REF(C>O AND REF(H=C,1) AND O>REF(C,1),1)) OR (O<REF(C,1) AND REF(C<O,1) AND C/REF(C,1)<0.97 AND L/REF(C,1)<0.927) OR (L/REF(C,1)<1.008 AND C/REF(C,1)<1.0199 AND C/O<0.955 AND O/C<1.13 AND REF(H=C,1)) OR (C<REF(L,2) OR C/REF(C,2)<0.951 OR C/REF(C,3)<0.951 OR C/REF(C,4)<0.951 OR X_1<0.951 AND (C/REF(C,2)<0.949 OR C/REF(C,3)<0.93 OR C/REF(C,4)<0.93 OR REF(COUNT(C<O AND REF(C<O,1),2)>=1,1) OR (C/REF(C,2)<0.96 AND REF(C>O AND REF(H=C AND C/REF(C,1)>1.095,1),2))))) AND (C/L<1.051 OR C/REF(C,1)<0.961) AND (X_21 OR X_19 OR (X_11>(-0.18) AND (X_9>(-1.61) OR COUNT(C/REF(C,1)<0.95,2)>=1 OR REF(COUNT(H=C,2)=2,3))));
X_24:=REF(X_6,1) OR OPEN<REF(OPEN,1) OR OPEN<REF(CLOSE,1);
X_25:=REF(HIGH/CLOSE<1.009 AND CLOSE/REF(CLOSE,1)>1.019 AND CLOSE>=OPEN AND REF(CLOSE>=OPEN,1),1);
X_26:=REF(REF(CLOSE<OPEN AND CLOSE/REF(CLOSE,1)<0.975,3) AND REF(REF(CLOSE<MA(CLOSE,10),1) AND OPEN<MA(CLOSE,10),1) AND OPEN<MA(CLOSE,10) AND (COUNT(CLOSE>OPEN,3)=3 AND REF(COUNT(CLOSE/REF(CLOSE,1)<1.01,2)=2,1) AND OPEN<MA(CLOSE,20) AND CLOSE/REF(CLOSE,1)<1.027 OR (REF(COUNT(CLOSE/OPEN>1.02,2)>=1 AND COUNT(CLOSE/OPEN>1.007,2)=2,1) AND OPEN<MA(CLOSE,20) AND HIGH>REF(HIGH,1) AND (CLOSE<OPEN AND HIGH/OPEN>CLOSE/LOW OR (CLOSE>OPEN AND HIGH/CLOSE>OPEN/LOW)) AND CLOSE/OPEN<1.025)),1);
X_27:=REF(COUNT(X_23,9)>=1 AND (C/REF(C,1)<1.0597 OR X_8) AND (X_7 AND (C/REF(C,1)>0.991 AND (X_4 AND REF(C<O OR H/C<1.005 OR COUNT(C>O,3)=3,2) AND H/C<O/L AND C<REF(O,1) AND REF(COUNT(C/REF(C,1)>1.011,3)>=1,2) AND REF(COUNT(C/O>0.97 AND REF(C/O>0.989,1),2)>=1,3) OR (H/C>O/L AND REF(COUNT(C<O,2)>=1,1) AND X_4)) AND REF(X_8,1) OR REF(C/L<1.006 AND C<=O,1)) OR COUNT(X_6 AND REF(C/O,2)<REF(C/O,1) AND H>REF(O,1),2)>=1 OR (X_8 AND (X_5 OR (REF(C/O,1)>C/O AND C/O>0.997 AND REF(C/O>1.021 AND REF(C/REF(C,1)<0.95,1),1))) AND (REF(X_7 AND REF(X_8,1) AND REF(C<=O,1),1) OR (C/REF(C,1)<0.952 AND C<O AND X_25))) OR (X_8 AND COUNT(C/O<0.991 AND REF(C<O,1) OR C/REF(C,1)<0.976 AND C/REF(C,1)<0.986,2)>=1 AND C<REF(C,1) AND REF(COUNT(C<=O OR C/REF(C,1)<1.029,2)>=1 OR REF(C/O>1.03 AND C/REF(C,1)>1.07,1),1) AND X_5)),1) AND (REF(X_8,1) OR REF(X_7,1)) AND REF(COUNT(C/O<0.982,7)>=2 OR COUNT(C/O>1.018,8)>=2 OR (X_8 AND REF(X_7 AND REF(X_8,1) AND REF(C<=O,1),1)) OR COUNT(C/REF(C,1)<0.955,6)>=1 OR COUNT(C/REF(C,1)>1.045,4)>=1 OR COUNT(C/REF(C,1)<0.982,2)>=1 OR (COUNT(C<=O,4)>=3 AND C/REF(C,1)<0.985) AND COUNT(C<=REF(C,1),3)>=1,1) AND (COUNT(O<=REF(LLV(O,2),2),2)>=1 OR REF(C/REF(C,2)<0.96 AND C/REF(O,1),1) OR (O<REF(O,2) AND REF(X_8,2) AND REF(COUNT(X_7,3)=3,3)) OR X_24);
X_28:=X_27 AND REF(CLOSE<OPEN OR (CLOSE>OPEN AND REF(COUNT(CLOSE<OPEN,2)>=1 AND REF(COUNT(CLOSE>OPEN,2)=1 OR COUNT(CLOSE>OPEN,4)>=3 OR COUNT(CLOSE<OPEN,4)>=3,1) OR COUNT(CLOSE<OPEN,3)=3,1)),1) AND REF(COUNT(X_5,2)>=1 OR REF(CLOSE/OPEN>1.011 OR REF(CLOSE/OPEN>1.021 AND REF(CLOSE>OPEN,1),1),1),1) AND REF(COUNT(X_3<REF(X_3,1),2)>=1 OR X_11<(-0.05) AND (CLOSE<REF(OPEN,1) AND CLOSE<OPEN OR COUNT(CLOSE/REF(CLOSE,1)<0.97,4)>=1 OR COUNT(CLOSE/REF(CLOSE,1)>1.025 OR (CLOSE/OPEN>1.02 AND CLOSE/REF(CLOSE,1)>1.01),4)>=1),1);
X_29:=REF(COUNT(X_23,9)>=1 AND (CLOSE/REF(CLOSE,1)<1.0597 OR X_8),1) AND X_26;
X_30:=X_29 AND CLOSE/REF(CLOSE,1)>1.025 AND CLOSE/OPEN>1.021 AND (X_9>0 OR X_11>(-0.01) AND (X_11>(-0.7) AND CLOSE/REF(CLOSE,1)>1.036 OR X_11>(-0.01))) OR (X_28 AND (CLOSE/REF(CLOSE,1)>1.036 OR CLOSE/OPEN>1.036 OR (CLOSE/REF(CLOSE,1)>1.025 AND CLOSE/OPEN>1.021 AND (X_9>0 OR X_11>(-0.01)) AND X_11>(-0.01))) AND (REF(CLOSE/REF(CLOSE,1)<1.035 OR CLOSE<OPEN,1) OR (REF(HIGH/CLOSE>OPEN/LOW AND CLOSE>OPEN,1) AND OPEN<REF(CLOSE,1)<0.98)) AND (CLOSE/REF(CLOSE,1)>1.028 OR (CLOSE/REF(CLOSE,1)>1.025 AND CLOSE/OPEN>1.021 AND (X_9>0 OR X_11>(-0.01)) AND X_11>(-0.01))));
X_31:=REF(X_23 AND REF(COUNT(CLOSE/REF(CLOSE,1)>1.095 AND HIGH/CLOSE<1.005 AND CLOSE/OPEN>1.03 AND REF(CLOSE/REF(CLOSE,1)>1.095 AND HIGH/CLOSE<1.005 AND CLOSE/OPEN>1.03,1),2)>=1,1) AND CLOSE/REF(CLOSE,1)<0.906,1) AND OPEN/MA(CLOSE,10)<1.005 AND CLOSE/REF(CLOSE,1)>1.01 AND CLOSE/OPEN>1.05;
X_32:=REF(COUNT(X_23,6)>=1,4) AND REF(COUNT(CLOSE<REF(CLOSE,1) AND HIGH>REF(CLOSE,1) AND REF(COUNT(CLOSE>REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)<1.036 AND CLOSE>=OPEN,4)=3 AND COUNT(CLOSE>REF(CLOSE,1) AND CLOSE>OPEN,2)=2,1),2)>=1 AND CLOSE<REF(CLOSE,1) OR (COUNT(CLOSE>OPEN AND CLOSE/REF(CLOSE,1)<1.035,2)=2 AND REF(COUNT(CLOSE<=OPEN,4)>=3 AND COUNT(CLOSE<=OPEN,3)>=2 AND COUNT(CLOSE<REF(CLOSE,1),4)>=3 AND CLOSE<OPEN,3) AND COUNT(CLOSE>=REF(CLOSE,1),3)>=2 AND COUNT(CLOSE/OPEN>1.0035,3)=3),1) AND CLOSE>REF(CLOSE,1) AND (HIGH/REF(CLOSE,1)>1.025 OR (REF(CLOSE>OPEN,1) AND CLOSE/OPEN>1.018)) AND CLOSE>REF(OPEN,1);
X_33:=REF(COUNT(X_23,18)>=1 AND (COUNT(COUNT(CLOSE<OPEN,5)=3 AND REF(COUNT(CLOSE>=OPEN,4)>=1,3),2)>=1 AND COUNT(CLOSE/REF(CLOSE,1)<REF(CLOSE/REF(CLOSE,1),1),2)>=1 AND CLOSE<MA(CLOSE,5) OR (COUNT(CLOSE<OPEN,4)=3 AND (COUNT(CLOSE<OPEN AND OPEN>REF(CLOSE,1) AND CLOSE/OPEN<0.997 AND HIGH>REF(HIGH,1),2)>=1 AND COUNT(CLOSE<OPEN,2)=2 AND COUNT(CLOSE/REF(CLOSE,1)>REF(CLOSE/REF(CLOSE,1),1),2)>=1 OR (COUNT(CLOSE<OPEN AND CLOSE<REF(CLOSE,1),2)=2 AND REF(COUNT(CLOSE>=OPEN AND CLOSE>REF(CLOSE,1),2)=2,2)) OR (COUNT(CLOSE<OPEN AND CLOSE<REF(CLOSE,1),3)=3 AND REF(COUNT(CLOSE>OPEN,2)=2,3))) AND REF(COUNT(CLOSE>=OPEN,2)>=1,3))) AND CLOSE<MA(CLOSE,10),1) AND CLOSE/REF(CLOSE,1)>1.02 AND CLOSE/OPEN>1.021;
X_34:=REF(COUNT(X_23,2)>=1,3) AND REF(REF(COUNT(CLOSE<OPEN,2)=2,2) AND REF(COUNT(CLOSE>OPEN,3)=3,4) AND REF(CLOSE>OPEN AND CLOSE>REF(CLOSE,1),1) AND COUNT(CLOSE/REF(CLOSE,1)<1.036,2)=2 AND HIGH>REF(HIGH,1) AND CLOSE<OPEN AND HIGH>MA(CLOSE,5) AND MA(CLOSE,10)>MA(CLOSE,5),1) AND CLOSE/OPEN>1.018 AND CLOSE>REF(OPEN,1);
X_35:=REF(COUNT(X_23,15)>=1,1) AND REF(REF(CLOSE<OPEN,3) AND REF(CLOSE>OPEN AND CLOSE>REF(CLOSE,1),2) AND COUNT(CLOSE<OPEN,2)=2 AND REF(CLOSE/OPEN,2)>REF(CLOSE/OPEN,1) AND REF(CLOSE/OPEN,2)>REF(CLOSE/OPEN,3) AND REF(HIGH,1)>REF(CLOSE,2) AND REF(CLOSE,1)>REF(LOW,2) AND REF(CLOSE/OPEN<0.987,3) AND CLOSE/OPEN<REF(CLOSE/OPEN,1) AND CLOSE/OPEN<0.987 AND CLOSE/REF(CLOSE,1)<0.979,1) AND CLOSE/OPEN>1.018 AND OPEN>REF(CLOSE,1);
X_36:=REF(COUNT(X_23,9)>=1 AND MA(CLOSE,5)<MA(CLOSE,10) AND CLOSE/REF(CLOSE,1)<1.0597 AND (REF(COUNT(CLOSE<OPEN,3)=3 AND CLOSE/OPEN<REF(CLOSE/OPEN,1) AND REF(COUNT(CLOSE>OPEN,2)=2,3),1) AND CLOSE>OPEN AND HIGH/CLOSE<1.009) OR (REF(COUNT(CLOSE<OPEN,3)=3 AND CLOSE/OPEN<REF(CLOSE/OPEN,1) AND REF(CLOSE>OPEN,3),2) AND (COUNT(CLOSE>OPEN,2)=2 OR REF(COUNT(CLOSE>OPEN,2)=2,5)) AND HIGH/CLOSE>1.025 AND REF(CLOSE/OPEN>1.035,1) AND CLOSE/OPEN<REF(CLOSE/OPEN,1)),1) AND X_9>1 AND X_11>(-2.5) AND CLOSE/REF(CLOSE,1)>1.021 AND CLOSE/OPEN>1.018;
X_37:=REF(HIGH/CLOSE>1.025 AND CLOSE/REF(CLOSE,1)<1.035 AND OPEN/LOW<1.025 AND CLOSE>OPEN AND HIGH>REF(HIGH,1) AND CLOSE/OPEN<REF(CLOSE/OPEN,1) AND REF(CLOSE/OPEN>1.011 AND COUNT(MA(CLOSE,5)>REF(MA(CLOSE,5),1),3)>=1 AND CLOSE<=REF(HHV(CLOSE,7),2) AND REF(CLOSE<OPEN,1),1),1) AND HIGH>MA(CLOSE,5) AND HIGH>REF(OPEN,1) AND HIGH>MA(CLOSE,10) AND MA(CLOSE,5)/MA(CLOSE,10)>0.985;
X_38:=REF(COUNT(X_23,6)>=1,4) AND REF(REF(HIGH/CLOSE>1.003 AND CLOSE>OPEN AND REF(COUNT(CLOSE<OPEN,3)=3,1),1) AND CLOSE>OPEN AND HIGH/CLOSE<1.003,1) AND CLOSE/OPEN>1.018 AND CLOSE/REF(CLOSE,1)>1.021;
X_39:=REF(X_23,7) AND REF(COUNT(REF(CLOSE>OPEN,1) AND CLOSE<OPEN,5)=3 AND CLOSE<OPEN AND CLOSE<REF(CLOSE,1) AND LOW<REF(OPEN,1) AND COUNT(CLOSE/REF(CLOSE,1)<0.979,5)>=1 AND REF(COUNT(COUNT(CLOSE<OPEN,3)=3,2)>=1,6),1) AND CLOSE/OPEN>1.018 AND CLOSE/REF(CLOSE,1)>1.021;
X_40:=REF(X_23,6) AND REF(COUNT(REF(CLOSE<OPEN,1) AND CLOSE>OPEN,5)=3 AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)<1.021 AND REF(CLOSE<REF(CLOSE,1) AND LOW<REF(OPEN,1),1) AND COUNT(CLOSE/REF(CLOSE,1)<0.979,5)>=1 AND REF(COUNT(COUNT(CLOSE<OPEN,3)=3,2)>=1,5),1) AND CLOSE/OPEN>1.018 AND CLOSE/REF(CLOSE,1)>1.021;
X_41:=REF(COUNT(X_23,6)>=1,7) AND REF(CLOSE>OPEN AND HIGH>MA(CLOSE,5) AND HIGH/CLOSE>OPEN/LOW AND REF(CLOSE<OPEN AND CLOSE<REF(CLOSE,1) AND REF(CLOSE/OPEN>1.01 AND CLOSE/OPEN>REF(CLOSE/OPEN,1) AND CLOSE>REF(CLOSE,1) AND REF(REF(CLOSE<OPEN OR COUNT(CLOSE>OPEN,3)=3 AND REF(CLOSE>OPEN AND CLOSE>REF(CLOSE,1),1),1),1),1),1),1);
X_42:=CLOSE/REF(CLOSE,1)>1.005 AND CLOSE/OPEN>1.01 OR (REF(HIGH/CLOSE>OPEN/LOW AND CLOSE>OPEN AND OPEN>REF(CLOSE,1),1) AND OPEN<REF(LOW,1) AND CLOSE>OPEN AND HIGH/CLOSE<OPEN/LOW);
X_43:=CLOSE>MA(CLOSE,3) OR HIGH>MA(CLOSE,5) OR BARSCOUNT(CLOSE)<15;
金涨停G3:REF(REF(COUNT(C/O>1.038,12)>=1,1) AND X_43 AND (C>MA(C,10) AND MA(C,5)>MA(C,20) AND (MA(C,5)>MA(C,10) OR MA(C,10)>MA(C,20)) AND H/O>1.025 AND C/O>0.972 AND (COUNT(O>REF(C,1),2)>0 AND REF(COUNT(C>=O,2)=2 AND C/O<1.033 OR (COUNT(C<=O,2)=2 AND REF(C/REF(C,1)<0.96,1)) OR C<O,1) OR REF(COUNT(C/O>1.033,2)=2,1)) OR (C/O<REF(C/O,1) OR H/C<REF(H/C,1) OR (REF(O/C>1.022 AND REF(C/O>1.038,1),1) AND O<REF(C,1) AND C>O AND H/C>1.015) AND H/C>1.015 AND (C>O OR (C<O AND H/O>1.024)) AND H<REF(H,1))) AND H/C>1.015 AND C/O>0.972 AND (C>O OR (C<=O AND H/O>O/C)),1) AND X_42 OR (X_30 OR X_31 OR X_32 OR X_33 OR X_34 OR X_35 OR X_36 OR X_38 OR X_39 OR X_40 OR X_41 OR (COUNT(X_37,3)>=1 AND C/O>1.005 AND C/REF(C,1)>1.005 AND REF(C/REF(C,1)<1.01,1)) OR (C/REF(C,1)>1.028 AND (REF(C/REF(C,1)<1.055 OR C<O,1) OR (REF(H/C>O/L AND C>O,1) AND O<REF(C,1)<0.98)) AND C/REF(C,1)>1.028 AND REF(X_30 AND X_7 AND C/REF(C,1)>1.023 AND C/REF(C,1)<1.065 AND C/O<1.071 AND H/REF(C,1)>1.036,1) AND O/REF(C,1)<0.985) OR (REF(X_30,2) AND X_22) AND (C>=O OR (C>REF(C,1) AND REF(REF(COUNT(C<O,3)=3,3) AND COUNT(C>O,3)=3,1))) AND X_3>=REF(X_3,1) AND REF(COUNT(H/O>=C/L AND C<O OR (C/O>1.02 AND H/C<O/L) OR (C>O AND H/C>O/L),5)>=1,1)) AND CAPITAL<30000000,COLORMAGENTA,LINETHICK2;
X_44:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
X_45:=SMA(X_44,3,1);
X_46:=SMA(X_45,3,1);
X_47:=3*X_45-2*X_46;
X_48:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_49:=SMA(X_48,3,1);
X_50:=SMA(X_49,3,1);
X_51:=3*X_49-2*X_50;{股民学院 www.zjznw.com 整理}
金涨停J3:X_51>REF(X_51,1) AND REF(X_51,1)<88 AND X_49>REF(X_49,1) AND REF(X_47,1)<96 AND 金涨停G3,COLORLIBLUE,LINETHICK2;
金达倍:REF(金涨停G3 AND HIGH/CLOSE>OPEN/LOW AND OPEN/LOW>1 AND LOW<MA(CLOSE,10),1) OR REF(REF(REF(金涨停G3 AND LOW<MA(CLOSE,10) AND OPEN/LOW>1,1) AND X_7 AND HIGH/LOW>REF(OPEN/LOW,1),1) AND X_7 AND COUNT(CLOSE/OPEN<1.033,2)=2,1) AND REF(CLOSE/REF(CLOSE,1)<1.08,1) AND CLOSE/OPEN>1.0288 AND HIGH>REF(HIGH,1) AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,5)>MA(CLOSE,20),COLOR3F00A8,LINETHICK2;
金涨停S3:金涨停G3 AND CAPITAL<11000000 AND (X_11>(-0.01) OR REF(COUNT(C<O,3)=3 AND COUNT(C/O<0.985,3)>0 AND REF(O<REF(O,1) OR C<REF(C,1) AND (C<O AND REF(C<O,1) OR COUNT(C>O AND REF(C>O,1),2)>=1),3),1) OR (X_11>(-0.6) AND X_9>0 AND REF(COUNT(C>O,3)=3 AND REF(C<O,3),1)) AND (X_9>=REF(X_9,1) OR (X_9/REF(X_9,1)>0.9 AND (X_9>0 OR COUNT(C<O,5)=5))) AND (X_20 OR X_22 OR X_26 OR REF(COUNT(C<O,3)=3 AND COUNT(C/O<0.985,3)>0 AND REF(C>O OR (C<O AND REF(C<O,1)),3),1)) AND L<MA(C,10) AND REF(L<MA(C,5) AND COUNT(H/O>C/L AND C<O OR (C>O AND H/C>O/L),5)>=1,1) OR REF(REF(O/C>1.025,1) AND C>O AND (C/O<REF(C/O,2) OR (C/O<REF(C/O,5) AND REF(C>O AND REF(H/C>O/L,1),4)) OR C/O<REF(C/O,4) OR C/O<REF(C/O,3) OR (O>REF(C,1) AND (C/O>1.02 OR (H/C<1.005 AND H/C<O/L)))) AND O<REF(O,1) AND C>REF(C,1) AND C/O<REF(O/C,1) AND C/O<C/L,1) OR REF(H/O>1.031 AND C/O>0.972 AND (C>O AND H/C>C/O OR (C<=O AND H/O>O/C)) AND (O>REF(C,1) AND REF(COUNT(C>=O,2)=2 AND C/O<1.033 OR (COUNT(C<=O,2)=2 AND REF(C/REF(C,1)<0.96,1)) OR C<O,1) OR REF(COUNT(C/O>1.033,2)=2,1)),1) OR REF(H/C>1.015 AND C>O AND (C/O>1.02 OR H/C>1.02) AND H<REF(H,1) AND C<REF(C,1) AND O<REF(C,1) AND REF(O/C>1.022 AND REF(H/C>O/L AND (C/O>1.038 OR C/REF(C,1)>1.038),1),1),1)),COLORYELLOW,LINETHICK2;
精选:IF(REF(CLOSE/LOW<1.006 OR (CLOSE/LOW<1.015 AND OPEN/CLOSE>1.031) AND OPEN/CLOSE>1.01 OR (OPEN/LOW<1.006 OR (OPEN/LOW<1.015 AND CLOSE/OPEN>1.031) AND CLOSE>OPEN),1) AND LOW<MA(CLOSE,10) AND X_11>0 AND (金涨停G3 OR 金达倍),0.5,0),COLORGREEN;
X_52:=REF(HIGH<REF(HIGH,1) AND REF(HIGH/CLOSE>1.028,1) OR REF(HIGH/CLOSE<1.003,1) AND CLOSE/LOW<1.025 AND CLOSE/OPEN>0.95 AND CLOSE<OPEN AND X_5 AND REF(COUNT(CLOSE<REF(CLOSE,1) OR CLOSE<=OPEN AND REF(HIGH=CLOSE AND CLOSE/REF(CLOSE,1)>1.05 AND REF(HIGH=CLOSE AND CLOSE/REF(CLOSE,1)>1.05,1),1),7)>=1,3) AND REF(CLOSE/OPEN>1.019 AND (NOT(COUNT(HIGH=CLOSE AND CLOSE/REF(CLOSE,1)>1.05,2)>0) OR REF(NOT(COUNT(HIGH=CLOSE,3)>0),2)) AND X_4 AND REF(HIGH>CLOSE,2) AND REF(OPEN>REF(OPEN,1) OR MA(CLOSE,5)>MA(CLOSE,10),3) AND HIGH>REF(HIGH,1) AND HIGH/REF(HIGH,2)>0.95 AND (HIGH/CLOSE>1.028 OR HIGH/CLOSE<1.003) AND REF(CLOSE>OPEN AND REF(COUNT(CLOSE<REF(CLOSE,1),2)>=1,1),1),1),1) AND OPEN/REF(CLOSE,1)<1.01 AND HIGH/OPEN>1.01 AND HIGH/REF(CLOSE,1)>0.993 AND HIGH/MA(CLOSE,5)>1.005 AND LOW<MA(CLOSE,5);
X_53:=REF(CLOSE/OPEN>1.038 AND OPEN<=REF(CLOSE,1) AND (CLOSE<REF(HHV(CLOSE,5),4) AND OPEN<MA(CLOSE,10) AND CLOSE>MA(CLOSE,10) AND REF(COUNT(X_7,2)=2,1) AND REF(HIGH>REF(HIGH,1) AND CLOSE/REF(CLOSE,1)>1.023 AND CLOSE/OPEN>1.021 AND X_4,1) AND REF(CLOSE<OPEN AND HIGH<REF(HIGH,1) AND REF(CLOSE>OPEN AND COUNT(CLOSE/OPEN>1.038,8)>0,1),3) OR (REF(COUNT(CLOSE/OPEN>1.05 AND CLOSE/REF(CLOSE,1)>1.035,2)>0 AND COUNT(HIGH=CLOSE AND CLOSE/REF(CLOSE,1)>1.095,6)>0,2) AND OPEN<MA(CLOSE,5) AND CLOSE>MA(CLOSE,5) AND (LOW>REF(OPEN,1) OR (REF(CLOSE>REF(CLOSE,1),1) AND REF(HIGH=CLOSE,2))) AND REF(COUNT(OPEN/CLOSE>1.041 AND CLOSE<REF(CLOSE,1),2)>0,3) AND HIGH/OPEN>1.057 AND HIGH/CLOSE>1.015 AND CLOSE/REF(CLOSE,1)>1 AND CLOSE/OPEN>1.05 AND HIGH>REF(HIGH,1) AND REF(CLOSE/OPEN>1.025 AND X_4,1))),1) AND HIGH/REF(CLOSE,1)>1.005 AND OPEN/REF(CLOSE,1)<1;
X_54:=REF(REF(OPEN/CLOSE>1.025 AND X_5 AND REF(COUNT(HIGH=CLOSE AND CLOSE/REF(CLOSE,1)>1.095 AND REF(CLOSE>=OPEN,1),7)>0,7),1) AND REF(COUNT(HIGH/CLOSE>OPEN/LOW AND CLOSE/OPEN>1.013,2)>0 AND REF(CLOSE/OPEN>1.045,4),2) AND CLOSE>OPEN AND X_7 AND CLOSE>REF(CLOSE,1) AND (CLOSE/OPEN<REF(CLOSE/OPEN,2) OR CLOSE/OPEN<REF(CLOSE/OPEN,3)) AND HIGH/CLOSE>OPEN/LOW AND CLOSE<REF(CLOSE,2) AND HIGH<REF(HIGH,1) AND REF(HIGH,1)<REF(HIGH,2) AND MA(CLOSE,5)<MA(CLOSE,10),1) AND OPEN>REF(CLOSE,1) AND (CLOSE>MA(CLOSE,3) OR CLOSE>MA(CLOSE,5));
金神通G:REF(HIGH=CLOSE AND (CLOSE/OPEN>1.02 OR (LOW=OPEN AND CLOSE=LOW)) AND CLOSE/REF(CLOSE,1)>1.095 AND REF(CLOSE>=OPEN,1),4) AND REF(REF(CLOSE/REF(CLOSE,1)>1.04 AND X_4 AND X_7 AND CLOSE/OPEN>1.007,2) AND REF(CLOSE>=REF(CLOSE,1) AND CLOSE/OPEN>1.03,1) AND HIGH/CLOSE>1.015 AND CLOSE>=OPEN AND (CLOSE/OPEN<1.007 OR (HIGH/CLOSE>1.04 AND CLOSE/OPEN<1.02)),1) AND OPEN/REF(CLOSE,1)<1.005 AND HIGH/OPEN>1.01 AND HIGH/REF(CLOSE,1)>0.993 AND HIGH/MA(CLOSE,5)>1.005 OR X_52 OR X_53 OR X_54,COLORBLUE,LINETHICK2;

相关文章